AX6S 23.05.3 boot loop

Cycling reboot 23.05.3

HW R801
DATE 12 2023

on Laptop Dell 9550 in Putty, choose doesnt work by default 3

F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0000 0041 [0000]
G0: 0190 0000
T0: 0000 036D [000F]
Jump to BL

UNIVPLL_CON0 = 0xFE000000!!!
mt_pll_init: Set pll frequency for 25M crystal
[PMIC_WRAP]wrap_init pass,the return value=0.
[pmic_init] Preloader Start..................
[pmic_init] MT6380 CHIP Code, reg_val = 0, 1:E2  0:E3
[pmic_init] Done...................
Chip part number:7622B
MT7622 Version: 1.2.8, (iPA)
SSC OFF
mt_pll_post_init: mt_get_cpu_freq = 1350000Khz
mt_pll_post_init: mt_get_mem_freq = 1600000Khz
mt_pll_post_init: mt_get_bus_freq = 279980Khz
[PLFM] Init I2C: OK(0)

[BLDR] Build Time: 20210316-161525
==== Dump RGU Reg ========
RGU MODE:     4D
RGU LENGTH:   FFE0
RGU STA:      0
RGU INTERVAL: FFF
RGU SWSYSRST: 8000
==== Dump RGU Reg End ====
RGU: g_rgu_satus:0
 mtk_wdt_mode_config  mode value=10, tmp:22000010
PL P ON
WDT does not trigger reboot
WDT NONRST=0x20000000
WDT IRQ_EN=0x340003
RGU mtk_wdt_init:MTK_WDT_DEBUG_CTL(590200F3)
[EMI] MDL number = 2
[EMI] DRAMC calibration start

[EMI] DRAMC calibration end

[EMI]rank size auto detect
[EMI]start_addr[0x40000000]=0x12345678, test_addr[0x48000000]= 0xEDCBA987
[EMI]start_addr[0x40000000]=0xEDCBA987, test_addr[0x50000000]= 0xEDCBA987
[EMI]rank0 size: 0x10000000
[MEM] complex R/W mem test pass
RAM_CONSOLE wdt status (0x0)=0x0
mtk_snand_get_device_info
2-Recognize NAND: ID [C8 1 ], Device Name [F50L1G41LB], Page Size
[2048]B Spare Size [64]B Total Size [128]MB
[BBT] BMT.v2 is found at 0x3FF
[PLFM] Init Boot Device: OK(0)

[PART] blksz: 2048B
[PART] [0x0000000000000000-0x000000000007FFFF] "PRELOADER" (256 blocks)
[PART] [0x0000000000080000-0x00000000000BFFFF] "tee1" (128 blocks)
[PART] [0x00000000000C0000-0x000000000013FFFF] "lk" (256 blocks)

Device APC domain init setup:

Domain Setup (0x0)
Domain Setup (0x0)
Device APC domain after setup:
Domain Setup (0x0)
Domain Setup (0x0)
[PART] Image with part header
[PART] name : U-Boot
[PART] addr : 41E00000h mode : -1
[PART] size : 356728
[PART] magic: 58881688h

[PART] load "lk" from 0x00000000000C0200 (dev) to 0x41E00000 (mem) [SUCCESS]
[PART] load speed: 16588KB/s, 356728 bytes, 21ms
load lk (ret=0)
[PART] Image with part header
[PART] name : atf
[PART] addr : FFFFFFFFh mode : -1
[PART] size : 57936
[PART] magic: 58881688h

[PART] load "tee1" from 0x0000000000080200 (dev) to 0x43000DC0 (mem) [SUCCESS]
[PART] load speed: 14144KB/s, 57936 bytes, 4ms
load tee1 (ret=0)
[BLDR] bldr load tee part ret=0x0, addr=0x43001000
[BLDR] boot part. not found
[BLDR] part_load_images ret=0x0
[BLDR] Others, jump to ATF

[BLDR] jump to 0x41E00000
[BLDR] <0x41E00000>=0xEA00000F
[BLDR] <0x41E00004>=0xE59FF014


U-Boot 2014.04-rc1 (May 20 2022 - 10:19:21)

auto detection g_total_rank_size = 0x F000000
DRAM:  240 MiB
Turn on power orange!
NAND:  Recognize SNAND: ID [c8 1 ], Device Name [F50L1G41LB], Page
Size [2048]B Spare Size [64]B Total Size [128]MB
[mtk_snand] probe successfully!
[BBT] BMT.v2 is found at 0x3ff
128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   mtk_eth
Uip activated

  *** U-Boot SPI NAND ***

     1. Load firmware 0 and bootup.
     2. Load firmware 1 and bootup.
     3. Load firmware selected by Xiaoqiang and bootup.
     U-Boot console

 trigger button release!
  Press UP/DOWN to move or Press 1~3 to choose, ENTER to select
Boot failure detected on both systems
Erasing NAND...
[mtk_nand_erase_hw] mtk_nand_erase_hw @4249, ret:0x40. page:0x280
Erasing at 0x140000 -- 100% complete.
Writing to NAND... OK
Booting System 1

NAND read: device 0 offset 0x20c0000, size 0x2000
 8192 bytes read: OK
[do_read_image_blks] Image format error,neither FIT image nor old image.
Bad Magic Number.

NAND read: device 0 offset 0x20c0000, size 0x0
 0 bytes read: OK
bootm flag=0, states=70f
Wrong Image Format for bootm command
ERROR: can't get kernel image!
resetting ...
mtk_arch_reset at pre-loader!

F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0000 0041 [0000]
G0: 0190 0000
T0: 0000 036D [000F]
Jump to BL

UNIVPLL_CON0 = 0xFE000000!!!
mt_pll_init: Set pll frequency for 25M crystal
RAM_CONSOLE preloader last status: 0x0 0x0 0x0 0x0 0x0 0x0
[PMIC_WRAP]wrap_init pass,the return value=0.
[pmic_init] Preloader Start..................
[pmic_init] MT6380 CHIP Code, reg_val = 0, 1:E2  0:E3
[pmic_init] Done...................
Chip part number:7622B
MT7622 Version: 1.2.8, (iPA)
SSC OFF
mt_pll_post_init: mt_get_cpu_freq = 1350000Khz
mt_pll_post_init: mt_get_mem_freq = 1600000Khz
mt_pll_post_init: mt_get_bus_freq = 279980Khz
[PLFM] Init I2C: OK(0)

[BLDR] Build Time: 20210316-161525
==== Dump RGU Reg ========
RGU MODE:     14
RGU LENGTH:   FFE0
RGU STA:      40000000
RGU INTERVAL: FFF
RGU SWSYSRST: 8000
==== Dump RGU Reg End ====
RGU: g_rgu_satus:2
 mtk_wdt_mode_config  mode value=10, tmp:22000010
PL RGU RST: ??
SW reset with bypass power key flag
Find bypass powerkey flag
WDT NONRST=0x20000000
WDT IRQ_EN=0x340003
RGU mtk_wdt_init:MTK_WDT_DEBUG_CTL(590200F3)
[EMI] MDL number = 2
[EMI] DRAMC calibration start

[EMI] DRAMC calibration end

[EMI]rank size auto detect
[EMI]start_addr[0x40000000]=0x12345678, test_addr[0x48000000]= 0xEDCBA987
[EMI]start_addr[0x40000000]=0x12345678, test_addr[0x50000000]= 0xEDCBA987
[EMI]rank0 size: 0x10000000
[MEM] complex R/W mem test pass
RAM_CONSOLE wdt status (0x2)=0x2
mtk_snand_get_device_info
2-Recognize NAND: ID [C8 1 ], Device Name [F50L1G41LB], Page Size
[2048]B Spare Size [64]B Total Size [128]MB
[BBT] BMT.v2 is found at 0x3FF
[PLFM] Init Boot Device: OK(0)

[PART] blksz: 2048B
[PART] [0x0000000000000000-0x000000000007FFFF] "PRELOADER" (256 blocks)
[PART] [0x0000000000080000-0x00000000000BFFFF] "tee1" (128 blocks)
[PART] [0x00000000000C0000-0x000000000013FFFF] "lk" (256 blocks)

Device APC domain init setup:

Domain Setup (0x0)
Domain Setup (0x0)
Device APC domain after setup:
Domain Setup (0x0)
Domain Setup (0x0)
[PART] Image with part header
[PART] name : U-Boot
[PART] addr : 41E00000h mode : -1
[PART] size : 356728
[PART] magic: 58881688h

[PART] load "lk" from 0x00000000000C0200 (dev) to 0x41E00000 (mem) [SUCCESS]
[PART] load speed: 16588KB/s, 356728 bytes, 21ms
load lk (ret=0)
[PART] Image with part header
[PART] name : atf
[PART] addr : FFFFFFFFh mode : -1
[PART] size : 57936
[PART] magic: 58881688h

[PART] load "tee1" from 0x0000000000080200 (dev) to 0x43000DC0 (mem) [SUCCESS]
[PART] load speed: 14144KB/s, 57936 bytes, 4ms
load tee1 (ret=0)
[BLDR] bldr load tee part ret=0x0, addr=0x43001000
[BLDR] boot part. not found
[BLDR] part_load_images ret=0x0
[BLDR] Others, jump to ATF

[BLDR] jump to 0x41E00000
[BLDR] <0x41E00000>=0xEA00000F
[BLDR] <0x41E00004>=0xE59FF014


U-Boot 2014.04-rc1 (May 20 2022 - 10:19:21)

auto detection g_total_rank_size = 0x F000000
DRAM:  240 MiB
Turn on power orange!
NAND:  Recognize SNAND: ID [c8 1 ], Device Name [F50L1G41LB], Page
Size [2048]B Spare Size [64]B Total Size [128]MB
[mtk_snand] probe successfully!
[BBT] BMT.v2 is found at 0x3ff
128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   mtk_eth
Uip activated

  *** U-Boot SPI NAND ***

     1. Load firmware 0 and bootup.
     2. Load firmware 1 and bootup.
     3. Load firmware selected by Xiaoqiang and bootup.
     U-Boot console

  Hit any key to stop autoboot:  3
  Press UP/DOWN to move or Press 1~3 to choose, ENTER to select

if pressed reset

 F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0000 0041 [0000]
G0: 0190 0000
T0: 0000 036D [000F]
Jump to BL

UNIVPLL_CON0 = 0xFE000000!!!
mt_pll_init: Set pll frequency for 25M crystal
[PMIC_WRAP]wrap_init pass,the return value=0.
[pmic_init] Preloader Start..................
[pmic_init] MT6380 CHIP Code, reg_val = 0, 1:E2  0:E3
[pmic_init] Done...................
Chip part number:7622B
MT7622 Version: 1.2.8, (iPA)
SSC OFF
mt_pll_post_init: mt_get_cpu_freq = 1350000Khz
mt_pll_post_init: mt_get_mem_freq = 1600000Khz
mt_pll_post_init: mt_get_bus_freq = 279980Khz
[PLFM] Init I2C: OK(0)

[BLDR] Build Time: 20210316-161525
==== Dump RGU Reg ========
RGU MODE:     4D
RGU LENGTH:   FFE0
RGU STA:      0
RGU INTERVAL: FFF
RGU SWSYSRST: 8000
==== Dump RGU Reg End ====
RGU: g_rgu_satus:0
 mtk_wdt_mode_config  mode value=10, tmp:22000010
PL P ON
WDT does not trigger reboot
WDT NONRST=0x20000000
WDT IRQ_EN=0x340003
RGU mtk_wdt_init:MTK_WDT_DEBUG_CTL(590200F3)
[EMI] MDL number = 2
[EMI] DRAMC calibration start

[EMI] DRAMC calibration end

[EMI]rank size auto detect
[EMI]start_addr[0x40000000]=0x12345678, test_addr[0x48000000]= 0xEDCBA987
[EMI]start_addr[0x40000000]=0xEDCBA987, test_addr[0x50000000]= 0xEDCBA987
[EMI]rank0 size: 0x10000000
[MEM] complex R/W mem test pass
RAM_CONSOLE wdt status (0x0)=0x0
mtk_snand_get_device_info
2-Recognize NAND: ID [C8 1 ], Device Name [F50L1G41LB], Page Size
[2048]B Spare Size [64]B Total Size [128]MB
[BBT] BMT.v2 is found at 0x3FF
[PLFM] Init Boot Device: OK(0)

[PART] blksz: 2048B
[PART] [0x0000000000000000-0x000000000007FFFF] "PRELOADER" (256 blocks)
[PART] [0x0000000000080000-0x00000000000BFFFF] "tee1" (128 blocks)
[PART] [0x00000000000C0000-0x000000000013FFFF] "lk" (256 blocks)

Device APC domain init setup:

Domain Setup (0x0)
Domain Setup (0x0)
Device APC domain after setup:
Domain Setup (0x0)
Domain Setup (0x0)
[PART] Image with part header
[PART] name : U-Boot
[PART] addr : 41E00000h mode : -1
[PART] size : 356728
[PART] magic: 58881688h

[PART] load "lk" from 0x00000000000C0200 (dev) to 0x41E00000 (mem) [SUCCESS]
[PART] load speed: 16588KB/s, 356728 bytes, 21ms
load lk (ret=0)
[PART] Image with part header
[PART] name : atf
[PART] addr : FFFFFFFFh mode : -1
[PART] size : 57936
[PART] magic: 58881688h

[PART] load "tee1" from 0x0000000000080200 (dev) to 0x43000DC0 (mem) [SUCCESS]
[PART] load speed: 14144KB/s, 57936 bytes, 4ms
load tee1 (ret=0)
[BLDR] bldr load tee part ret=0x0, addr=0x43001000
[BLDR] boot part. not found
[BLDR] part_load_images ret=0x0
[BLDR] Others, jump to ATF

[BLDR] jump to 0x41E00000
[BLDR] <0x41E00000>=0xEA00000F
[BLDR] <0x41E00004>=0xE59FF014


U-Boot 2014.04-rc1 (May 20 2022 - 10:19:21)

auto detection g_total_rank_size = 0x F000000
DRAM:  240 MiB
Turn on power orange!
NAND:  Recognize SNAND: ID [c8 1 ], Device Name [F50L1G41LB], Page
Size [2048]B Spare Size [64]B Total Size [128]MB
[mtk_snand] probe successfully!
[BBT] BMT.v2 is found at 0x3ff
128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   mtk_eth
Uip activated

  *** U-Boot SPI NAND ***

     1. Load firmware 0 and bootup.
     2. Load firmware 1 and bootup.
     3. Load firmware selected by Xiaoqiang and bootup.
     U-Boot console

 detect button press, continue check 5 secs
 detect button pressed 5 secs !s 1~3 to choose, ENTER to select
 confirm to launch xq_upgrade !
 cmd=dhcp
ETH already turn on and power on flow will be skipped...

 Waitting for RX_DMA_BUSY status Start... done

mt7531: mt7531_sw_init
mt7531: mt7531_core_pll_setup, hwstrap = 000000ff, xtal=25MHz
mt7531: mt7531_mac_port_setup, port = 6
mt7531: mt7531_set_port_sgmii_force_mode, port = 6
mt7531: timeout waiting for SGMII_LINK
mt7531: mt7531_mac_port_setup, PMCR6 = f805633b
>>>>>>>>>>>>>>>>>>>>>>>>>>>>> START CALIBRATION:
-------- gephy-calbration (port:0) --------
CALDLY = 40
0x1e-e0 = 2929
0x1f-115 = 5
  GE Rext AnaCal Done! (9)(0x29)
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE R50 AnaCal Done! (10) (0x32)(0xb2)
 GE R50 AnaCal Done! (10) (0x32)(0xb2)
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE 1e_174(0xb1b2), 1e_175(0xb2b1)
 GE Tx offset AnaCal Done! (pair-0)(2)(0x2) 0x1e_172=0x220
 GE Tx offset AnaCal Done! (pair-1)(2)(0x21) 0x1e_172=0x221
 GE Tx offset AnaCal Done! (pair-2)(3)(0x22) 0x1e_173=0x2220
 GE Tx offset AnaCal Done! (pair-3)(3)(0x22) 0x1e_173=0x2222
 GE Tx amp AnaCal Done! (pair-0)(1e_12 = 0x6018)
 GE Tx amp AnaCal Done! (pair-1)(1e_17 = 0x2323)
 GE Tx amp AnaCal Done! (pair-2)(1e_19 = 0x222a)
 GE Tx amp AnaCal Done! (pair-3)(1e_21 = 0x272f)
PORT 0 RX_DC_OFFSET
before pairA output = 1e
after pairA output = 2
before pairB output = f
after pairB output = 0
before pairC output = 1e
after pairC output = ff
before pairD output = 1d
after pairD output = 1
-------- gephy-calbration (port:1) --------
CALDLY = 40
 GE R50 AnaCal Done! (12) (0x30)(0xb0)
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE R50 AnaCal Done! (10) (0x32)(0xb2)
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE 1e_174(0xb0b1), 1e_175(0xb2b1)
 GE Tx offset AnaCal Done! (pair-0)(3)(0x22) 0x1e_172=0x2220
 GE Tx offset AnaCal Done! (pair-1)(2)(0x21) 0x1e_172=0x2221
 GE Tx offset AnaCal Done! (pair-2)(4)(0x4) 0x1e_173=0x420
 GE Tx offset AnaCal Done! (pair-3)(3)(0x3) 0x1e_173=0x403
 GE Tx amp AnaCal Done! (pair-0)(1e_12 = 0x741d)
 GE Tx amp AnaCal Done! (pair-1)(1e_17 = 0x1a1a)
 GE Tx amp AnaCal Done! (pair-2)(1e_19 = 0x141c)
 GE Tx amp AnaCal Done! (pair-3)(1e_21 = 0x1f27)
PORT 1 RX_DC_OFFSET
before pairA output = f
after pairA output = 0
before pairB output = d
after pairB output = 2
before pairC output = 1e
after pairC output = ff
before pairD output = 1c
after pairD output = 0
-------- gephy-calbration (port:2) --------
CALDLY = 40
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE R50 AnaCal Done! (10) (0x32)(0xb2)
 GE R50 AnaCal Done! (10) (0x32)(0xb2)
 GE 1e_174(0xb1b1), 1e_175(0xb2b2)
 GE Tx offset AnaCal Done! (pair-0)(2)(0x2) 0x1e_172=0x220
 GE Tx offset AnaCal Done! (pair-1)(1)(0x1) 0x1e_172=0x201
 GE Tx offset AnaCal Done! (pair-2)(5)(0x5) 0x1e_173=0x520
 GE Tx offset AnaCal Done! (pair-3)(3)(0x22) 0x1e_173=0x522
 GE Tx amp AnaCal Done! (pair-0)(1e_12 = 0x681a)
 GE Tx amp AnaCal Done! (pair-1)(1e_17 = 0x2020)
 GE Tx amp AnaCal Done! (pair-2)(1e_19 = 0x171f)
 GE Tx amp AnaCal Done! (pair-3)(1e_21 = 0x141c)
PORT 2 RX_DC_OFFSET
before pairA output = 1e
after pairA output = 0
before pairB output = c
after pairB output = 1
before pairC output = 1e
after pairC output = ff
before pairD output = 1d
after pairD output = 1
-------- gephy-calbration (port:3) --------
CALDLY = 40
 GE R50 AnaCal Done! (12) (0x30)(0xb0)
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE R50 AnaCal Done! (11) (0x31)(0xb1)
 GE R50 AnaCal Done! (10) (0x32)(0xb2)
 GE 1e_174(0xb0b1), 1e_175(0xb1b2)
 GE Tx offset AnaCal Done! (pair-0)(1)(0x1) 0x1e_172=0x120
 GE Tx offset AnaCal Done! (pair-1)(2)(0x21) 0x1e_172=0x121
 GE Tx offset AnaCal Done! (pair-2)(1)(0x1) 0x1e_173=0x120
 GE Tx offset AnaCal Done! (pair-3)(3)(0x3) 0x1e_173=0x103
 GE Tx amp AnaCal Done! (pair-0)(1e_12 = 0x8020)
 GE Tx amp AnaCal Done! (pair-1)(1e_17 = 0x1717)
 GE Tx amp AnaCal Done! (pair-2)(1e_19 = 0x1a22)
 GE Tx amp AnaCal Done! (pair-3)(1e_21 = 0x242c)
PORT 3 RX_DC_OFFSET
before pairA output = e
after pairA output = ff
before pairB output = d
after pairB output = 0
before pairC output = f
after pairC output = ff
before pairD output = 1e
after pairD output = fe
-------- gephy-calbration (port:4) --------
CALDLY = 40
 GE R50 AnaCal Done! (9) (0x34)(0xb4)
 GE R50 AnaCal Done! (9) (0x34)(0xb4)
 GE R50 AnaCal Done! (8) (0x35)(0xb5)
 GE R50 AnaCal Done! (9) (0x34)(0xb4)
 GE 1e_174(0xb4b4), 1e_175(0xb5b4)
 GE Tx offset AnaCal Done! (pair-0)(3)(0x3) 0x1e_172=0x320
 GE Tx offset AnaCal Done! (pair-1)(2)(0x21) 0x1e_172=0x321
 GE Tx offset AnaCal Done! (pair-2)(2)(0x2) 0x1e_173=0x220
 GE Tx offset AnaCal Done! (pair-3)(3)(0x22) 0x1e_173=0x222
 GE Tx amp AnaCal Done! (pair-0)(1e_12 = 0x5014)
 GE Tx amp AnaCal Done! (pair-1)(1e_17 = 0x1212)
 GE Tx amp AnaCal Done! (pair-2)(1e_19 = 0x151d)
 GE Tx amp AnaCal Done! (pair-3)(1e_21 = 0x141c)
PORT 4 RX_DC_OFFSET
before pairA output = 1e
after pairA output = 0
before pairB output = d
after pairB output = fe
before pairC output = 1e
after pairC output = ff
before pairD output = 1d
after pairD output = 0
 0x1b000014 = 0x00110214
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5

Retry count exceeded; starting again
BOOTP broadcast 1
BOOTP broadcast 2

1 Like

How is this related to Openwrt?

Are you joke? what is it number 23.05.3

Oh, so by posting the version you just made it relevant?

Where in your 1st post does Openwrt even initiate a boot sequence?

BMW

I guess this thread is now about BMWs too ?

2 Likes

Can you provide more detail on the device running 23.05.3?

I'm unable to locate "R801" on a basic search for supported devices.

Are you saying that you selected Option 3 on the U-Boot console?

HW RB01

After writing the version
openwrt-23.05.3-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-factory.bin
it was the first firmware update from stock to OpenWRT. For this, I used XMIR:

The AX3200 stopped working after power OFF and power ON, I don't know what was the reason.

ok i can choose

  *** U-Boot SPI NAND ***

     1. Load firmware 0 and bootup.
     2. Load firmware 1 and bootup.
     3. Load firmware selected by Xiaoqiang and bootup.
     U-Boot console

I connected the wires incorrectly, but now I can select option 1.

OK, I can choose 1. Load firmware 0 and bootup.

However, the problem persists: after rebooting, option 3 is selected by default, and the router goes into a reboot loop.

I am now going to try flashing the router with the following firmware version: openwrt-23.05.3-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-sysupgrade

OpenWRT Firmware Selector Link

its my uboot config

printenv
CountryCode=(delete)
Router_unconfigured=0
SN=(delete)
arch=arm
autostart=yes
baudrate=115200
board=mt7622_evb
board_name=mt7622_evb
boot_auto=bootxq
boot_fw0=run boot_rd_img;bootm
boot_fw1=run boot_rd_img2;bootm
boot_rd_img=nand read ${loadaddr} 0x2C0000 2000;image_blks 2048;nand
read ${loadaddr} 0x2C0000 ${img_align_size}
boot_rd_img2=nand read ${loadaddr} 0x20C0000 2000;image_blks 2048;nand
read ${loadaddr} 0x20C0000 ${img_align_size}
boot_wait=on
bootargs=console=ttyS0,115200n1 loglevel=8 swiotlb=512
rootfstype=squashfs firmware=1 uart_en=1
bootdelay=3
bootmenu_0=1. Load firmware 0 and bootup.=run boot_fw0
bootmenu_1=2. Load firmware 1 and bootup.=run boot_fw1
bootmenu_2=3. Load firmware selected by Xiaoqiang and bootup.=run boot_auto
bootmenu_delay=5
color=100
cpu=armv7
ethact=mtk_eth
ethaddr=(delete)
ethaddr_wan=(delete)
fdt_high=0x6c000000
flag_boot_rootfs=1
flag_boot_success=1
flag_boot_type=2
flag_last_success=0
flag_ota_reboot=0
flag_try_sys1_failed=6
flag_try_sys2_failed=2067
invaild_env=no
ipaddr=192.168.31.1
loadaddr=0x4007FF28
miot_did=633834769
miot_key=(delete)
mode=Router
model=RB01
no_wifi_dev_times=0
nv_sys_pwd=(delete)
nv_wifi_enc=psk2
nv_wifi_enc1=psk2
nv_wifi_pwd=(delete)
nv_wifi_pwd1=(delete)
nv_wifi_ssid=Xiaomi_9908
nv_wifi_ssid1=Xiaomi_9908
restore_defaults=0
serverip=192.168.31.100
soc=mt7622
ssh_en=1
stderr=serial
stdin=serial
stdout=serial
telnet_en=1
uart_en=1
vendor=mediatek
wl0_radio=1
wl0_ssid=xiaomi-router-rb01_miap9908_5G
wl1_radio=1
wl1_ssid=xiaomi-router-rb01_miap9908

Environment size: 1741/65532 bytes

Helped is next

I change 2 field
boot_auto=run boot_fw0
bootcmd=run boot_fw0

*** U-Boot SPI NAND ***

 1. Load firmware 0 and bootup.
 2. Load firmware 1 and bootup.
 3. Load firmware selected by Xiaoqiang and bootup.
 U-Boot console

and by defaulf 3. Load firmware selected by Xiaoqiang and bootup. is loading this menu bootmenu_0=1. Load firmware 0 and bootup.=run boot_fw0

CountryCode=(delete)
Router_unconfigured=0
SN=(delete)
arch=arm
autostart=yes
baudrate=115200
board=mt7622_evb
board_name=mt7622_evb
boot_auto=run boot_fw0
boot_fw0=run boot_rd_img;bootm
boot_fw1=run boot_rd_img2;bootm
boot_rd_img=nand read ${loadaddr} 0x2C0000 2000;image_blks 2048;nand read ${loadaddr} 0x2C0000 ${img_align_size}
boot_rd_img2=nand read ${loadaddr} 0x20C0000 2000;image_blks 2048;nand read ${loadaddr} 0x20C0000 ${img_align_size}
boot_wait=on
bootargs=console=ttyS0,115200n1 loglevel=8 swiotlb=512 rootfstype=squashfs firmware=1 uart_en=1
bootcmd=run boot_fw0
bootdelay=3
bootmenu_0=1. Load firmware 0 and bootup.=run boot_fw0
bootmenu_1=2. Load firmware 1 and bootup.=run boot_fw1
bootmenu_2=3. Load firmware selected by Xiaoqiang and bootup.=run boot_auto
bootmenu_delay=5
color=100
cpu=armv7
ethact=mtk_eth
ethaddr=(delete)
ethaddr_wan=(delete)
fdt_high=0x6c000000
flag_boot_rootfs=1
flag_boot_success=1
flag_boot_type=2
flag_last_success=0
flag_ota_reboot=0
flag_try_sys1_failed=6
flag_try_sys2_failed=2071
invaild_env=no
ipaddr=192.168.31.1
loadaddr=0x4007FF28
miot_did=633834769
miot_key=7hVLpTRCfkTmUwp6
mode=Router
model=RB01
no_wifi_dev_times=0
nv_sys_pwd=(delete)
nv_wifi_enc=psk2
nv_wifi_enc1=psk2
nv_wifi_pwd=(delete)
nv_wifi_pwd1=(delete)
nv_wifi_ssid=Xiaomi_9908
nv_wifi_ssid1=Xiaomi_9908
restore_defaults=0
serverip=192.168.31.100
soc=mt7622
ssh_en=1
stderr=serial
stdin=serial
stdout=serial
telnet_en=1
uart_en=1
vendor=mediatek
wl0_radio=1
wl0_ssid=xiaomi-router-rb01_miap9908_5G
wl1_radio=1
wl1_ssid=xiaomi-router-rb01_miap9908
1 Like

https://openwrt.org/toh/xiaomi/ax3200#debricking

1 Like

How should your message help me? Do you read my previously post.

just as much as you appear to have read the link I provided.

1 Like