AX3600 problem after install OpenWrt

Now im in work , after back to home i try it ...

I download custom with add Luci like u write ..
And i download sysupgrade from normal version ...

Only 2 file i need to download? First [INITRAMFS-FACTORY.UBI] with Luci and second [SYSUPGRADE]
and i understand LuCI i have from that initrframfs file with custom download ?

i dont need KERNEL installation and FACTORY installation ?

You only need the custom sysupgrade.bin with luci added, nothing else.

Then you use that custom sysupgrade.bin to do steps 8, 9 and 10 from here:

You don't need to repeat the other steps, because you are already running openwrt snapshot (but without luci package).

Factory FW is only used to go from xiaomi factory FW to openwrt FW.

:slight_smile: I have to reinstall... after the second installation gave the same result as the first... after restoring the original firmware... I restored the Chinese rom again .. and I have to do the flashing again :slight_smile:

I have SSH access so it will be easy, I've already done it 2x :smiley: so when I get home I'll try to do it right away :slight_smile: I'll let you know the results.

So with ( I do steps 1-8 in step 9. instead of the file from the website, I upload this sysupgrade file generated in Customize installed packages ... and I should have openwrt with a web interface for management? :slight_smile:

maybe I will warn you not to ask later ... I enter the interface and login is root ? password blank ?

Yes, that's it.

After you have openwrt snapshot running with Luci, you'll want to do future sysupgrades to new snapshots.

There are 2 ways to have luci always installed:
A) The one you just did, using firmware selector, generating a custom sysupgrade img by adding luci package (if you like you can also add other packages here for it to include).


B) You can install luci-app-attendedsysupgrade package and use attended sysupgrade.
This will include the packages you are using in the image, so it will be easier/faster to use.

You can install this package from Luci software option or add it exactly like you added luci to the sysupgrade you are going to flash (.... luci luci-app-attendedsysupgrade).

Then when you want to upgrade to a new version you just need to do:

1 Like

:slight_smile: Thanks for help .. now i have other problem ... i was think opewrt its easy to use but see its hard :confused:

I have web interface but i dont know how configure wan/lan to power on Internet in router ...

I get address from dhcp i can enter LuCi login page ...

I go to Network > Interface
I configure Interface WAN but he is RED :confused:
I dont touch br-lan becasue when i change it to pppoe i lose connection to router (i make reset)

I have fiber connection ... before router i have huawei gpon ... provider of internet give me only login/password to PPPoE session ... how configure this ?

the network cable from the GPON to the WAN port is connected

EDIT: Internet i have i disable ipv6 and work now ....

now i have problem how to set internet to Radio .. i enable radio/wifi and dont have there internet

EDIT: Problem with internet in WIFI - repair

Now next problem > Wifi connect dont take dhcp address (ip)

You need to configure the country in all radios.

My suggestion is to configure wifi like this:

Use a big random key.
Also it's better that you disable the IOT radio, the antenna it's too close to the others and can interfere, but it's not mandatory to disable it.

What client doesn't get dhcp? Maybe the client has fixed IP configured.

1 Like

I have done DHCP :confused: omg its hard for newbie
i set radio for PL :slight_smile: i set WPA2-PSK .. i set password ... and what is that Ebable key reinstallation ? what that mean ?

IOT antena ? i know there is that antena but which one is it :)?

5,1Ghz or 5,7Ghz ?

The IOT radio is the QCA9887, the first one in your list.
It only has one antenna and it's reported by several users that it interferes a bit with the other radio, it will lower the other radio performance, but it's not mandatory to disable it.

The Enable Key reinstallation option, enables a counter measure against a hack called KRACK. You can google by KRACK.

In future if all you clients are compatible, you can consider to use WPA3.

1 Like

Disabled :slight_smile:

Next problem :slight_smile: what i see ... in orginal firmware i have speedtest

now only

somewhere openwrt cut speed ?

i have fiber 1gb/300mb

Yeah, that is a issue, because openwrt does't use HW acceleration and PPPoE uses more cpu than DHCP.

Try to enable these options:

  1. -> network-firewall-> enable Software flow offloading.

(Also in firewall screen I replaced all the reject options by drop.
In rules tab I disable all the rules (I don't use IPv6).
But those are not mandatory and has nothing to do with the speed issue.
You can do a port scan here and see the difference: menu->services->shieldsup! ->proceed->allserviceports).

  1. ->network-interfaces-global-> enable Packet Steering
    (this option requires a reboot to take effect)

  2. -> In system-startup-localstartup make sure you have this:

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

#assign 4 rx interrupts to each cores
echo 8 > /proc/irq/50/smp_affinity
echo 4 > /proc/irq/51/smp_affinity
echo 2 > /proc/irq/52/smp_affinity
echo 1 > /proc/irq/53/smp_affinity

#assign 3 tcl completions to 3 CPUs
echo 4 > /proc/irq/73/smp_affinity
echo 2 > /proc/irq/74/smp_affinity
echo 1 > /proc/irq/75/smp_affinity

exit 0

You need to reboot for it to take effect.

  1. -> If you still lack speed try to see if adding this line before the exit 0 above will make a difference:
    echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
    You need to reboot, these options are executed at startup.
1 Like

Ad. 1 enabled
Ad. 2 enabled
Ad. 3 i have other information there

#Put your custom commands here that should be executed once
#the system init finished. By default this file does nothing.
exit 0

and change to your version
without last option 4 :smiley: after reboot i have:

i think its correct now ?

after add line from ad. 4 i get

so i think nothing change special :slight_smile:

so i need left that line or delete ?

BTW. SQRWV you helped me a lot .. can I repay you somehow? you're not from Poland, can I send you a beer? :slight_smile:

one more question: what application/service i should install , which help me with router or help to protect router more and visit site ... for example i add now AdBlock and try configure that :slight_smile: what else do you recommend for installation?

and probably the last question: D is it possible to connect an ax3600 router containing openwrt with a phone (for management, such as MiWIFI) ???

you can install lot of things.
i use e.g
adblock for certificate
wireguard for vpn
mosquitto for iot

1 Like

It's nice to see top speed after those tweaks!

You can delete it or leave it, It will put the cpu always at max. freq., but that wont be bad, it will only consume 100 to 200 miliwatts more when cpu is idle. Temperature is not a problem in ax3600. The advantage is that the cpu wont take time (probably micro seconds) to change to higher freqs.

With that option the router will be more responsive.
I would let it on, since you have a lot of bandwidth and want to install more packages.

I'm glad I could help, no need for anything, but thanks!
Just help the next guy when you can. :slight_smile:

Depends on what we need, but some I use are:

Take your time, just a couple of days before you install/configure more packages, so you can keep track how it's working.


OFC i visit forum and try help other guys ,

now i need read about openwrt to learn them more ... and learn what application is good to make router better :slight_smile:

:beers: for u @sqrwv

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.