AX3000T - Bricked?

Hi all.

At some point I made a mistake and I think my router is bricked. I cannot access http://192.168.1.1 or ssh access. I can ping on 192.168.1.1 (15% loss) and that's it. I was trying to rollback to stock firmware on the step " Go Back to stock from Openwrt U-Boot". I run these commands "ubidetach -p /dev/mtd8; ubiformat /dev/mtd8 -y; ubiattach -p /dev/mtd8; mtd erase Nvram", router rebooted and never worked well anymore. I cannot go to internet through this router (cable or wireless). And now I have a steady blue light right after power up (about 4 seconds). No blinking or orange light, just the blue.
Any ideas?
Thanks in advance.

Try to connect the serial-to-USB and check the initial log, and TFTP flash a firmware.
If you do not have the serial-to-USB tools on hand, just try the TFTP recovery.

1 Like

Hey bro

Do you have the tftp tutorial link? I don't have the serial-to-USB hardware

Use youtube, they're all the same.
Search for router tftp recovery.

1 Like

Worked!

First, I opened tftpd and found this log:

Connection received from 192.168.1.1 on port 3599 [30/06 20:15:46.003]
Read request for file <openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-initramfs-recovery.itb>. Mode octet [30/06 20:15:46.004]
File <openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-initramfs-recovery.itb> : error 2 in system call CreateFile O sistema não pode encontrar o arquivo especificado. [30/06 20:15:46.005]

The router seemed to be looking for this file openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-initramfs-recovery.itb - I downloaded, put in the tftpd folder, started tftp, powered up the router and uploaded to the router. Router rebooted and SSH was back. I followed the debrick tutorial (point 7) but I got an error:

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r26815-b4069fad02
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# ubidetach -p /dev/mtd8
root@OpenWrt:~# ubiformat /dev/mtd8 -y -f /tmp/openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-initramfs-factory.ubi
ubiformat: mtd8 (nand), size 117440512 bytes (112.0 MiB), 896 eraseblocks of 131072 bytes (128.0 KiB), min. I/O size 2048 bytes
libscan: scanning eraseblock 895 -- 100 % complete
ubiformat: 896 eraseblocks have valid erase counter, mean value is 7
ubiformat: flashing eraseblock 62 -- 100 % complete
ubiformat: formatting eraseblock 895 -- 100 % complete
root@OpenWrt:~#
root@OpenWrt:~# reboot
root@OpenWrt:~#

After this reboot, router back to the first state and nothing happens. I cannot access via SSH or web.

Check the initial log and find what's wrong.

Where is this log? I can paste it here.

Your router serial initial log.

I don't have it. I only can access the router after the tftp process (upload file ubootmod-initramfs-recovery.itb), but just SSH.

Then, seems your BL2 is ok, I do not know how to solve this.

This means you already in openwrt SSH?

Yes. I run these commands:

root@OpenWrt:~# ubidetach -p /dev/mtd8
root@OpenWrt:~# ubiformat /dev/mtd8 -y -f /tmp/openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-initramfs-factory.ubi

Then I have to reboot. When it's rebooted, nothing happens and I have to flash initramfs-factory.ubi again to gain SSH access.

In the root@OpenWrt:~# CLI, you could check the partitions status, try cat /proc/mtd.

Yes, sure.

root@OpenWrt:~# cat /etc/openwrt_release
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='SNAPSHOT'
DISTRIB_REVISION='r26815-b4069fad02'
DISTRIB_TARGET='mediatek/filogic'
DISTRIB_ARCH='aarch64_cortex-a53'
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r26815-b4069fad02'
DISTRIB_TAINTS=''
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00100000 00020000 "BL2"
mtd1: 00040000 00020000 "Nvram"
mtd2: 00040000 00020000 "Bdata"
mtd3: 00200000 00020000 "Factory"
mtd4: 00200000 00020000 "FIP"
mtd5: 00040000 00020000 "crash"
mtd6: 00040000 00020000 "crash_log"
mtd7: 00040000 00020000 "KF"
mtd8: 07000000 00020000 "ubi"

you already in openwrt, ram mode?

Maybe do sysupgrade ..... the code is -sysupgrade.???

becareful, I do not know if it's right.

1 Like

Finally worked, not with sysupgrade from command line but somehow yes.

  1. upload itb file again (file: openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-initramfs-recovery.itb)
  2. get into "ram mode"
  3. install kmod-mtd-rw: opkg update && opkg install kmod-mtd-rw
  4. install LuCI: opkg install luci
  5. go to web interface (received a warning that all the system was running through memory and it will be deleted if I reboot)
  6. go to System → Backup/Flash firmware → Flash new firmware image → select and upload (file: openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-squashfs-sysupgrade.itb)
  7. reboot

Seems ok for now.
Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.