AVM Fritz!Repeater 3000 appears dead after FW upgrade

My AVM 3000 appears to be dead after a FW upgrade (custom 22.03 build). It didn't reconnect to the mesh after the update and got "banned" by the main AP (this happens sometimes and needs a reboot of both devices to fix). To reboot, I briefly removed power. However, since then, it appears it does not boot up any more.

After applying power, the green indicator LED lights up continuously, followed by the customizable WIFI LED (white). A few seconds afterwards, the power indicator starts to blink rapidly for about 10 seconds, then all LEDs turn off.

I've tried enabling failsafe mode by pressing the Connect button between the LEDs (which is the only button of this device), but that didn't seem to do anything. There is no reset button AFAIK so no way to do a factory reset.

I assume without a serial there is no way to debug this further?

You should be able to recover the same way you installed OpenWrt, using the ftp implementation in the bootloader.

Mhm, I've since bought a new device (still in the initrd phase since apparently my self-built initrd images are no good and the only available pre-built working with the new unit's NAND is snapshot), but while eva_ramboot.py seems to work, the old device does not request a TFTP image.

Should it request the image from the same IP address as when initially flashing OpenWRT ( If so, it appears to be broken.

So after some experimentation with the new and old device, I have been able to recover using the following steps:

  1. Revert to stock AVM firmware with their Windows-based recovery tool. The device did not respond on anymore after the recovery procedure.
  2. Run eva_discover script from YourFritz in a Ubuntu virtual machine to re-enable ramboot (the script fails with "invalid substitution" in line 422, but it triggers the "urlader" to respond on the standard IP again using some broadcast packet).
  3. Run initial eva_ramboot.py flashing procedure again.

Addendum: It looks like I can't currently build working FWs for the Fritz!Repeater anymore, not sure what changed (Docker container on macOS - the underlying hardware did change from Intel to Apple Silicon, but the build I did for the R7800 worked fine). The last build of OpenWrt 22.03-SNAPSHOT r20143-695a22ab15 done in May on the Intel works fine, OpenWrt 22.03-SNAPSHOT r20211-de29f15af1 from today clean-built on Apple Silicon today didn't.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.