AVM FRITZ!Repeater 3000/1200 - Can't use VLANs

I would like to test OpenWrt on the AVM FRITZ!Repeater 3000 (AVM FRITZ!Repeater 1200 should be similar).
I think the 3000 is very interesting because of its performance and of three radios (2x 5GHz, 1x 2.4GHz).

But I fail already during the installation, the installation is described here (FRITZ!Repeater 3000, FRITZ!Repeater 1200).

I have downloaded the following files for the AVM 3000:
wget https://downloads.openwrt.org/releases/19.07.0/targets/ipq40xx/generic/openwrt-19.07.0-ipq40xx-generic-avm_fritzrepeater-3000-initramfs-fit-uImage.itb
wget https://downloads.openwrt.org/releases/19.07.0/targets/ipq40xx/generic/openwrt-19.07.0-ipq40xx-generic-avm_fritzrepeater-3000-squashfs-sysupgrade.bin
wget https://downloads.openwrt.org/releases/19.07.0/targets/ipq40xx/generic/u-boot-fritz3000/uboot-fritz3000.bin
wget https://downloads.openwrt.org/releases/19.07.0/targets/ipq40xx/generic/u-boot-fritz3000/upload-to-f4040.sh
wget https://raw.githubusercontent.com/project-openwrt/openwrt-latest/master/scripts/flashing/eva_ramboot.py

On a pi I executed the following commands, but I can never ping 192.168.178.1, only 192.168.178.2.

root@pi1:# ip a add 192.168.178.10/255.255.255.0 dev eth0
root@pi1:# chmod 755 eva_ramboot.py
root@pi1:# ./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz3000.bin

Does anyone here have experience with the AVM FRITZ! repeater 3000/1200?

Maybe the network interface of the pi needs too long to really send and receive packets after you have connected the network cable or the power of your fritzbox.
Try to put a switch between the fritzbox and your pi so that the network interface of the pi is always up.

That should not be the problem, with an AVM Fritzbox 4040 I can find the FTP server.

pi@pi1:~ $ ping 192.168.178.1 -> Test with AVM Fritzbox 4040
PING 192.168.178.1 (192.168.178.1) 56(84) bytes of data.
64 bytes from 192.168.178.1: icmp_seq=23 ttl=250 time=0.668 ms -> ftp server
64 bytes from 192.168.178.1: icmp_seq=24 ttl=250 time=0.302 ms -> ftp server
64 bytes from 192.168.178.1: icmp_seq=25 ttl=250 time=0.305 ms -> ftp server
64 bytes from 192.168.178.1: icmp_seq=54 ttl=64 time=1040 ms -> FritzOS
64 bytes from 192.168.178.1: icmp_seq=55 ttl=64 time=0.841 ms
64 bytes from 192.168.178.1: icmp_seq=56 ttl=64 time=0.508 ms

  1. Assign yourself the IP address 192.168.178.10/24. Connect your
    Computer to one of the boxes LAN ports.

Have you tried with one and the other port?

It should but it could :wink:

So now the ping works, "ip a add" sets a static IP, but dhcp is still active for the interface. When connecting the Fritzbox, the interface still learns the default route via DHCP and is delayed a bit. If you set a static IP in /etc/dhcpcd.conf it works.

It works :slight_smile:

root@pi1:# chmod 755 eva_ramboot.py
pi@pi1:$ ./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz3000.bin
> SETENV memsize 0x00080000
< 200 SETENV command successful
> SETENV kernel_args_tmp mtdram1=0x85000000,0x88000000
< 200 SETENV command successful
> MEDIA SDRAM
< 200 Media set to MEDIA_SDRAM

Change IP
root@pi1:# cp openwrt-19.07.0-ipq40xx-generic-avm_fritzrepeater-3000-initramfs-fit-uImage.itb FRITZ3000.bin

#Install TFTP Server
# https://askubuntu.com/questions/201505/how-do-i-install-and-run-a-tftp-server



root@pi1:# cp FRITZ3000.bin /tftpboot/


root@pi1:# cat /var/log/syslog |grep tftp
Jan 17 21:35:25 pi1 xinetd[1138]: Reading included configuration file: /etc/xinetd.d/tftp [file=/etc/xinetd.d/tftp] [line=26]
Jan 17 21:35:30 pi1 tftpd[1143]: tftpd: trying to get file: FRITZ3000.bin
Jan 17 21:35:30 pi1 tftpd[1143]: tftpd: serving file from /tftpboot


root@pi1:# scp uboot-fritz3000.bin 192.168.1.1:/
uboot-fritz3000.bin    100%  512KB   3.5MB/s   00:00    

root@pi1:# scp openwrt-19.07.0-ipq40xx-generic-avm_fritzrepeater-3000-squashfs-sysupgrade.bin 192.168.1.1:/
openwrt-19.07.0-ipq40xx-generic-avm_fritzrepeater-3000-squashfs-sysupgrade.bin        100% 5410KB   3.8MB/s   00:01


root@pi1:~ # ssh 192.168.1.1
....
root@OpenWrt:~# 

root@OpenWrt:~# ls -al / |grep "\.bin"
-rw-r--r--    1 root     root       5540130 Jan  7 21:41 openwrt-19.07.0-ipq40xx-generic-avm_fritzrepeater-3000-squashfs-sysupgrade.bin
-rw-r--r--    1 root     root        524288 Jan  7 21:40 uboot-fritz3000.bin


root@OpenWrt:~# mtd write /uboot-fritz3000.bin uboot0
root@OpenWrt:~# mtd write /uboot-fritz3000.bin uboot1
root@OpenWrt:~# ubirmvol /dev/ubi0 --name=avm_filesys_0
root@OpenWrt:~# ubirmvol /dev/ubi0 --name=avm_filesys_1
root@OpenWrt:~# sysupgrade -n /openwrt-19.07.0-ipq40xx-generic-avm_fritzrepeater-3000-squashfs-sysupgrade.bin
Image not in /tmp, copying...
Commencing upgrade. Closing all shell sessions.
Connection to 192.168.1.1 closed by remote host.
Connection to 192.168.1.1 closed.


Reboot

connet to http://192.168.1.1
1 Like

Speed is good (with WPA3 and MacBook Pro)

$ iperf -c 10.x.x.x -p 5201 -t 120 -i 10
------------------------------------------------------------
Client connecting to 10.x.x.x, TCP port 5201
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 10.x.x.x port 54285 connected with 10.x.x.x port 5201
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec   606 MBytes   509 Mbits/sec
[  4] 10.0-20.0 sec   367 MBytes   308 Mbits/sec
[  4] 20.0-30.0 sec   615 MBytes   516 Mbits/sec
[  4] 30.0-40.0 sec   657 MBytes   551 Mbits/sec
[  4] 40.0-50.0 sec   646 MBytes   542 Mbits/sec
[  4] 50.0-60.0 sec   636 MBytes   534 Mbits/sec
[  4] 60.0-70.0 sec   648 MBytes   544 Mbits/sec
[  4] 70.0-80.0 sec   645 MBytes   541 Mbits/sec
[  4] 80.0-90.0 sec   626 MBytes   525 Mbits/sec
[  4] 90.0-100.0 sec   629 MBytes   528 Mbits/sec
[  4] 100.0-110.0 sec   626 MBytes   525 Mbits/sec
[  4] 110.0-120.0 sec   645 MBytes   541 Mbits/sec
[  4]  0.0-120.0 sec  7.17 GBytes   514 Mbits/sec

wlan radios:

  • radio0: 5GHz, only Channel 100-165 (In Germany these are probably not all allowed), 20/40/80/160 MHz
  • radio1: 2.4GHz
  • radio2: 5GHz, only Channel 36-64, 20/40/80 MHz

VLAN:

  • Unfortunately I can't get Vlans running on the two LAN ports (eth0.x, eth1.x [x = vlan]) yet :-/
1 Like

In the Web gui (LUCI) there is no Switch-Config (Netwok->Switch) so I guess I have to use driver-level VLANs (make a bridge interface with eth0.x and a wlan interface), but somehow that doesn't work.

But on the AVM 3000 there is also a switch (port:4 -> lan1, port:5 -> lan2). In the output you can see that VLANs are enabled on the switch ( enable_vlan: 1).
Can anyone explain this to me?

root@avm3000:~# swconfig dev switch0 show 
Global attributes:
	enable_vlan: 1
	enable_mirror_rx: 0
	enable_mirror_tx: 0
	mirror_monitor_port: 0
	mirror_source_port: 0
	linkdown: ???
Port 0:
	mib: Port 0 MIB counters
RxBroad     : 561
RxPause     : 0
RxMulti     : 53
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 467
Rx128Byte   : 1624
Rx256Byte   : 978
Rx512Byte   : 657
Rx1024Byte  : 173
Rx1518Byte  : 212
RxMaxByte   : 1134
RxTooLong   : 0
RxGoodByte  : 2688638
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 527
TxBroad     : 2217
TxPause     : 0
TxMulti     : 1284
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 7285
Tx256Byte   : 711
Tx512Byte   : 816
Tx1024Byte  : 381
Tx1518Byte  : 91
TxMaxByte   : 16
TxOverSize  : 0
TxByte      : 1352135
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 
Port 1:
	mib: Port 1 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:2 link:down
Port 3:
	mib: Port 3 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:3 link:down
Port 4:
	mib: Port 4 MIB counters
RxBroad     : 165
RxPause     : 0
RxMulti     : 3
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 123
Rx128Byte   : 2
Rx256Byte   : 43
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 15108
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 83
TxBroad     : 1
TxPause     : 0
TxMulti     : 13
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 9
Tx256Byte   : 4
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 1
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 2441
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:4 link:up speed:1000baseT full-duplex txflow rxflow auto
Port 5:
	mib: Port 5 MIB counters
RxBroad     : 2135
RxPause     : 0
RxMulti     : 1281
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 2988
Rx128Byte   : 4217
Rx256Byte   : 763
Rx512Byte   : 759
Rx1024Byte  : 381
Rx1518Byte  : 107
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 1309325
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 40
TxPause     : 0
TxMulti     : 33
TxUnderRun  : 0
Tx64Byte    : 467
Tx128Byte   : 1611
Tx256Byte   : 975
Tx512Byte   : 138
Tx1024Byte  : 178
Tx1518Byte  : 1343
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 2490431
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 2
	link: port:5 link:up speed:1000baseT full-duplex txflow rxflow auto
VLAN 1:
	vid: 1
	ports: 0t 4 
VLAN 2:
	vid: 2
	ports: 0t 5 
root@avm3000:~# 


root@avm3000:~# swconfig dev switch0 help
switch0: 90000.mdio(QCA AR40xx), ports: 6 (cpu @ 0), vlans: 128

root@avm3000:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd42:ae77:b589::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth1'

config interface 'vlan5'
	option type 'bridge'
	option proto 'dhcp'
	option defaultroute '0'
	option ifname 'eth0.5'
root@avm3000:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'DE'
	option legacy_rates '0'
	option channel '112'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option htmode 'HT20'
	option channel 'auto'
	option country 'DE'

config wifi-device 'radio2'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option channel 'auto'
	option country 'DE'
	option legacy_rates '0'
	option disabled '1'

config wifi-iface 'wifinet4'
	option ssid 'radio1.v5'
	option encryption 'psk2'
	option device 'radio1'
	option mode 'ap'
	option key 'xxx'
	option network 'vlan5'

config wifi-iface 'wifinet3'
	option ssid 'radio0.v5'
	option encryption 'sae-mixed'
	option device 'radio0'
	option mode 'ap'
	option ieee80211w '1'
	option key 'xxx'
	option network 'vlan5'

With the following modifications in the file /etc/config/network, I got vlans (vlan 5 and 20) running on interface eth1 (switchport 5) and eth0 (switchport 4) is without vlans.

Actually only the sections "config switch" and "config switch_vlan x" have to be edited via ssh in the file /etc/config/network, the interface "config interface x" can also be created via the WebGui.

Note that vlan 1 and 2 are used internally, so you should not use these vlans. The switch (type ipq40xx) is not yet supported by the WebGui (luci). The menu item (Network->Switch) is now available, but there is an error "TypeError portstate is null --- Switch switch0 has unknown topology - VLAN setings might not be accurate".

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd79:8335:d906::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan 'eth1_2'
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t'

config switch_vlan 'eth1_5'
	option device 'switch0'
	option vlan '5'
	option vid '5'
	option ports '0t 5t'

config switch_vlan 'eth1_20'
	option device 'switch0'
	option vlan '20'
	option vid '20'
	option ports '0t 5t'

config interface 'vlan5'
	option ifname 'eth1.5'
	option proto 'dhcp'

config interface 'vlan20'
	option ifname 'eth1.20'
	option proto 'dhcp'
root@OpenWrt:~# swconfig dev switch0 show
Global attributes:
	enable_vlan: 1
	enable_mirror_rx: 0
	enable_mirror_tx: 0
	mirror_monitor_port: 0
	mirror_source_port: 0
	linkdown: ???
Port 0:
	mib: Port 0 MIB counters
RxBroad     : 44
RxPause     : 0
RxMulti     : 45
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 88
Rx128Byte   : 979
Rx256Byte   : 86
Rx512Byte   : 89
Rx1024Byte  : 30
Rx1518Byte  : 158
RxMaxByte   : 502
RxTooLong   : 0
RxGoodByte  : 1151767
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 10
TxBroad     : 764
TxPause     : 0
TxMulti     : 291
TxUnderRun  : 0
Tx64Byte    : 29
Tx128Byte   : 2521
Tx256Byte   : 343
Tx512Byte   : 134
Tx1024Byte  : 194
Tx1518Byte  : 55
TxMaxByte   : 7
TxOverSize  : 0
TxByte      : 496460
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 
Port 1:
	mib: Port 1 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:2 link:down
Port 3:
	mib: Port 3 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:3 link:down
Port 4:
	mib: Port 4 MIB counters
RxBroad     : 590
RxPause     : 0
RxMulti     : 200
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 698
Rx128Byte   : 1746
Rx256Byte   : 268
Rx512Byte   : 102
Rx1024Byte  : 187
Rx1518Byte  : 60
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 454728
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 364
TxBroad     : 6
TxPause     : 0
TxMulti     : 23
TxUnderRun  : 0
Tx64Byte    : 74
Tx128Byte   : 938
Tx256Byte   : 82
Tx512Byte   : 52
Tx1024Byte  : 34
Tx1518Byte  : 659
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 1128650
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:4 link:up speed:1000baseT full-duplex txflow rxflow auto
Port 5:
	mib: Port 5 MIB counters
RxBroad     : 579
RxPause     : 0
RxMulti     : 209
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 501
Rx128Byte   : 641
Rx256Byte   : 174
Rx512Byte   : 96
Rx1024Byte  : 11
Rx1518Byte  : 2
RxMaxByte   : 2
RxTooLong   : 0
RxGoodByte  : 156188
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 831
TxBroad     : 36
TxPause     : 0
TxMulti     : 14
TxUnderRun  : 0
Tx64Byte    : 14
Tx128Byte   : 37
Tx256Byte   : 4
Tx512Byte   : 36
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 17724
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 2
	link: port:5 link:up speed:1000baseT full-duplex txflow rxflow auto
VLAN 1:
	vid: 1
	ports: 0t 4 
VLAN 2:
	vid: 2
	ports: 0t 
VLAN 5:
	vid: 5
	ports: 0t 5t 
VLAN 20:
	vid: 20
	ports: 0t 5t

Install all Updates

opkg update
opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

Install TLS for HTTPS
opkg update && opkg install luci-ssl-openssl
INFO: If you use the package "luci-ssl-nginx", the backup via WebGui will not work anymore.

Install WPA3
opkg update && opkg remove wpad-basic && opkg install wpad-openssl

Installation like this instructions work well. I have installed openwrt, but the
tests with some Clients (especially Apple HomePods) are very slow and
i get many packet loss on the wlan side. With a 2nd Accesspoint with
AVM orginal frimware everythings works fine without Problems.

Is There a working way back? With the AVM Recovery tool (both Versions 7.05
and 7.14) wont work. The tool is looking for 192.168.178.1 but the box never
start anymore with this IP when openwrt is installed.

Try to flash the "kernel.image" from the original AVM image file via sysupgrade,
after reboot box was not reachable.

I got the box back to running openwrt but found no way back to stock firmware.

Does somebody has any idea? Thanks.

The ftp server should still be reachable at 192.168.178.1 when booting the access point, so I have already done a rollback on a Fritzbox 4040.


A test confirms that the IP 192.168.178.1 is still pingable!

pi@pi1:~ $ ping 192.168.178.1
PING 192.168.178.1 (192.168.178.1) 56(84) bytes of data.
64 bytes from 192.168.178.1: icmp_seq=19 ttl=250 time=0.614 ms
64 bytes from 192.168.178.1: icmp_seq=20 ttl=250 time=0.303 ms
64 bytes from 192.168.178.1: icmp_seq=21 ttl=250 time=0.323 ms
From 192.168.178.10 icmp_seq=31 Destination Host Unreachable
From 192.168.178.10 icmp_seq=32 Destination Host Unreachable
From 192.168.178.10 icmp_seq=33 Destination Host Unreachable

So far the access point is working quite well for me. But I have not yet managed to determine which client is connected with WPA3. On the MacBook I can see WPA3, but on the iPhone and iPad I cannot determine this on the device.

With update to v19.07.1 the switch config is now also displayed in LUCI (Network->Switch) However, the following note still appears
"Switch switch0 has an unknown topology - the VLAN settings might not be accurate."
But after the update (19.07 -> 19.07.1) I had to reinstall all manually installed packages, so my wlan with wap3 did not work anymore.

Since I haven't tested the switch config over luci yet, here is my current vlan config again.
eth0 (port 4) without vlans and eth1 with vlan 20,21,22. VLAN 1 and 2 should never be configured, in the vlan config above I changed vlan 2, this caused problems.

Up to now everything runs with me otherwise without problems with several wlan devices.

root@avm3000:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd79:8335:d906::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '20'
	option ports '0t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '21'
	option ports '0t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '22'
	option ports '0t 5t'

config interface 'vlan21'
	option ifname 'eth1.21'
	option type 'bridge'
	option proto 'none'

config interface 'vlan22'
	option proto 'dhcp'
	option ifname 'eth1.22'
	option type 'bridge'

config interface 'vlan20'
	option proto 'dhcp'
	option type 'bridge'
	option ifname 'eth1.20'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.