AVM FRITZ!Box 7360 SL ADSL Annex B connnection problem

Hello,

I'm trying to set up ADSL Annex B connection with an ISP. I've tried to copy parameters from the previous router/modem running stock firmware where ADSL Annex B connection is working just fine. Unfortunately, no luck settings up ADSL Annex B connection with FRITZ!Box 7360 running stable 19.07.7 OpenWrt version.

Here's network config.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'XXXX:XXXX:XXXX::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'dsl0'
	option proto 'pppoe'
	option ipv6 '1'
	option username 'XXXXXXXXX@XXXX.XX'
	option password 'XXXXXXXXXXX'
	option mtu '1492'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

Thanks.

Not quite sure how I solved it, but I applied vectoring firmware and also used RJ 11 to RJ 45 cable since 7360 SL model has DSL RJ 45 port and then rebooted device.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.