Avm fb 7530 bridge mode help --> patch needed!

i have an r7800 (ipq806x) 22.03.5 with this network config:

HOME

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

#GLOBALS

config globals 'globals'
        option ula_prefix 'REDACTED'
        option packet_steering '1'

#LAN

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.9'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan'

#WAN

config device
        option name 'eth0'
        option macaddr 'REDACTED' --> CLONED ISP MAC

config device
        option name 'eth0.7'
        option type '8021q'
        option ifname 'eth0'
        option vid '7'
        option macaddr 'REDACTED' --> CLONED ISP MAC

config interface 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '127.0.0.1'
        option device 'eth0.7'
        option metric '10'
        option vendorid 'REDACTED' --> CLONED ISP VENDORID
#       option hostname '*'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '0::1'
        option device '@wan'
        option metric '10'

#SWITCH-VLANS

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '0t 5t'

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option vid '9'
        option ports '6t 4t 3 2 1'

connected to a tplink td-w8970 (lantiq xrx200) 22.03.5 in bridge mode with this network config:

#HOME

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

#GLOBALS

config globals 'globals'
        option ula_prefix 'REDACTED'
        option packet_steering '1'

#DSL

config dsl 'dsl'
        option annex 'b'
        option tone 'bv'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
        option ds_snr_offset '-5'

config device
        option name 'dsl0'
        option macaddr 'REDACTED' --> ORIGINAL DEVICE MAC

#LAN-LAN

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config bridge-vlan
        option device 'br-lan'
        option vlan '9'
        list ports 'lan1:t'
        list ports 'lan2'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.254'
        option device 'br-lan.9'

#WAN-MODEM --> ISP REQUIRE VLAN 100

config device
        option name 'dsl0.100'
        option type '8021q'
        option ifname 'dsl0'
        option vid '100'
        option macaddr 'REDACTED' --> ORIGINAL DEVICE MAC

config device
        option type 'bridge'
        list ports 'lan3'
        option name 'br-modem'

config bridge-vlan
        option device 'br-modem'
        option vlan '7'
        list ports 'lan3:t'
        list ports 'dsl0.100'

config interface 'modem'
        option proto 'none'
        option device 'br-modem.7'

all is working great, rock solid no problems.. r7800 gets ipv4 connectivity via dhcp and ipv6 6rd from provider. now i got my hands on an avm fb 7530 (ipq40xx) installed 23.05.0 with this network config:

#HOME

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

#GLOBALS

config globals 'globals'
        option ula_prefix 'REDACTED'
        option packet_steering '1'

#DSL

config dsl 'dsl'
        option annex 'b'
        option tone 'bv'
        option ds_snr_offset '-5'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'

config device
        option name 'dsl0'
        option macaddr 'REDACTED' --> ORIGINAL DEVICE MAC

#LAN-LAN

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan4'

config bridge-vlan
        option device 'br-lan'
        option vlan '9'
        list ports 'lan2:u'
        list ports 'lan4:t'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.254'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan.9'

#WAN-MODEM --> ISP REQUIRE VLAN 100

config device
        option name 'dsl0.100'
        option type '8021q'
        option ifname 'dsl0'
        option vid '100'
        option macaddr 'REDACTED' --> ORIGINAL DEVICE MAC

config device
        option type 'bridge'
        list ports 'lan1'
        option name 'br-modem'

config bridge-vlan
        option device 'br-modem'
        option vlan '7'
        list ports 'lan1:t'
        list ports 'dsl0.100'

config interface 'modem'
        option proto 'none'
        option device 'br-modem.7'

and r7800 can't get connectivity from the 7530 bridge.. network config is basically the same of 8970 and i really can't understand why?? i did a few factory reset just in case a re-flash checking all sha256sum, checked cables connections, no firewall involved. i'm lost.. any thoughts/ideas?

many thanks!

Did you check whether your line is up, i.e. if the DSL line is synced? Did you install the required firmware files for the 7530?
Please provide the relevant log entries from your 7530.

yes, i did follow the wiki instruction for install including the dsl firmware part. i also read the info about vlan id number 1 or 2 that can cause trouble.

dsl line is synced up showtime.

thank you.

OK. And you're trying to bridge DSL VLAN 100 to Lan 1 VLAN 7?

yes, the same config works on the tplink 8970 not on the fb 7530.

edit: i did also check that ports are not in reverse order.

thank you.

tested a snapshot image same results, bridge not working. did some research and this is the culprit:
https://patchwork.ozlabs.org/project/openwrt/patch/20230130224020.473703-1-jan@3e8.eu/
built a quick image 23.05.0 with patch included:

root@modem:~# logread | grep magic
kern.info kernel: [    0.377967] qcom-pcie 40000000.pci: Applying PCIe host magic

with config posted above all works as intended. @andyboeh thanks for your help and let's hope this gets merged soon (i have no idea how to tag developers).

edit: if someone has wiki access a link to this could be helpful.

many thanks!

1 Like

just for reference:

thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.