"available software" empty on luci if I use extroot

Hello, I have using OpenWRT for many years.
When I enabled "extroot", my "available software" list on luci will be empty, and search is not work (also empty).
But I can list / search / install any package from commandline, I can install any package if I know the name from luci.

This problem appear immediately after I prepare an usb stick for extroot. Before I make any change in it.
When I remove my usb stick and reboot, package list works again.

Now I bought another router, this problem comes again!

Even I was configured this router from zero, not using any old config files.
The old router using official release from many years ago, the new one is using an image built from git master by myself.

Is this a luci bug? or I did something wrong?


config global
    option  anon_swap       '1'
    option  anon_mount      '0'
    option  auto_swap       '1'
    option  auto_mount      '1'
    option  delay_root      '3'
    option  check_fs        '0'

config mount
    option target '/overlay'
    option options 'rw,sync'
    option enabled '1'
    option fstype 'ext4'
    option label 'EA9500'


dest root /
dest ram /tmp
#lists_dir ext /data/opkg
option overlay_root /overlay
#lists_dir ext /data/opkg

why have you done this?



It's exact same result no matter it's enabled or not

opkg's buggy that way, I'm on a hybrid ext_root, I have a old 2000v3 doing nfs-as-root,
and luci actually worked with that..
I's say look at the following, if you can't ssh and opkg list/update,etc, it won't work in luci.
There's about 64 interweve's in startup stuff and overlay just confuses the stuff.
watch the mount points from the cli.
I prefer it not saving the opkg lists anyway, it's a good indicator when messing with stuff if
it can't d/l the lists somethings wrong.
And if all else fails, send dest to /tmp and unpack the stuff. :wink: