Automount of 9p fs not working [solved - workaround]

Greetings,

I'm running lede on a x86+64 vm under kvm, I want to automount a share on the vm, the fs is 9p, I've installed block-mount and configured the entry in the ui but the automount isn't working, here is the config entry:

config mount
        option enabled '1'
        option device 'share'
        option target '/mnt/share'
        option fstype '9p'
        option options 'trans=virtio'

/mnt/share exists and I can mount it manually.
what am I doing wrong?

Thanks,

Dagg.

Did you install kmod-fs-9p?

https://openwrt.org/packages/pkgdata/kmod-fs-9p

You might need to to install libblkid
That fs detection library helps block to identify and mount more exotic file systems.

See e.g. Mounting USB: block info block detect not able to see exFAT [solved]

1 Like

Greetings,

both are installed, see:

dagg@NCC-5001-D ~/workspace/router/openwrt $ egrep "9p|blkid" .config
CONFIG_PACKAGE_kmod-fs-9p=y
CONFIG_PACKAGE_kmod-9pnet=y
CONFIG_PACKAGE_libblkid=y
# CONFIG_PACKAGE_blkid is not set

Have you set the automount option in the global fstab section?

You might simply force the mount by a manual mount command placed in /etc/rc.local that is run at the end of the boot.

Greetings,

here are more outputs:


root@router:~# mount
/dev/root on / type ext4 (rw,noatime,block_validity,delalloc,barrier,user_xattr)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
root@router:~# cat /etc/config/fstab

config global
        option anon_swap '0'
        option anon_mount '0'
        option auto_swap '1'
        option auto_mount '1'
        option delay_root '5'
        option check_fs '0'

config mount
        option target '/mnt/vda1'
        option uuid '57f8f4bc-abf4-655f-bf67-946fc0f9f25b'
        option enabled '0'

config mount
        option target '/mnt/vda2'
        option uuid '57f8f4bc-abf4-655f-bf67-946fc0f9f25b'
        option enabled '0'

config mount
        option enabled '1'
        option device 'share'
        option target '/mnt/share'
        option fstype '9p'
        option options 'trans=virtio'

manual force is a possability but I'd rather try to use the standard flow.

Auto-mounting of any filesystems not backed by local device nodes is not possible atm. So things like NFS, Samba etc. will not work.

2 Likes

thanks for the clearup, will use another method.

thanks, I've ended using this method, e.g. entered a entry in /etc/fstab and mount it at rc.local

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.