Automatically connect to saved wifi

#1

I am using a GL-AR300M-Lite in repeater mode. The wifi details of the wifi network I am trying to connect to are correctly saved. For example, from a browser, I can connect to 192.168.8.1 and click on "join" the saved network, and it works fine. However, I would like my router to connect automatically as soon as the saved network appears.

Any ideas on how to do that / why it does not connect automatically?

#2

I’d suggest either the travelmate package on “vanilla” OpenWrt or using v3 of the excellent GL.iNet firmware (effectively 18.06.1 with additional packages, last I checked).

1 Like
#3

Well, I checked and I do have the GL.iNet firmware v18.06.01. The network appeared as saved in the web interface. But it won't join if I don't click manually on "Join" (from the Repeater mode menu). Any hint welcome. Otherwise I'll try the travelmate package.

#4

I'm not sure of the sequence of events you're hoping will happen, such as when the device is powered on, what it is presently associated with (if anything), what causes the saved network to appear, if you're expecting a list of saved networks, ...

I do know that my GL.iNet AR750S running v3 firmware "just works" when I'm on travel connecting to the hotel's wireless once the network is known. Reading that the GL.iNet firmware is running on 18.06.01 may not that it is v3 as both their develop and production branches seem to have 18.06.1 as their merge base.

Perhaps if you could explain a bit more of your use case, we can help more,

#5

OK so here is the context: my GL-AR300M-Lite is at home, always switched on. My PC is always connected to it. To access the internet from my PC, I'm using my phone as hotspot (wifi): the router is a repeater (or bridge) of the hotspot.

The issue is that when I activate the hotspot on my phone, the router does not connect automatically to it. If I click "join" from the web interface, then it works: the password and SSID have been properly stored in the router.

#6

Maybe it is more clear with screencaptures:

  1. Router does not automatically connect to wifi from hotspot
#7
  1. The wifi networks are saved
#8
  1. And if I click "Join" on network "andy", it works
#9

That isn't OpenWrt pictured.

Please see:

Otherwise, I believe @jeff suggested installing plain OpenWrt:

#10

Actually, that is effectively 18.06.1 with additional packages. You’ll find all of LuCI in the Advanced settings.

That said, support of the GL.iNet UI and packages (such as the implementation of repeater modes) is best handled on the GL.iNet forums.

It doesn’t look like you have repeater mode enabled. If configuring that doesn’t resolve it, the GL.iNet forums would be the next step if you want to stick with their firmware. (One of my AR750S devices is on GL.iNet firmware.)

Edit: The AR300M-Lite is a single-Ethernet device. If your PC is plugged in to it, by default it is probably plugged into the "WAN", so you'll have to re-configure that as well. The repeater functions typically repeat the wireless over wireless and over "LAN", not WAN

1 Like
#11

I had this problem on one of my GL devices (either MT300N-v2 or AR300M16) with a v3 firmware. Using the latest testing/beta firmware version fixed it (v3.022 if I recall correctly).

3 Likes
#12

Indeed, the release note (https://dl.gl-inet.com/firmware/ar300m/testing/à includes

"v3.022-20190329

[UPDATES]
1.Optimize Repeater Auto Connection."

I'll investigate and keep you posted. Thank you all for your hints.

2 Likes
#13

That's it! Upgrading the software from v3.019 to the beta v3.022 solved the issue. I deduce that "Optimize Repeater Auto Connection" signifies "fix a bug"... Thanks again for your help.

3 Likes