Auto rollback - No "Apply Unchecked" box

Just wondering if anyone else has encountered issues with the auto rollback mechanism in LuCI since 18.06.0 release?

eg. There have been cases where I've tried to change the LAN IP address of Home Hub 5A, and after the 30 second count down, the 'Apply unchecked' dialogue box some times does not appear.

Hub is then inaccessible and requires a power cycle.

When the problem repeatedly persisted on one occasion, I end up SSH into the hub and manually editing the /etc/config/network to change the LAN IP address in frustration.

I haven't yet been able to determine what may be causing this intermittent issue. I've tried different browsers with popup blocker turned off etc.

Same symptoms as described in first post:

Is there any way to turn off auto rollback ?

Yes, the settings are in /etc/config/luci under config internal 'apply.'

That's probably best. The rollback is designed so that you don't loose connectivity. A LAN IP change would definitely make you loose connectivity to LuCI.

Are you making multiple settings changes at once?

Just making one simple change when I've encountered this intermittent issue.
eg. LAN IP address from to

I tried deleting the config internal 'apply.' section but it doesn't seem to make any difference to LuCI's behaviour. Do you know where it is documented?

Since you changed the subnet, clients cannot reach the router until they get a new IP address as well.
Did your PC pick up the new address in time? If you are using Windows with DHCP, try ipconfig /renew, disable/enable the network interface or unplug/replug the network cable to force a DHCP request.
Update: Sorry, DHCP renewal does not work here.

1 Like

Yes, I did try changing IP address on PC to be on new subnet to see if I could see the hub on new LAN IP address, but it made no difference, as hub was not visible on new IP address.

As far as I'm aware, I think the 'Apply Unchecked' dialogue box should appear 'before' the LAN IP address is forcibly changed on the hub, when it has worked.

No luck yet in finding a way to disable auto-roll back after searching github. Looks like it cannot be disabled, but I could be wrong.

Update (2 Oct 2018):
Turns out this issue happens on HH5A when WAN and LAN are configured with same subnet.
LAN (default)
WAN static IP
LAN IP address cannot be subsequently changed using LuCI under such conditions.

WAN and LAN on same subnet

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.