Auto mount usb ntfs defaults to read only

I've plugged my USB HDD formatted in NTFS to my archer c7 v2.
I want to use it as a share for everyone on the network, without credentials.

my /etc/config/fstab file looked like this:

config global
        option anon_swap '0'
        option anon_mount '1'
        option auto_swap '1'
        option auto_mount '1'
        option delay_root '5'
        option check_fs '0'

config mount
        option target '/mnt/298GB'
        option uuid '5C1A90441A901CD8'
        option enabled '1'

but when performing reboot or "block mount" it mounts it as:
/dev/sda1 on /mnt/298GB type ntfs (ro,relatime,uid=0,gid=0,fmask=0177,dmask=077,nls=default,errors=continue,mft_zone_multiplier=1)
which is read only (using ntfs and not ntfs-3g).

I can mount it properly by using:
ntfs-3g /dev/sda1 /mnt/298GB -o rw,noatime,async,big_writes
then I get:
/dev/sda1 on /mnt/298GB type fuseblk (rw,noatime,user_id=0,group_id=0,allow_other,blksize=4096)

I tried editing my fstab:

config mount '298GB'
        option target '/mnt/298GB'
        option uuid '5C1A90441A901CD8'
        option enabled '1'
        option fstype 'ntfs-3g'
        option options 'rw,noatime,async,big_writes'

but it fails and dmesg says:
[ 1877.750146] ntfs: (device sda1): parse_options(): Unrecognized mount option big_writes.
I tried without the big_writes option, and again it mounts it as ntfs, and ro.

I want to use fstab and not auto start script, because I want to mount according to uuid, since the mounted drives can change.

any help would be greatly appreciated!