Authentication Session expired problems

Had updated to master snapshot on a C7, and after getting thru the command line Luci install, I'm in a loop of a Session Expired box laid over the Authorization Required login page.

Problem is, I hit the "to login" button at the end of the "Session expired" box and it loops instantly back to the same box, not letting me do a login. Theres a red box with SessionError and details that's hidden by the Session expired box that I cant read.

Found some stuff on ubus, that I dont fully understand, seems to indicate session should time out in 5 min, that dosent seem to be happening.

About to have people wake up and get grumpy with no net! Help!

“Incognito” browser or clearing cache may help.

Tried stuff like that, no joy. Accidentally found that after the first press of go to login and warning box comeback cycle, you CAN type in the password box, despite the rest of the regular login being greyed over.

But, this either did nothing different, or the entire page goes away to be replaced by an almost empty white page with a cryptic lua error in plain text. (which I unfortunately dont have access to at the moment)


Doing the load master, ssh and opkg update and install luci dance, I wondered if for this router (C7 v3) that got me the right version? I npoticed on "latest master" (or, what's in the Snapshot link) for a C7, its June 17 or something, not daily built. Is the luci package I got via opkg update a later build, and maybe not compatable?

Got the main AP box (the C7 I'm updating the FW on) back w a factory reset, but no joy on the luci thing, and I'm enouch of a command line wimp to not do the full setup and conversion to dumb AP box that way. Whole thing greatly complicated by my having a separate x86 router box that owns, and of course do does the AP box as a brand new FW update. Much plugging of cables and lack of easy net access in the process... Maybe I rethink some address structure....

I now have the whole house back up on a travel router to prevent rioting and insurrection. So at least theyll let me live to figure out the rest.

ar71xx is dead, no further builds of snapshots any more. ath79 is the future.
Since the C7 v3 works with the v2 image: Have you tried flashing either ath79 snapshot or 19.07-snapshot?

Also rpcd has high CPUs when this occurred for me this moring. To solve, I installed the 19.07-SNAPSHOT firmware for ath79 instead.

So, was I right abt getting Luci got me a current ver package not compatible w the months old ar71 last snapshot?

Ok, but first a stupid question... wheres the link for master or 19.x.x? I see "Development Snapshot" off the main OpenWrt Downloads page...

And as I have gone back to look at it again, I think I realize whats going on. I went earlier to the ath79 dir and didnt seem to find the C7, and thought it not supported, and went back to the ath71. Now I see way down the list, there is a "tp-link" preceding "archer", which is how its been listed all this time.

So is this "master"? And 19.x.x is somewhere else? As well as master is more recent and desirable than 19.x.x?

Final newb question, sysupgrade from at71 snap or 18.06.4 for that matter, or factory upgrade?


19.01 is a joke. It’s already over 1000 commits behind master (literally). It doesn’t even have agreed scope, not to mention schedule. OpenWrt has basically never hit a six-month release cadence, so don’t hold your breath for 20.01. What was on master months ago now I’d not expect in a release for another year.

“Snapshot” builds are off master.

Not stupid, I believe it's hidden:

This morning, I installed (OpenWrt SNAPSHOT r11357-b49f2113cc / LuCI Master (git-19.301.33306-7707b67) from

All appears to have worked well.

Well, thought that the easy way out of this would be to remove the luci version I have, find the address of the luci version in the at71 directory, and voila...a working web interface to make short work out of reflashing to the current snapshot .

Except, there ISN'T a luci package in the older at71 dir! So I have to just go ahead and do a command line firmware update, a formidable (well, for me anyway) task. Grumble ...

A warning to those trying this, if you install the old at71 era snapshot and follow the suggested intstall instructions for luci, you will have a luci that wont work and you will be screwed.

So, solution, don't do what I did, just go to snapshot ath79 and you'll have a luCI that works.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.