Auth_type in (WPA3)

I've been looking at the code for hostapd in 19.07 but I can't figure out where the value auth_type is coming from:

Can someone give me a hint?


Took a few minutes to figure it out, but it comes from lib/netifd/ via the function wireless_vif_parse_encryption that is called in the functions that access auth_type (or by the functions that call the functions using auth_type).

The source is in the netifd package source, not in the main OpenWrt source:;a=blob;f=scripts/;h=6bc48c6a3f1c6cf7dc8219f189df4c31ab3cd656;hb=HEAD#l191

1 Like

I was trying to follow @est31's instructions but on 19.07:

They added append wpa_key_mgmt "SAE" to hostapd_append_wpa_key_mgmt(). I thought 19.07 would set this automatically but no. I was trying to go upstream but this comes from json_get_vars encryption. Does anyone know how to enable WPA3 on 19.07?


If you want WPA3, use the current master. There the support works ok and also LuCI supports WPA3. Discussion e.g. in Wpa3 support in OpenWrt?

The support in 19.07 is not complete. @jow has done effort in fixing things in LuCI and the supporting packages in master, but some of those fixes (e.g. for rpcd, iwinfo) have not yet been backported to 19.07.

I tried installing master but LuCI didn't work. I'm doing a talk about WPA3 at the end of the week and was hoping to have a demo. I've got 18.06 running with SAE but was hoping to get something better.

ar71xx does not work in snapshots, if you are using it.

Ah right, I'm using a Netgear WNDR3700 v1.

So is it possible to turn on WPA3 in 19.07?

Yes, just use UCI to set encryption to "sae" and everything else is handled.

Are you seeing different behaviour?

I tried editing /etc/config/wireless directly, that didn't seem to work. I'll try UCI tonight - I assume it's:
uci set wireless.@wifi-iface[0].encryption=sae

That should do it.
I've personally got mine set to "sae-mixed" for non WPA3 aware devices as well.

In that case you could use my community build for the wndr3700 series.

The master build has LuCI and has the up-to-date support for wpa3.


Thanks @hnyman that seems to be working well. It died when I tried turning on 5GHz as well so I had to factory reset and start again, but 2.4GHz seems to be working fine.

@lantis1008 the point of the demo is to setup a WPA3 network so people can see how their devices fail to connect, but thanks for the info.

1 Like