Auc error - Received inncorrect version

Is this error a known issue due the pending release of -rc4?

root@OpenWrt:~# auc
auc/0.3.2-1
Server:    https://sysupgrade.openwrt.org
Running:   23.05-SNAPSHOT r23467-9349302bca on mediatek/mt7622 (linksys,e8450-ubi)
Available: 23.05-SNAPSHOT r23484-b742216dc8
Requesting package lists...
 libopenssl-devcrypto: 3.0.11-1 -> 3.0.10-1
 iperf3: 3.15-1 -> 3.13-1
Are you sure you want to continue the upgrade process? [N/y] y
Requesting build..................Current Target: "mediatek/mt7622"
Current Architecture: "aarch64"
Current Revision: "r23485-e92cf0c46f"
Default Packages: base-files ca-bundle dropbear fstools libc libgcc libustream-mbedtls logd mtd netifd opkg uci uclient-fetch urandom-seed urngd busybox procd procd-ujail procd-seccomp kmod-leds-gpio kmod-gpio-button-hotplug kmod-mt7622-firmware wpad-basic-mbedtls uboot-envtools dnsmasq firewall4 nftables kmod-nft-offload odhcp6c odhcpd-ipv6only ppp ppp-mod-pppoe
Available Profiles:

bananapi_bpi-r64:
    Bananapi BPi-R64
    Packages: kmod-ata-ahci-mtk kmod-btmtkuart kmod-usb3 e2fsprogs mkf2fs f2fsck
    hasImageMetadata: 1
    SupportedDevices: bananapi,bpi-r64
buffalo_wsr-2533dhp2:
    Buffalo WSR-2533DHP2
    Packages: kmod-mt7615-firmware swconfig
    hasImageMetadata: 1
    SupportedDevices: buffalo,wsr-2533dhp2
elecom_wrc-2533gent:
    Elecom WRC-2533GENT
    Packages: kmod-btmtkuart kmod-mt7615-firmware kmod-usb3 swconfig
    hasImageMetadata: 1
    SupportedDevices: elecom,wrc-2533gent
elecom_wrc-x3200gst3:
    ELECOM WRC-X3200GST3
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: elecom,wrc-x3200gst3
linksys_e8450:
    Linksys E8450
    Packages: kmod-mt7915-firmware kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: linksys,e8450
linksys_e8450-ubi:
    Linksys E8450 UBI
    Packages: kmod-mt7915-firmware kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: linksys,e8450-ubi
mediatek_mt7622-rfb1:
    MediaTek MTK7622 rfb1 AP
    Packages: kmod-ata-ahci-mtk kmod-btmtkuart kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: mediatek,mt7622-rfb1
mediatek_mt7622-rfb1-ubi:
    MediaTek MTK7622 rfb1 AP (UBI)
    Packages: kmod-ata-ahci-mtk kmod-btmtkuart kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: mediatek,mt7622-rfb1-ubi
netgear_wax206:
    NETGEAR WAX206
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: netgear,wax206
ruijie_rg-ew3200gx-pro:
    Ruijie RG-EW3200GX PRO
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ruijie,rg-ew3200gx-pro
reyee_ax3200-e5:
    reyee AX3200 E5
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: reyee,ax3200-e5
totolink_a8000ru:
    TOTOLINK A8000RU
    Packages: kmod-mt7615-firmware swconfig
    hasImageMetadata: 1
    SupportedDevices: totolink,a8000ru
ubnt_unifi-6-lr-v1:
    Ubiquiti UniFi 6 LR v1
    Packages: kmod-mt7915-firmware kmod-leds-ubnt-ledbar
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v1 ubnt,unifi-6-lr
ubnt_unifi-6-lr-v1-ubootmod:
    Ubiquiti UniFi 6 LR v1 U-Boot mod
    Packages: kmod-mt7915-firmware kmod-leds-ubnt-ledbar
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v1-ubootmod ubnt,unifi-6-lr-ubootmod
ubnt_unifi-6-lr-v2:
    Ubiquiti UniFi 6 LR v2
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v2
ubnt_unifi-6-lr-v2-ubootmod:
    Ubiquiti UniFi 6 LR v2 U-Boot mod
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v2-ubootmod
ubnt_unifi-6-lr-v3:
    Ubiquiti UniFi 6 LR v3
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v3
ubnt_unifi-6-lr-v3-ubootmod:
    Ubiquiti UniFi 6 LR v3 U-Boot mod
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v3-ubootmod
xiaomi_redmi-router-ax6s:
    Xiaomi Redmi Router AX6S
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: xiaomi,redmi-router-ax6s
Error: Received inncorrect version r23485-e92cf0c46f (requested r23484-b742216dc8)
Bad message (74)
root@OpenWrt:~#

This is snapshot, how is it related to rc3 or rc4?

Seems like you started an update on snapshot but the version changed.

1 Like

I'm trying to execute again here a few hrs later with no changes on my end..

root@OpenWrt:~# auc
auc/0.3.2-1
Server:    https://sysupgrade.openwrt.org
Running:   23.05-SNAPSHOT r23467-9349302bca on mediatek/mt7622 (linksys,e8450-ubi)
Available: 23.05-SNAPSHOT r23485-e92cf0c46f
Requesting package lists...
 libopenssl-devcrypto: 3.0.11-1 -> 3.0.10-1
 iperf3: 3.15-1 -> 3.13-1
Are you sure you want to continue the upgrade process? [N/y] y
Requesting build................................................................Connection error: Connection timed out
adblock - 4.1.5-8
attendedsysupgrade-common - 8
auc - 0.3.2-1
avahi-dbus-daemon - 0.8-8
avahi-utils - 0.8-8
banip - 0.9.0-1
...

There was a change. Why didn't you post the portion of the output containing the error?

After reinstalling a new from snapshot image, auc seems to want to bring the version back..

Its never behaved like this for me before.

root@OpenWrt-mt7622:~# auc
auc/0.3.2-1
Server:    https://sysupgrade.openwrt.org
Running:   23.05-SNAPSHOT r23486-3fff625542 on mediatek/mt7622 (linksys,e8450-ubi)
Available: 23.05-SNAPSHOT r23485-e92cf0c46f
Requesting package lists...
 kmod-usb-storage: 5.15.132-1 -> 5.15.130-1
 libopenssl: 3.0.11-1 -> 3.0.10-1
 kmod-crypto-gf128: 5.15.132-1 -> 5.15.130-1
 kmod-nft-compat: 5.15.132-1 -> 5.15.130-1
 wpad-basic-mbedtls: 2023-09-08-e5ccbfc6-4 -> 2023-09-08-e5ccbfc6-3
 kmod-usb-core: 5.15.132-1 -> 5.15.130-1
 luci-app-opkg: git-23.272.64824-99559f9 -> git-23.009.82915-ec3aac4
 kmod-usb-storage-uas: 5.15.132-1 -> 5.15.130-1
..

I'm not sure if you mean that it works now; but since you won't post the relevant output at the end, it's difficult to determine. I also observed you're not really interacting, so just feel free to post that output if you still need assistance.

1 Like

I could imagine AUC being tricky with snapshots, since the packages, and their versions could, potentially, change on the daily basis.

3 Likes

I think my issue was related. Tried to update my snapshots via Luci attended sysupgrade, but the firmware building got stuck and I got a similar failure notice. Never had this before and I've been using snapshots and luci attended sysupgrade for months now.
I'll try again tonight when I'm home.

1 Like

@lleachii sorry for the slow response.

I'm not sure what the issue is, but auc is behaving like it's not using the -head openwrt-23-05 tag, which I thought was 23.05-SNAPSHOT?

image

@lamelogin - thanks for your response. Nonetheless, if you're seeking help, we need to see the full output of the command.

Please do not truncate the output - the relevant information is at the bottom.

  • 23.05-SNAPSHOT != 22.05.0-rcX
  • Your Git screenshot again omits relevant information; but I think I understood
1 Like

You also need to wait until the buildbots finish building the 23.05 snapshot for your device.

2 Likes

@lleachii, thank you for spending the time to reply.

I understand that -SNAPSHOT is not the same as the release candidate tag. I want to install the -head of the 23.05 on my device, not an older rc4 version.

I don't show the rest of the command output, because I don't want to install an older version of firmware than the device already has. in the output you'll notice the kernal module versions go from 5.15.132 to 5.15.130. I'm trying to figure out why.

As @dave14305 suggests, it may be a timing issue? I'll try again in a few days.

    23.05-SNAPSHOT != 22.05.0-rcX
    Your Git screenshot again omits relevant information; but I think I understood

It seems that a master update also goes wrong (Received inncorrect version). Notice the typo.

Pulling the master from https://firmware-selector.openwrt.org/ gives the original version back (r24054). Strange.

root@RT3200_Router:~# auc -b SNAPSHOT -B SNAPSHOT
auc/0.3.2-1
Server:    https://sysupgrade.openwrt.org
Running:   SNAPSHOT r24054-fe10f97439 on mediatek/mt7622 (linksys,e8450-ubi)
Available: SNAPSHOT r24071-b7eea2db73
Requesting package lists...
 luci-app-opkg: git-23.267.29502-3e7fe9f -> git-23.009.82915-ec3aac4
 base-files: 1542-r24054-fe10f97439 -> 1535-r24002-e3559fb445
 netifd: 2023-09-19-7a58b995-2 -> 2023-09-19-7a58b995-1
 dnsmasq: 2.89-6 -> 2.89-4
 luci-app-banip: git-23.267.29818-4c03f5f -> git-23.243.32451-737619f
 luci-app-firewall: git-23.267.29502-3e7fe9f -> git-23.212.18089-5d1e581
 luci-base: git-23.266.27574-7744ad0 -> git-23.236.53281-98e3743
Are you sure you want to continue the upgrade process? [N/y] y
Current Target: "mediatek/mt7622"
Current Architecture: "aarch64"
Current Revision: "r24072-a181b9f0f9"
Default Packages: base-files ca-bundle dropbear fstools libc libgcc libustream-mbedtls logd mtd netifd opkg uci uclient-fetch urandom-seed urngd busybox procd procd-ujail procd-seccomp kmod-leds-gpio kmod-gpio-button-hotplug kmod-mt7622-firmware wpad-basic-mbedtls uboot-envtools dnsmasq firewall4 nftables kmod-nft-offload odhcp6c odhcpd-ipv6only ppp ppp-mod-pppoe
Available Profiles:

bananapi_bpi-r64:
    Bananapi BPi-R64
    Packages: kmod-ata-ahci-mtk kmod-btmtkuart kmod-usb3 e2fsprogs mkf2fs f2fsck
    hasImageMetadata: 1
    SupportedDevices: bananapi,bpi-r64
buffalo_wsr-2533dhp2:
    Buffalo WSR-2533DHP2
    Packages: kmod-mt7615-firmware swconfig
    hasImageMetadata: 1
    SupportedDevices: buffalo,wsr-2533dhp2
buffalo_wsr-3200ax4s:
    Buffalo WSR-3200AX4S
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: buffalo,wsr-3200ax4s
elecom_wrc-2533gent:
    Elecom WRC-2533GENT
    Packages: kmod-btmtkuart kmod-mt7615-firmware kmod-usb3 swconfig
    hasImageMetadata: 1
    SupportedDevices: elecom,wrc-2533gent
elecom_wrc-x3200gst3:
    ELECOM WRC-X3200GST3
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: elecom,wrc-x3200gst3
linksys_e8450:
    Linksys E8450
    Packages: kmod-mt7915-firmware kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: linksys,e8450
linksys_e8450-ubi:
    Linksys E8450 UBI
    Packages: kmod-mt7915-firmware kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: linksys,e8450-ubi
mediatek_mt7622-rfb1:
    MediaTek MTK7622 rfb1 AP
    Packages: kmod-ata-ahci-mtk kmod-btmtkuart kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: mediatek,mt7622-rfb1
mediatek_mt7622-rfb1-ubi:
    MediaTek MTK7622 rfb1 AP (UBI)
    Packages: kmod-ata-ahci-mtk kmod-btmtkuart kmod-usb3
    hasImageMetadata: 1
    SupportedDevices: mediatek,mt7622-rfb1-ubi
netgear_wax206:
    NETGEAR WAX206
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: netgear,wax206
ruijie_rg-ew3200gx-pro:
    Ruijie RG-EW3200GX PRO
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ruijie,rg-ew3200gx-pro
reyee_ax3200-e5:
    reyee AX3200 E5
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: reyee,ax3200-e5
totolink_a8000ru:
    TOTOLINK A8000RU
    Packages: kmod-mt7615-firmware swconfig
    hasImageMetadata: 1
    SupportedDevices: totolink,a8000ru
ubnt_unifi-6-lr-v1:
    Ubiquiti UniFi 6 LR v1
    Packages: kmod-mt7915-firmware kmod-leds-ubnt-ledbar
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v1 ubnt,unifi-6-lr
ubnt_unifi-6-lr-v1-ubootmod:
    Ubiquiti UniFi 6 LR v1 U-Boot mod
    Packages: kmod-mt7915-firmware kmod-leds-ubnt-ledbar
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v1-ubootmod ubnt,unifi-6-lr-ubootmod
ubnt_unifi-6-lr-v2:
    Ubiquiti UniFi 6 LR v2
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v2
ubnt_unifi-6-lr-v2-ubootmod:
    Ubiquiti UniFi 6 LR v2 U-Boot mod
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v2-ubootmod
ubnt_unifi-6-lr-v3:
    Ubiquiti UniFi 6 LR v3
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v3
ubnt_unifi-6-lr-v3-ubootmod:
    Ubiquiti UniFi 6 LR v3 U-Boot mod
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: ubnt,unifi-6-lr-v3-ubootmod
xiaomi_redmi-router-ax6s:
    Xiaomi Redmi Router AX6S
    Packages: kmod-mt7915-firmware
    hasImageMetadata: 1
    SupportedDevices: xiaomi,redmi-router-ax6s
Error: Received inncorrect version r24072-a181b9f0f9 (requested r24071-b7eea2db73)
Bad message (74)
root@RT3200_Router:~#

1 Like

Thanks for the relevant information - this is helpful for assisting you.

Again it seems the same issue:

A suggestion was posted:

Not sure what this meant, it's understood that people generally update. Nonetheless someone else was willing to post. If you don't post needed output - just be aware it's impossible to guess or assit effectively.

1 Like

I would expect that a version becomes available for a device when the build is done.
Apparently not?

I don't understand the statement, or are you disagreeing:

It was a general remark in that I expected that uac of attendedsysupgrade would only present openwrt versions (master/snapshot/RC's/release) that are finished building and ready to download.
Like in my case I'm running master r24054. Available is master r24071. Requested is master r24071 but for some reason master r24072 is presented (which apparently is not finished building).

1 Like

Apparently still issues with snapshots for my WAX202 and WAX206, still weird that it takes so long as I haven't seen this before...

If you install luci and luci-app-attendedsysupgrade, it will allow you to install 23.0.5-SNAPSHOT r23489.

@hecatae is correct. if you use the UI it gives you a more recent version than the CLI.