Ath79 builds with all kmod packages through opkg [flow offloading]


#82

I´ve added a new build!

Changelog:

  • add build for Phicomm K2T

Download 4.14.54

Please read first post if you come from ar71xx

Greets


#83

Wow it works perfect after upgrade! Many thanks!


#84

Memory occupancy has been down a little bit with the latest build, from 71% down to 66%.


#85

Are the factory.bin files for Archer C7 v2 safe to use? (Safe to flash via stock Firmware)


#86

Going to try this on my c7 thanks.


#87

Do you mean you have more free ram with latest build?

If you have more free ram, then this would be related to the added link time optimizations to some essential packages in the last days... See the commit history...

I think it should be safe... There is nothing different on ath79 in comparison to ar71xx with the factory images. As i wrote in the first post, i do not have a c7.
If not sure or it does not work, use the tftp recovery install method.


#88

Yes it's safe to flash OpenWRT via stock firmware. I have done that without a glitch.


#89

I noticed these lines with dmesg command:

What does it mean and does it matter?


#90

This is a normal behavior. The wifi driver does search for the firmware file in your filesystem and afterwards is falling back to a user space helper script to extract it directly from a mtd raw partition (named art or something similar).
You will see this on all devices with ath10k wifi hw.


#91

When I was trying to upgrade luci-base, I got these error messages:

Configuring luci-base.
ACollected errors:
 * resolve_conffiles: Existing conffile /etc/config/luci is different from the conffile in the new package. The new conffile will be placed at /etc/config/luci-opkg.
 * resolve_conffiles: Existing conffile /etc/config/ucitrack is different from the conffile in the new package. The new conffile will be placed at /etc/config/ucitrack-opkg.

How I am supposed to fix this?


#92

This is due to some changes/updates in the luci and uci default configs on master.
Check out the changes in you own config files and the one with opkg appended and merge the needed changes manually into your config files if needed...

This errors / warnings will happen on all snapshot/master/trunk targets and not only on my build.


#93

Just experienced a weird issue with 2.4G WiFi, when I tried to connect to it, the iPhone showed me that the WiFi password is not correct, while I didn't changed it at all.

Get into LuCi and restart the 2.4G WiFi service fixed it. I wonder how this can happen, is it a bug, and anyone else have ever experienced it?

Edit: Not sure the issue has something to do with the new dynack which I am using.


#94

Could you please add the tp-link RE450v2 to your build system? It has support only for ath79


#95

I´ve added a new build!

Changelog:

  • add build for TP-Link RE450 V2

Download 4.14.54

Please read first post if you come from ar71xx

Greets


#96

How do I do to keep all settings after upgrade?


#97

If you're crossgrading from ar71xx to ath79, you better don't (at the very least /etc/config/wireless will differ and a wrong board.json might also not help). When upgrading between ath79 snapshots, just as normal.


#98

guys, i have and archer c7 v2 and i would like to test these builds.

i know it will sound silly, but just to make sure i would like to ask you:

my understanding is that i will have to

  • "sysupgrade -n -F "
    and
  • change the setting "option flow_offloading '1'" in the /etc/config/firewall.

Is there any other setting or anything else that i should to take full advantage of these builds?

thanks a lot
M


#99

You can also find flow offloading option in LuCI.


#100

ok thanks a lot
M


#101

Hey, what does "iw list" show you as "Coverage class" when dynack is enabled?
I compiled a firmware for my wzr-hp-g300nh, which is an ar71xx device, with dynack support but if I set "iw phy0 set distance auto" the "Coverage class" is still zero. It does not show any error.

Coverage class: 0 (up to 0m)

Setting "iw phy0 set distance 1" changes the "Coverage class" accordingly. Anything greater 1 has no effect.

Coverage class: 1 (up to 450m)

Where can I see if it is setup correctly without testing?