Ath79 builds with all kmod packages through opkg [flow offloading]


#62

There is also a workaround mentioned in the first post...

/etc/init.d/network reload and ubus call network reload did not work reliable...
You have to use restart instead of reload or do a reboot.

This would only occur if you change the ip of a existing interface with a ethernet device attached.


#63

Hi @juppin
Can you porting buffalo wzh-hp-ag300h for me ? It use ar7161 chipset.


#64

Sorry i´d like to have the devices by my own for debugging purposes.

Anyway the ar7161 has some problems with the pci driver...
@hnyman tried to get pcie wireless on wndr3700 (ar7161) working, but no success so far.


#65

I´ve added a new build!

Changelog:

  • new kernel version 4.14.53
  • usb leds now not swapped on TP-Link Archer C7

Download 4.14.53

Please read first post if you come from ar71xx

Greets


#66

I´ve added a new build!

Changelog:

  • new kernel version 4.14.54
  • include support for ath9k dynack

Download 4.14.54

Please read first post if you come from ar71xx

Greets


#67

Nice, gotta test dynack here. Thank you man.


#68

Is dynack about every packets, or it's just WiFi related?


#69

Thanks for the new builds.
my setup: WDR3600 @720MHz + gigabit PPPoE.
I'm experiencing low speeds, especially upload. (the fast path build is fast enough).
any further PPPoE optimizations beside "option flow_offloading 1" that i'm missing?


#70

It's ath9k wireless related. As if you've set in /etc/config/wireless distance = 'auto' instead of a fixed number, it compensates on the fly to the most optimal distance class. Really smart.


#71

Someone know how to retrieve the default distance before applying dynack?

Another question is that after applied the cmd

can it survive a reboot of the router?

Edit: I just tried to execute the command, unfortunately it gave a "Not Supported" error (-122). I am pretty sure that I have the latest build installed.

Edit2: Further question, which features dynack is relying on? I am not using any sqm when I execute the command, to be clear.


#72

You're probably trying to configure the wrong wireless device. Try phy1 or use iw list to check which is the 2.4GHz radio.


#73

Thanks. You're right, phy1 works. Sorry for the trivial questions, I'm kinda new here.


#74

Is iw phy1 set distance auto equilvalent to:

config wifi-device 'radio1'
...
option distance 'auto'

?

I ran iw phy1 set distance auto but I don't see it saving the setting to any config file in /etc/config.


#75

Same question from me. I did asked if this command can survive a reboot.


#76

I actually set it in Luci and it survived reboot, just entered auto in the field and saved, applied and rebooted, seemed to have taken effect and i can see it in /etc/config/wireless as well


#77

I don´t think so... PPPoE performance is not that good with flow offloading as with SFE (QCA hack)


#78

Thanks, that's what I did too.

So I guess two important notes for anyone who's interested in Dynack:

  1. It only works on 2.4gHz radios
  2. It doesn't seem like the prescribed command (iw phy1 set distance auto) works or is persistent; instead set it via LuCI (enter auto in the Advanced tab for Distance Optimization) or modify the /etc/config/wireless file and add option distance 'auto' under the config wifi-device settings for the 2.4gHz radio

#79

Have an Archer C7 V2 as a backup (main router now is a WRT32X)... just curious if OpenWrt 18.06 will see Ath79 officially be used on the C7, or is this further down the road? Thanks.


#80

On OpenWRT 18.06 the ath79 target does not and will never exist...


#81

Hello, can you also build for phicomm-k2t target?


This device hit market recently and only ath79 dts are submitted to the repo, so currently there's no available official image and corresponding kernel mods for the device.