Ath10k Wi-Fi 2.g band not coming up first boot and dropping during operation

How do you join ap-s to bridges? Like /etc/config/wireless and ./network

My network file is below, I have a suspicion that hotplug events from wan changes somehow disable the WI-FI?

I don't seem to have problems if i disable modem manager in startup

I did a make distclean and the WI-FI loaded on boot this time with the CT-htt drivers there is something weird going on.


config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fdf6:0e5c:4f41::/48'

config interface 'adults_lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option device 'br-adults_lan'

config interface 'kids_lan'
	option proto 'static'
	option type 'bridge'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option proto 'dhcp'
	option peerdns '0'
	option device 'wan'
	option metric '1'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'none'
	option reqprefix 'auto'
	option peerdns '0'
	option device 'wan'
	option metric '2'
	option auto '0'

config device
	option name 'br-adults_lan'
	option type 'bridge'
	list ports 'lan'

config device
	option name 'br-kids_lan'

config interface 'wwan'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option auth 'none'
	option metric '3'
	option pdptype 'ipv4'
	option auto '0'

Kids lan should be brought up empty
https://openwrt.org/docs/guide-user/network/network_configuration

It defiantly works, I have had the same setup since before the DSA changeover, I have dual DNSmasq instances and that is possibly the missing link here.
I was told conflicting information in the past where I was told it should not be a bridge but an AP and others said it should be the way I currently have it.


config dnsmasq 'adults_dns'
	option localise_queries '1'
	option rebind_protection '0'
	option local '/adults_lan/'
	option domain 'adults_lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/adults_lan/dhcp.leases'
	list interface 'adults_lan'
	option localservice '0'
	list notinterface 'kids_lan'
	option confdir '/tmp/adults_lan/dnsmasq.d'
	option quietdhcp '1'
	option filterwin2k '1'
	option allservers '1'
	list server '127.0.0.1#5054'
	list server '127.0.0.1#5053'
	option boguspriv '0'
	option doh_backup_noresolv '-1'
	option noresolv '1'
	list doh_backup_server '8.8.8.8'
	list doh_server '127.0.0.1#5054'
	list doh_server '127.0.0.1#5053'

config dnsmasq 'kids_dns'
	option localise_queries '1'
	option rebind_protection '0'
	option local '/kids_lan/'
	option domain 'kids_lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/kids_lan/dhcp.leases'
	option confdir '/tmp/kids_lan/dnsmasq.d'
	list interface 'kids_lan'
	option localservice '0'
	option quietdhcp '1'
	option filterwin2k '1'
	option allservers '1'
	list server '127.0.0.1#5054'
	list server '127.0.0.1#5053'
	option boguspriv '0'
	option doh_backup_noresolv '-1'
	option noresolv '1'
	list doh_backup_server '8.8.8.8'
	list doh_server '127.0.0.1#5054'
	list doh_server '127.0.0.1#5053'
	list notinterface 'adults_lan'
	list notinterface 'loopback'

config dhcp 'adults_lan'
	option instance 'adults_dns'
	option interface 'adults_lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option force '0'
	list dhcp_option '43,ANDROID_METERED'

config dhcp 'kids_lan'
	option instance 'kids_dns'
	option interface 'kids_lan'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option force '0'
	list dhcp_option '43,ANDROID_METERED'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config domain
	option name 'shed-link-1'
	option ip '192.168.1.30'

config domain
	option name 'shed-link-2'
	option ip '192.168.1.31'

config domain
	option name 'shed-router'
	option ip '192.168.1.40'

config domain
	option name 'power-line-1'
	option ip '192.168.1.50'

config domain
	option name 'power-line-2'
	option ip '192.168.1.51'

config domain
	option ip '192.168.1.10'
	option name 'mr-sparkle-pc'

It is racy if you dont have bridge up when wifis start.

This is what popped up at the time the WI-FI went down and came back up again.

Tue May  7 22:15:05 2024 kern.warn kernel: [167520.285527] ------------[ cut here ]------------
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.285608] WARNING: CPU: 0 PID: 0 at target-arm_cortex-a7+neon-vfpv4_musl_eabi/linux-ipq40xx_generic/ath10k-ct-regular/ath10k-ct-2023.06.05~fadd0768/ath10k-6.4/wmi.c:4031 ath10k_wmi_event_host_swba+0x69c/0x6fc [ath10k_core]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.289264] memcpy: detected field-spanning write (size 64) of single field "tim->virtual_map" at target-arm_cortex-a7+neon-vfpv4_musl_eabi/linux-ipq40xx_generic/ath10k-ct-regular/ath10k-ct-2023.06.05~fadd0768/ath10k-6.4/wmi.c:4031 (size 1)
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.309237] Modules linked in: xt_connlimit qcserial pppoe ppp_async option nf_conncount cdc_mbim ath10k_pci(O) ath10k_core(O) ath(O) xt_state xt_helper xt_conntrack xt_connmark xt_connbytes xt_CT wireguard usb_wwan sierra_net sierra qmi_wwan pppox ppp_generic nft_redir nft_nat nft_masq nft_flow_offload nft_fib_inet nft_ct nft_chain_nat nf_nat nf_flow_table_inet nf_flow_table nf_conntrack_netlink nf_conntrack_bridge nf_conntrack mac80211(O) libchacha20poly1305 ipt_REJECT huawei_cdc_ncm curve25519_neon cfg80211(O) cdc_ncm cdc_ether xt_time xt_tcpudp xt_tcpmss xt_statistic xt_recent xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY usbserial usbnet slhc sch_cake poly1305_arm nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject_bridge nft_reject nft_quota nft_numgen nft_meta_bridge nft_log nft_limit nft_hash nft_fwd_netdev nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_dup_netdev nft_compat nf_tables nf_reject_ipv4 nf_log_syslog nf_dup_netdev
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.310048]  nf_defrag_ipv6 nf_defrag_ipv4 libcurve25519_generic libcrc32c iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables hwmon crc_ccitt compat(O) chacha_neon cdc_wdm sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ipmac ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 msdos ifb ip6_udp_tunnel udp_tunnel ntfs autofs4 nls_utf8 nls_iso8859_1 nls_cp437 crypto_user algif_skcipher algif_rng algif_hash algif_aead af_alg sha512_arm ghash_arm_ce cmac usb_storage leds_gpio xhci_plat_hcd xhci_pci xhci_hcd dwc3 dwc3_qcom sd_mod scsi_mod scsi_common gpio_button_hotplug(O) vfat fat ext4
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.398159]  mbcache jbd2 exfat mii crc32c_generic
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.509567] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G           O       6.6.29 #0
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.514236] Hardware name: Generic DT based system
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.521879]  unwind_backtrace from show_stack+0x10/0x14
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.526561]  show_stack from dump_stack_lvl+0x40/0x4c
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.532115]  dump_stack_lvl from __warn+0x94/0xbc
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.537062]  __warn from warn_slowpath_fmt+0xf8/0x15c
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.541838]  warn_slowpath_fmt from ath10k_wmi_event_host_swba+0x69c/0x6fc [ath10k_core]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.547015]  ath10k_wmi_event_host_swba [ath10k_core] from ath10k_wmi_10_4_op_rx+0x458/0x594 [ath10k_core]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.555213]  ath10k_wmi_10_4_op_rx [ath10k_core] from ath10k_htc_rx_completion_handler+0x100/0x15c [ath10k_core]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.564765]  ath10k_htc_rx_completion_handler [ath10k_core] from ath10k_pci_fw_dump_work+0xee0/0xf28 [ath10k_pci]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.575205]  ath10k_pci_fw_dump_work [ath10k_pci] from ath10k_ce_per_engine_service+0x64/0x84 [ath10k_core]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.585423]  ath10k_ce_per_engine_service [ath10k_core] from ath10k_ce_per_engine_service_any+0x74/0x194 [ath10k_core]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.595408]  ath10k_ce_per_engine_service_any [ath10k_core] from ath10k_pci_napi_poll+0x44/0x150 [ath10k_pci]
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.605905]  ath10k_pci_napi_poll [ath10k_pci] from __napi_poll.constprop.0+0x2c/0x180
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.615973]  __napi_poll.constprop.0 from net_rx_action+0x140/0x2e8
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.623868]  net_rx_action from __do_softirq+0x100/0x270
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.630465]  __do_softirq from irq_exit+0x88/0xb4
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.635760]  irq_exit from call_with_stack+0x18/0x20
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.640449]  call_with_stack from __irq_svc+0x80/0x98
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.645568] Exception stack(0xc0e01f28 to 0xc0e01f70)
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.650609] 1f20:                   00000003 00000001 2221684c 40000000 00000000 c0e04f68
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.655735] 1f40: c0e08680 c0e04fa4 00000000 00000000 c0e04f08 00000000 00000017 c0e01f78
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.663978] 1f60: c0a32f78 c0a336e0 60000013 ffffffff
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.672220]  __irq_svc from default_idle_call+0x2c/0x30
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.677339]  default_idle_call from do_idle+0x1d8/0x228
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.682808]  do_idle from cpu_startup_entry+0x28/0x2c
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.688102]  cpu_startup_entry from kernel_init+0x0/0x12c
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.693051]  kernel_init from arch_post_acpi_subsys_init+0x0/0x8
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.698585] ---[ end trace 0000000000000000 ]---
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.705013] ath10k_ahb a800000.wifi: SWBA overrun on vdev 0, skipped old beacon
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.709440] ath10k_ahb a800000.wifi: SWBA overrun on vdev 1, skipped old beacon
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.717493] ath10k_ahb a000000.wifi: SWBA overrun on vdev 1, skipped old beacon
Tue May  7 22:15:05 2024 kern.warn kernel: [167520.724257] ath10k_ahb a000000.wifi: SWBA overrun on vdev 0, skipped old beacon

change to non-ct?

that did not seem to work with non ct drivers also but:

Mon May 13 11:20:43 2024 daemon.notice netifd: Network device 'Adults_2.5G' link is down
Mon May 13 11:20:43 2024 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon May 13 11:20:43 2024 daemon.notice hostapd: Adults_2.5G: CTRL-EVENT-TERMINATING
Mon May 13 11:20:43 2024 daemon.err hostapd: hostapd_free_hapd_data: Interface Adults_2.5G wasn't started
Mon May 13 11:20:43 2024 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon May 13 11:20:43 2024 daemon.notice hostapd: Kids_2.5g: CTRL-EVENT-TERMINATING
Mon May 13 11:20:43 2024 daemon.err hostapd: hostapd_free_hapd_data: Interface Kids_2.5g wasn't started
Mon May 13 11:20:43 2024 daemon.notice hostapd: hostapd.add_iface failed for phy phy0 ifname=Adults_2.5G
Mon May 13 11:20:44 2024 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Mon May 13 11:20:44 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon May 13 11:20:44 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.adults_dns - 21 names
Mon May 13 11:20:44 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.kids_dns - 14 names
Mon May 13 11:20:44 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon May 13 11:20:44 2024 daemon.err procd: Got unexpected signal 1

I captured it right when the fault happened this time:
it seemed there was conectivity loss on the Kids_lan thay is a bridge with no ports associated with it with just two WI-FI segments on it.
it seemed it lost connectivity and was unable to setup the interface again

Mon May 13 11:20:42 2024 daemon.notice netifd: Interface 'kids_lan' is now down
Mon May 13 11:20:42 2024 daemon.info avahi-daemon[4384]: Withdrawing address record for 192.168.2.1 on br-kids_lan.
Mon May 13 11:20:42 2024 daemon.info avahi-daemon[4384]: Leaving mDNS multicast group on interface br-kids_lan.IPv4 with address 192.168.2.1.
Mon May 13 11:20:42 2024 daemon.info avahi-daemon[4384]: Interface br-kids_lan.IPv4 no longer relevant for mDNS.
Mon May 13 11:20:43 2024 daemon.info ModemManager[7806]: hotplug: remove network interface Kids_2.5g: event processed
Mon May 13 11:20:43 2024 daemon.notice hostapd: nl80211: Failed to remove interface Kids_2.5g from bridge br-kids_lan: No such device
Mon May 13 11:20:43 2024 daemon.notice [4511]: <msg> [base-manager] port Kids_2.5g released by device '/sys/devices/platform/soc/a000000.wifi'
Mon May 13 11:20:43 2024 daemon.warn [4511]: <wrn> [plugin-manager] task 3,Kids_2.5g: failed: Operation was cancelled
Mon May 13 11:20:43 2024 daemon.notice netifd: Interface 'kids_lan' is disabled
Mon May 13 11:20:43 2024 daemon.notice netifd: bridge 'br-kids_lan' link is up
Mon May 13 11:20:43 2024 daemon.notice netifd: Interface 'kids_lan' has link connectivity
Mon May 13 11:20:43 2024 daemon.notice netifd: bridge 'br-kids_lan' link is down
Mon May 13 11:20:43 2024 daemon.notice netifd: Interface 'kids_lan' has link connectivity loss
Mon May 13 11:20:43 2024 user.info usteer: Found nl80211 phy on wdev hostapd.Adults_2.5G, ssid=Adults_2.5g
Mon May 13 11:20:43 2024 daemon.info ModemManager[7874]: hotplug: remove network interface br-kids_lan: event processed
Mon May 13 11:20:43 2024 user.info usteer: Connecting to local node hostapd.Adults_2.5G
Mon May 13 11:20:43 2024 user.notice firewall: Reloading firewall due to ifup of kids_lan (br-kids_lan)
Mon May 13 11:20:43 2024 daemon.err hostapd: Interface initialization failed
Mon May 13 11:20:43 2024 daemon.notice hostapd: Adults_2.5G: interface state COUNTRY_UPDATE->DISABLED
Mon May 13 11:20:43 2024 daemon.notice hostapd: Adults_2.5G: AP-DISABLED
Mon May 13 11:20:43 2024 daemon.err hostapd: Adults_2.5G: Unable to setup interface.
Mon May 13 11:20:43 2024 daemon.notice hostapd: nl80211: deinit ifname=Adults_2.5G disabled_11b_rates=0
Mon May 13 11:20:43 2024 kern.info kernel: [   70.940280] ath10k_ahb a000000.wifi Adults_2.5G: left allmulticast mode
Mon May 13 11:20:43 2024 kern.info kernel: [   70.940370] ath10k_ahb a000000.wifi Adults_2.5G: left promiscuous mode
Mon May 13 11:20:43 2024 kern.info kernel: [   70.946108] br-adults_lan: port 2(Adults_2.5G) entered disabled state
Mon May 13 11:20:43 2024 kern.info kernel: [   71.031085] ath10k_ahb a000000.wifi: mac flush null vif, drop 0 queues 0xffff
Mon May 13 11:20:43 2024 kern.warn kernel: [   71.095160] ath10k_ahb a000000.wifi: peer-unmap-event: unknown peer id 0
Mon May 13 11:20:43 2024 kern.warn kernel: [   71.095249] ath10k_ahb a000000.wifi: peer-unmap-event: unknown peer id 0
Mon May 13 11:20:43 2024 daemon.notice netifd: Network device 'Adults_2.5G' link is down
Mon May 13 11:20:43 2024 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon May 13 11:20:43 2024 daemon.notice hostapd: Adults_2.5G: CTRL-EVENT-TERMINATING
Mon May 13 11:20:43 2024 daemon.err hostapd: hostapd_free_hapd_data: Interface Adults_2.5G wasn't started
Mon May 13 11:20:43 2024 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon May 13 11:20:43 2024 daemon.notice hostapd: Kids_2.5g: CTRL-EVENT-TERMINATING
Mon May 13 11:20:43 2024 daemon.err hostapd: hostapd_free_hapd_data: Interface Kids_2.5g wasn't started
Mon May 13 11:20:43 2024 daemon.notice hostapd: hostapd.add_iface failed for phy phy0 ifname=Adults_2.5G

Add option to create bridge without ports

config device
        option name 'br-kids-lan'
        option type 'bridge'
        option bridge_empty '1'