Ath10k: the dreadful bug "deauthenticated due to inactivity (timer DEAUTH/REMOVE)"

FYI it is an iphone 11 not a 13, i corrected my post above.

Also this iphone is 30-40 ft from the access point, through several walls and one floor (it's up relative to the AP). Even with all this, it still prefers the 5 GHz band - it could connect to 2.4 if it wanted to. It would not surprise me that, with such a strained connection, the device would use more power to keep wifi connected continuously compared to "checking in" every 30 sec to a min.

But this is just my situation, yours is apparently different.

1 Like

Tried this and one of the iPhones kept disconnecting/reconnecting all night (while attached to a single SSID), so it's unrelated to that.

Having this problem, I tried changing to the non-ct version of the driver, but it made no difference. Problem persisted.

To which value should I increase it? Disable Inactivity Polling was already unchecked. I have same issue on OpenWRT 21.02.1 and Archer C7 v2, while GL-iNet GL-B1300 is rock stable (i am using both routers with 802.11r).

Mine is set to well over 8 hours, and I haven't had an issue since.

1 Like

For me looks like unchecking "Disassociate On Low Acknowledgement" fixed issue, I'll test more. Also I didn't tried to set station inactivity limit yet.

Same issue here even with Disassociate On Low Acknowledgement disabled.
It's weird because the device is not even inactive when it happens.

It looks like for me it won't work either, I will try @anon89577378 solution now.

It didn't helped for me

Tue Feb 22 14:43:40 2022 daemon.notice hostapd: wlan0: DFS-RADAR-DETECTED freq=5260 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5290 cf2=0
Tue Feb 22 14:43:40 2022 daemon.notice hostapd: dfs_downgrade_bandwidth: no DFS channels left, waiting for NOP to finish
Tue Feb 22 14:43:40 2022 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Feb 22 14:43:40 2022 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 8a:9e:60:15:32:8a
Tue Feb 22 14:43:40 2022 daemon.err hostapd: 20/40 MHz: center segment 0 (=58) and center freq 1 (=5270) not in sync
Tue Feb 22 14:43:40 2022 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Tue Feb 22 14:43:40 2022 kern.info kernel: [97317.326437] device wlan0 left promiscuous mode
Tue Feb 22 14:43:40 2022 kern.info kernel: [97317.331109] br-lan: port 2(wlan0) entered disabled state
Tue Feb 22 14:43:40 2022 daemon.notice netifd: Network device 'wlan0' link is down
Tue Feb 22 14:43:40 2022 kern.info kernel: [97317.344842] ath10k_pci 0000:00:00.0: mac flush null vif, drop 0 queues 0xffff
Tue Feb 22 14:43:40 2022 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Tue Feb 22 14:43:41 2022 kern.warn kernel: [97318.400319] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Tue Feb 22 14:43:41 2022 kern.info kernel: [97318.417636] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Tue Feb 22 14:43:41 2022 kern.info kernel: [97318.423988] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Tue Feb 22 14:43:41 2022 kern.info kernel: [97318.432154] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 24984 iram: 38672'
Tue Feb 22 14:43:41 2022 kern.warn kernel: [97318.500511] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Tue Feb 22 14:43:41 2022 kern.info kernel: [97318.515462] ath10k_pci 0000:00:00.0: rts threshold -1
Tue Feb 22 14:43:41 2022 kern.info kernel: [97318.526486] br-lan: port 2(wlan0) entered blocking state
Tue Feb 22 14:43:41 2022 kern.info kernel: [97318.531922] br-lan: port 2(wlan0) entered disabled state
Tue Feb 22 14:43:41 2022 kern.info kernel: [97318.537593] device wlan0 entered promiscuous mode
Tue Feb 22 14:43:41 2022 daemon.notice hostapd: wlan0: interface state DISABLED->COUNTRY_UPDATE
Tue Feb 22 14:43:41 2022 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Tue Feb 22 14:43:44 2022 daemon.err hostapd: could not get valid channel
Tue Feb 22 14:43:44 2022 daemon.notice hostapd: wlan0: interface state HT_SCAN->DFS

Should I open another thread?

EDIT: Downgrading to OpenWRT 19.07.9 fixed all my Wi-Fi issues.

Hi!
Just wanted to say that I experience the same error messages.

I use 2 SSIDs on 5Ghz on a Archer C6 v2.
A smartphone is connected to the 1st, and a laptop to the 2nd SSID.
When the laptop is connected, then the smartphone has a good chance of having connection issues and generating the deauthenticated-due-to-inactivity-timer messages on my router. Sometimes this can be fixed by running "wifi up" on the router, so that the Wifi is reinitialized.

I tried OpenWrt 21.02 with ath10-ct. I tried the regular firmware (qca9888-ct) as well as the alternative "htt" (qca9888-ct-htt). Unfortunately it made no difference.

Next thing on my to-do list is to try the master branch / snapshots instead of 21.02.

Same here. Does anybody knows if the issue is known by the driver/firmware developer?

I wish I had something to report, but no, I've no idea if the author(s) are acting on this.
Based on the variety and quantity of problem threads on here that have the ath10k drivers in common, it's surprising that it's still unresolved.

One other suggestion worth trying.

There is a good guide for qca wifi settings here. This is for ddwrt, so not everything in this guide is applicable to openwrt. However, check if the DTIM interval is 1 and the Beacon interval is 200 on both the 2.4GHz and 5GHz radios. If you don't have these values, try them as apparently it may help for some devices (like apple).

From the openwrt luci www GUI, both the DTIM and Beacon interval's can be found for each SSID via the "Network" menu, "Wireless" menu item. For each SSID under the "Wireless Overview" heading, chose "Edit".

"Beacon Interval" is found under the "Device Configuration" in the "Advanced Settings" tab.

"DTIM Interval" is found under "Interface Configuration" in the "Advanced Settings" tab.

Save after changing each value and don't forget to apply the saved changes. For good measure, you might want to disconnect/reconnect the problematic devices.

Don't go overboard with changing some of the settings from this guide (i.e. prim numbers for beacon interval or RTS/CTS settings until you've had a few days to evaluate any changes you've tried.

HTH

FYI

I rarely see these messages i.e. days between events with a wifi netowork up 24/7 (using ath10k-ct driver/htt firmware on a qca9980 wifi chipset).

On wifi, I've got 2 windows clients, 2 osx clients, 1 chrombook, 2 unbuntu clients, 1-2 android clients and at least 5 ios clients (at least part of the day all of them are on together).

Given the mix of complaints above as well as other ath10k users not experiencing any real issues, there are likely several causes for these messages, most are probably client or "location" related (think wifi interference) and, i suspect, none of them related to the ath10k driver or firmware.

1 Like

only for users with windows 10 devices with Intel chip set WiFi cards

both of my laptops started having problems with my EA8500's WiFi
one of the conditions described as new connections just stopped
it's worded like this due current connections would still be playing
like I'm still watching you tube & it's still played but everything else has stopped

anyway I had just updated my windows versions LTSC from 1809 to 21H2
I found I had to install an older driver to remove the problem
my "Wifi Intel AC 7260" back to V18.0.0.11
my "Wifi Intel AC 7265" back to V18.33.1.11
other problems noted was not connected after resume from sleep
backdating these drivers stoped these problems
I use "snappy driver installer" to do this easily

1 Like

Did it work ?

Unfortunately I couldn't try it (yet?) because of missing-files problems while compiling with master branch.

But I looked deeper into the source code and have no reason to believe that the situation will improve on master. There are not that many changes in the ath10k-ct version used on master, and those few changes don't really seem to relate to anything which could potentially be interesting for this problem.
ath10k-ct is updated from the 5.10 to 5.15 kernel base, but from my perspective there are no "deep enough" changes which could possibly fix this or change any behavior. I could still be wrong, but I decided its not worth to try right now.

I decided to try the regular ath10k instead. I dislike it because it's closed source, but it's actually working flawlessly for exactly 1 week now, so I'm carefully optimistic that this actually solved my problem.

Side-note:
Changing Beacon Interval and DTIM on ath10k-ct seemed to have some effect for some time. But after a day the problem re-appeared.
So it feels to me like this is (at least in my specific case) a timing-related issue which is likely (but not guranteed!) to be triggered when at least 2 clients are connected simultaneously.
Or it could be multiple problems, because it seems like everyone has slightly different variations of the core problem. Same error messages, different symptoms.

2 Likes

Unless you need to compile from source, openwrt's image builder can be used to create a sysupgrade image from the master branch without compiling from source code. Image builder takes minuets to run, can be used to "preload" packages (or files, scripts, etc) to a sysupgrade (or factory) image - potentially saving overlay space, time reinstalling packages, and time configuring after flashing a new image. I use it as much as i can when I'm not compiling from source.

(I suspect you know the following, but I'll comment with the intent of helping others that may see this)

It's my understanding that both the ath10k and ath10k-ct drivers are open source. Both the ath10k and ath10k-ct firmware are closed source. Candela apparently has an nda with QCA so they can compile their own firmware; however, they cannot share the source code. (Note you can use the ath10k (non ct) firmware with the ath10k-ct driver, but I'm not aware of anyone that does this on a regular basis)

That's what I see in this particular thread; however, if you consistently do not have an issue with the non-ct version and consistently do have an issue with the ct version, then this is a good indication of possible bug in the ct version.

I use DTIM = 1 and Beacon interval = 200 and one apple ios device will sometimes still disconnect right after a re-key event. It does not always happen after the re-key events and i don't see this for most other devices so my best guess is that this device is "sleeping." If i change my DTIM/Beacon interval, I tend to see disconnects more often.

I have still issues with non-CT drivers. What are your wireless settings? Perhaps I can change something to get wireless working again. Actually my wife complained and then I have to change something...

In my case non-CT drivers worked only with Snapshot Release. Did not tried CT again but if everything is fine I will not touch it the next time...

With Intel Wifi Cards I have to disable MIMO energy saving option on the driver and all my notebooks with Intel 7260 and also AX201 have no issues anymore. With MIMO energy savings enabled there was still connection issues.

Perhaps we could start trying old versions until a stable one is found?

1 Like