Ath10k issues - 5GHz interface not starting 18.06.2

#1

Hi,
I'm currently using a Netgear R7800-100PES.

Version: OpenWrt 18.06.2 r7676-cddd7b4c77

That's an extract from the kernel log. (last edit: initial post)

root@OpenWrt:~# dmesg | grep ath -B 5 -A 5
[   11.505977] ip_tables: (C) 2000-2006 Netfilter Core Team
[   11.515254] nf_conntrack version 0.5.0 (8192 buckets, 32768 max)
[   11.550317] xt_time: kernel timezone is -0000
[   11.571869] PPP generic driver version 2.4.2
[   11.572563] NET: Registered protocol family 24
[   11.581853] ath10k_pci 0000:01:00.0: assign IRQ: got 67
[   11.582457] ath10k_pci 0000:01:00.0: enabling device (0140 -> 0142)
[   11.582553] ath10k_pci 0000:01:00.0: enabling bus mastering
[   11.583143] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 r                                                                                                                                                             eset_mode 0
[   11.770564] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9984/                                                                                                                                                             hw1.0/firmware-6.bin failed with error -2
[   11.770612] ath10k_pci 0000:01:00.0: Falling back to user helper
[   11.801623] firmware ath10k!QCA9984!hw1.0!firmware-6.bin: firmware_loading_st                                                                                                                                                             ore: map pages failed
[   12.178933] ath10k_pci 0000:01:00.0: qca9984/qca9994 hw1.0 target 0x01000000                                                                                                                                                              chip_id 0x00000000 sub 168c:cafe
[   12.178983] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs                                                                                                                                                              1 testmode 1
[   12.192551] ath10k_pci 0000:01:00.0: firmware ver 10.4-3.5.3-00053 api 5 feat                                                                                                                                                             ures no-p2p,mfp,peer-flow-ctrl,btcoex-param,allows-mesh-bcast,no-ps crc32 4c56a3                                                                                                                                                             86
[   14.467498] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id 0:1 crc32 dd6d03                                                                                                                                                             9c
[   20.367229] ath10k_pci 0000:01:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-ca                                                                                                                                                             l-file max-sta 512 raw 0 hwcrypto 1
[   20.457953] ath: EEPROM regdomain: 0x0
[   20.457966] ath: EEPROM indicates default country code should be used
[   20.457976] ath: doing EEPROM country->regdmn map search
[   20.457994] ath: country maps to regdmn code: 0x3a
[   20.458007] ath: Country alpha2 being used: US
[   20.458017] ath: Regpair used: 0x3a
[   20.462924] ath10k_pci 0001:01:00.0: assign IRQ: got 100
[   20.464066] ath10k_pci 0001:01:00.0: enabling device (0140 -> 0142)
[   20.464199] ath10k_pci 0001:01:00.0: enabling bus mastering
[   20.464893] ath10k_pci 0001:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 r                                                                                                                                                             eset_mode 0
[   20.641684] ath10k_pci 0001:01:00.0: Direct firmware load for ath10k/QCA9984/                                                                                                                                                             hw1.0/firmware-6.bin failed with error -2
[   20.641740] ath10k_pci 0001:01:00.0: Falling back to user helper
[   20.878512] firmware ath10k!QCA9984!hw1.0!firmware-6.bin: firmware_loading_st                                                                                                                                                             ore: map pages failed
[   20.878748] ath10k_pci 0001:01:00.0: qca9984/qca9994 hw1.0 target 0x01000000                                                                                                                                                              chip_id 0x00000000 sub 168c:cafe
[   20.886473] ath10k_pci 0001:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs                                                                                                                                                              1 testmode 1
[   20.898420] ath10k_pci 0001:01:00.0: firmware ver 10.4-3.5.3-00053 api 5 feat                                                                                                                                                             ures no-p2p,mfp,peer-flow-ctrl,btcoex-param,allows-mesh-bcast,no-ps crc32 4c56a3                                                                                                                                                             86
[   23.188845] ath10k_pci 0001:01:00.0: board_file api 2 bmi_id 0:2 crc32 dd6d03                                                                                                                                                             9c
[   29.114673] ath10k_pci 0001:01:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-ca                                                                                                                                                             l-file max-sta 512 raw 0 hwcrypto 1
[   29.208223] ath: EEPROM regdomain: 0x0
[   29.208236] ath: EEPROM indicates default country code should be used
[   29.208245] ath: doing EEPROM country->regdmn map search
[   29.208263] ath: country maps to regdmn code: 0x3a
[   29.208276] ath: Country alpha2 being used: US
[   29.208286] ath: Regpair used: 0x3a
[   29.216901] kmodloader: done loading kernel modules from /etc/modules.d/*
[   33.137643] Generic PHY fixed-0:01: attached PHY driver [Generic PHY] (mii_bu                                                                                                                                                             s:phy_addr=fixed-0:01, irq=POLL)
[   33.138583] dwmac1000: Master AXI performs any burst length
[   33.146653] ipq806x-gmac-dwmac 37400000.ethernet eth1: IEEE 1588-2008 Advance                                                                                                                                                             d Timestamp supported
[   33.152066] ipq806x-gmac-dwmac 37400000.ethernet eth1: registered PTP clock
--
[   33.187689] br-lan: port 1(eth1.1) entered blocking state
[   33.187724] br-lan: port 1(eth1.1) entered disabled state
[   33.192303] device eth1.1 entered promiscuous mode
[   33.197556] device eth1 entered promiscuous mode
[   33.205289] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   33.753665] ath: EEPROM regdomain: 0x8028
[   33.753673] ath: EEPROM indicates we should expect a country code
[   33.753677] ath: doing EEPROM country->regdmn map search
[   33.753682] ath: country maps to regdmn code: 0x37
[   33.753686] ath: Country alpha2 being used: AT
[   33.753690] ath: Regpair used: 0x37
[   33.753696] ath: regdomain 0x8028 dynamically updated by user
[   33.753719] ath: EEPROM regdomain: 0x8028
[   33.753724] ath: EEPROM indicates we should expect a country code
[   33.753727] ath: doing EEPROM country->regdmn map search
[   33.753731] ath: country maps to regdmn code: 0x37
[   33.753735] ath: Country alpha2 being used: AT
[   33.753738] ath: Regpair used: 0x37
[   33.753743] ath: regdomain 0x8028 dynamically updated by user
[   34.233183] ipq806x-gmac-dwmac 37400000.ethernet eth1: Link is Up - 1Gbps/Ful                                                                                                                                                             l - flow control off
[   34.233478] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   34.241997] br-lan: port 1(eth1.1) entered blocking state
[   34.247168] br-lan: port 1(eth1.1) entered forwarding state
[   34.252786] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

Some other output: (last edit: initial post)

root@OpenWrt:~# iw phy0 info
Wiphy phy0
        max # scan SSIDs: 16
        max scan IEs length: 199 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Available Antennas: TX 0xf RX 0xf
        Configured Antennas: TX 0xf RX 0xf
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 2:
                Capabilities: 0x19ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-31
                VHT Capabilities (0x339b79fa):
                        Max MPDU length: 11454
                        Supported Channel Width: 160 MHz, 80+80 MHz
                        RX LDPC
                        short GI (80 MHz)
                        short GI (160/80+80 MHz)
                        TX STBC
                        SU Beamformer
                        SU Beamformee
                        MU Beamformer
                        MU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: MCS 0-9
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 1560 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: MCS 0-9
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 1560 Mbps
                Frequencies:
                        * 5180 MHz [36] (20.0 dBm)
                        * 5200 MHz [40] (20.0 dBm)
                        * 5220 MHz [44] (20.0 dBm)
                        * 5240 MHz [48] (20.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                        * 5500 MHz [100] (27.0 dBm) (radar detection)
                        * 5520 MHz [104] (27.0 dBm) (radar detection)
                        * 5540 MHz [108] (27.0 dBm) (radar detection)
                        * 5560 MHz [112] (27.0 dBm) (radar detection)
                        * 5580 MHz [116] (27.0 dBm) (radar detection)
                        * 5600 MHz [120] (27.0 dBm) (radar detection)
                        * 5620 MHz [124] (27.0 dBm) (radar detection)
                        * 5640 MHz [128] (27.0 dBm) (radar detection)
                        * 5660 MHz [132] (27.0 dBm) (radar detection)
                        * 5680 MHz [136] (27.0 dBm) (radar detection)
                        * 5700 MHz [140] (27.0 dBm) (radar detection)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (disabled)
                        * 5765 MHz [153] (disabled)
                        * 5785 MHz [157] (disabled)
                        * 5805 MHz [161] (disabled)
                        * 5825 MHz [165] (disabled)
                        * 5845 MHz [169] (disabled)
        valid interface combinations:
                 * #{ managed } <= 1, #{ AP, mesh point } <= 16,
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Device supports VHT-IBSS.

config file (only partial) (last edit: 27/02/2019 5:59 pm CET)

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'AT'
        option legacy_rates '0'
        option disabled '0'
        option channel '40'
        option htmode 'VHT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option key 'xxx'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option encryption 'psk2'

System log (last edit: 27/02/2019 5:59 pm CET)

Wed Feb 27 17:48:14 2019 daemon.info dnsmasq-dhcp[1329]: read /etc/ethers - 0 addresses
Wed Feb 27 17:48:57 2019 daemon.notice netifd: radio0 (13111): command failed: Not supported (-95)
Wed Feb 27 17:48:57 2019 daemon.notice netifd: radio0 (13111): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Wed Feb 27 17:48:57 2019 daemon.notice netifd: radio0 (13111): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path ()
Wed Feb 27 17:48:57 2019 daemon.notice netifd: radio0 (13111): Command failed: Invalid argument
Wed Feb 27 17:48:57 2019 daemon.notice netifd: radio0 (13111): Device setup failed: HOSTAPD_START_FAILED

It's quite weird. This worked fine on 17.X. Do you know anything I can to in order do toubleshoot/fix this?

Regards
Elys

0 Likes

#2

Snapshot? Release?

(There was a change to the CT drivers recently on master)

1 Like

#3

Thanks for your answer. Added this information to the main post.

1 Like

#4

Try setting a non-DFS channel and 20 MHz bandwidth. In other words, crawl before you try to run.

AP mode with DFS may not be supported.

When width > 20 MHz not all the channel numbers are settable, since the signal occupies more than one channel width.

Run wifi to restart wireless then check log for any errors.

2 Likes

#5

Try without wds.
Like mk24 said, as basic settings as possible.

There has been a wds fix today on master, but I am not sure if that bug has been in 18.06.2

Ps. You showed only the early kernel log regarding radio initialisation, but not the system log when the interface tries to come up.

Do "wifi up" and copy the relevant system log items from that period.

1 Like

#6

Thanks for your help!
I've added the system log to the main post and updated /etc/config/wireless there as well.

0 Likes

#7

The error message seems somewhat similar that happens if you try enabling features that are not supported by the current wpad variant.

You still have ieee80211w enabled.
Are you sure that you installed the full wpad?
or are you using the default wpad-mini? (which doesn't support 80211w, I think)

Yeah, similar error message in an old ticket for you:
https://dev.archive.openwrt.org/ticket/20179.html

1 Like

#8
root@OpenWrt:~# iw dev
phy#1
        Interface wlan1
                ifindex 6
                wdev 0x100000001
                addr xxx
                type managed
                txpower 0.00 dBm
phy#0
        Interface wlan0
                ifindex 6854
                wdev 0x1abf
                addr xxx
                ssid OpenWrt
                type AP
                channel 40 (5200 MHz), width: 20 MHz, center1: 5200 MHz
                txpower 20.00 dBm

Well, ok I forgot to disable that in the config file!

It's "working" now.

hostapd-common and wpad-mini were pre-installed.

Then I tried this using wpad / hostapd which produced more or less the same error

Wed Feb 27 18:26:57 2019 daemon.notice netifd: radio0 (4854): command failed: Not supported (-95)
Wed Feb 27 18:26:57 2019 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Wed Feb 27 18:26:58 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Wed Feb 27 18:27:04 2019 kern.info kernel: [  246.162608] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Wed Feb 27 18:27:04 2019 kern.info kernel: [  246.168913] br-lan: port 2(wlan0) entered blocking state
Wed Feb 27 18:27:04 2019 kern.info kernel: [  246.168992] br-lan: port 2(wlan0) entered disabled state
Wed Feb 27 18:27:04 2019 kern.info kernel: [  246.173879] device wlan0 entered promiscuous mode
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: interface state HT_SCAN->DFS
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: DFS-CAC-START freq=5500 chan=100 sec_chan=1, width=2, seg0=114, seg1=0, cac_time=60s
Wed Feb 27 18:27:04 2019 daemon.err hostapd: DFS start_dfs_cac() failed, -1
Wed Feb 27 18:27:04 2019 daemon.err hostapd: Interface initialization failed
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: interface state DFS->DISABLED
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: AP-DISABLED
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: AP-DISABLED
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Wed Feb 27 18:27:04 2019 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Wed Feb 27 18:27:04 2019 kern.info kernel: [  246.527772] device wlan0 left promiscuous mode
Wed Feb 27 18:27:04 2019 kern.info kernel: [  246.527906] br-lan: port 2(wlan0) entered disabled state
Wed Feb 27 18:27:04 2019 kern.warn kernel: [  246.532430] ath10k_pci 0000:01:00.0: peer-unmap-event: unknown peer id 1
Wed Feb 27 18:27:04 2019 daemon.notice hostapd: ELOOP: remaining socket: sock=21 eloop_data=0xb6f4eaa0 user_data=0 handler=0x42314
Wed Feb 27 18:27:04 2019 daemon.notice netifd: radio0 (4854): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Wed Feb 27 18:27:04 2019 daemon.notice netifd: radio0 (4854): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path ()
Wed Feb 27 18:27:04 2019 daemon.notice netifd: radio0 (4854): Command failed: Invalid argument
Wed Feb 27 18:27:10 2019 kern.info kernel: [  252.754435] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Wed Feb 27 18:27:10 2019 kern.info kernel: [  252.798605] br-lan: port 2(wlan0) entered blocking state
Wed Feb 27 18:27:10 2019 kern.info kernel: [  252.798629] br-lan: port 2(wlan0) entered disabled state
Wed Feb 27 18:27:10 2019 kern.info kernel: [  252.803144] device wlan0 entered promiscuous mode
0 Likes

#9

You might try wpad-basic (current default for most targets) or wpad to see if that resolves your issues.

0 Likes

#10

I just did that.

1 Like

#11

Your config above says "channel 40" and it worked(????), but then in the next system log extract you have apparently changed to a DFS channel100 (=5500 MHz), where the error message clearly complains about DFS...

Just stick to the non-DFS channels like 36, and see if that works.

https://www.google.com/search?q=dfs+problem+5ghz

1 Like

#12

I tested a lot of configurations (and I'm currently using hostapd)

"worked" was intended to mean that this specific configuration works fine but hasn't solved my problem yet.

Yes: this configuration works fine with wpad-mini / wpad / hostapd

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'AT'
        option legacy_rates '0'
        option disabled '0'
        option channel '40'
        option htmode 'VHT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option key 'xxx'
        option wpa_disable_eapol_key_retries '1'
        option encryption 'psk2'

Trust me on this I've already searched up a lot on this for several days and was quite active on the IRC.

0 Likes

#13

Well I'll submit an issue concerning this topic. (And link it later)
Subband 1 is definitely not an option for my location due to the poor SNR.

Edit:

Issue: https://bugs.openwrt.org/index.php?do=details&task_id=2154

0 Likes

#14

I'm testing your builds now @hnyman

0 Likes

#15

There is nothing special for wifi in my builds, so that will not help you. Trying to use DFS channels is not easy. You may even need to fall back to HT20.

0 Likes

#16

This is quite weird ... some users reported on your R7800 build thread that this is working for them and for me it's not. There are different regional hardware revisions but I don't think they differ that much.
I'm currently testing the r9497 SNAPSHOT.

0 Likes