ATA and Apple TV lose connection thru switch

I setup a Linksys E8450 router and utilized a Linksys SE3008 switch (unmanaged) to get all my gear connected. On the switch I had an Apple TV and ATA for phones. The ATA and Apple TV kept losing Internet connection (both are wired ethernet). One by one, I switched them to direct connection to the router and the problem went away.

But I don't have enough router ports now for my computers.

Can anybody advise why the switch is preventing these devices from connecting? Initially the connection works after router boot. But then some time later the devices lose Internet. Do I need a managed switch or something?

Given that the switch is unmanaged, there are no configurations or any other items that can be messed up. My guess is that it is simply failing -- I've personally experienced things like this when a switch had bad capacitors inside.

Replace your switch (or repair it, if you're so inclined) and you should be good to go again.

After much experimentation, it appears to be a near fully loaded 8-port switch that causes the problem. I also tried different router models, so the problem is not specific to the E8450. I have now tried 3 different switches: 2 Linksys SE3008 models and 1 TP-Link TL-SG108 model. Highly unlikely all 3 that I tried are "bad."

These models of switch are all "home" rated. Might this make a difference? Like could it be a bandwidth limitation on the switch that is causing the problem? I have 500Mbps down from cable provider. The switches are rated to 1000Gbps, but I noticed business class switches report having 16GB bandwidth but I can't find a "bandwidth" reporting on home rated switches. Would the bandwidth be the same between home and business class switch?

Anybody have any insight?

What troubleshooting have you performed?

Specifically, it is a good idea to run persistent pings from:

  • one device to another on the same switch
  • that same device to the router itself
  • that same device to another device that is connected to the router
  • that same device to the internet
  • from the a device connected directly to the router to the router itself
  • from a device directly connected to the router to the internet

From there, the patterns may reveal what is implicated.

okay, I will start doing this. This issue is really frustrating.

When everything dies, the router lights are flickering crazy fast (same with switch) as if huge amounts of data are flying by. When the router is working well, the lights flicker slow and occasionally.

With that additional info, this sounds like it is not related to OpenWrt at all, but likely a problem with a misbehaving device (or a switching loop):

  • Verify that all the cables go to an end device. If you happen to have a cable that creates a loop, that will cause this problem (it's like an 'infinite mirror').
  • You may have hardware that has a bug -- for example, I've seen USB-C hubs with ethernet that freak out and send out broadcast storms when the host computer goes to sleep or is disconnected.
  • You could have hardware that is poorly designed with multiple interfaces -- I've also seen Peloton bikes that create a switching loop if they are connected by wifi and ethernet (I think this has been fixed, but they had bridged the interfaces rather than treating them as 2 individual interfaces).
  • I used to use a Sonos bridge and I also had another sonos component connected by ethernet... the system is supposed to use STP to prevent switching loops, but something changed and it caused one, bringing down my network.

How do you find the offending device? With any luck, my examples above will give you a headstart. But if not, you need to unplug one device at a time from your network when the problem is manifesting and observe when it stops. Or, start with most things unplugged and connect things one at a time. It is a process of elimination.

Let us know what you find.

This is very helpful. Thank you so much.

So far, it is looking like my crashed network is caused by a Lenovo ThinkPad docking station. I looked at Amazon reviews of Anker docking stations, and many reviews report those docking stations crashing their network.

By chance do you know of a docking station that does not crash networks and delivers 65W power and ethernet via USB-C?

Bingo! Check with Lenovo's support to see if they have a firmware upgrade or any solution for this issue. With any luck, you can solve it without spending any money. (Or just go wireless on that system instead of using ethernet).

This issue affects a handful of vendors/chipsets, but I don't know which specific products to avoid, nor do I know which ones were good. I don't have any recommendations to give. Sorry about that. My best suggestion is to read reviews. Or, get something that is new on the market -- the problem is likely to have been addressed in the last few years since it first started crashing networks.

I think that unplugging ethernet from that docking station will ultimately resolve the core issue (getting a good replacement is a secondary one, but unrelated to OpenWrt). When you feel confident that the problem has been solved... please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

I identified the source of the problem to be a broadcast storm created by a Lenovo ThinkPad Hybrid USB-C dock (part number 40AF0135US). Online information indicates many docking stations of all make and model present with this problem, so I have had to discontinue use of a dock for now.

I want to send my gratitude to @psherman for his generous sharing of time in helping me solve this problem.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.