Asus Zenfone Max M1 Pro - USB Tethering with Android 8.1

I am trying to configure USB Tethering on my D-Link 505 A1 using OpenWRT 17.1.05. I could get Samsung On8 phone working properly, but couldn't get the driver loaded for Asus Zenfone Max M1 Pro. Below is the /sys/kernerl/debug/usb/devices output with Zenfone connected. As there are no Drivers associated it haven't created an interface. Tried with cdc-ether and rndis drivers but no luck. The phone works fine with WIndows 10 and it lists as Remote NDIS device.

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  9 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0b05 ProdID=7775 Rev= 4.04
S:  Manufacturer=asus
S:  Product=SDM636-QRD _SN:F9DE178F
S:  SerialNumber=J5AAB761X390HDC
C:* #Ifs= 3 Cfg#= 1 Atr=80 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=ef(misc ) Sub=04 Prot=01
I:* If#= 0 Alt= 0 #EPs= 1 Cls=ef(misc ) Sub=04 Prot=01 Driver=(none)
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=42 Prot=01 Driver=(none)
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

Just to add...

Have tried below modules.

lsmod | grep usb
mii                     3640  1 usbnet
nls_base                4992  1 usbcore
usb_common              2221  1 usbcore
usbcore               122140  7 rndis_host,qmi_wwan,cdc_ether,usbnet,cdc_wdm,ehci_platform,ehci_hcd
usbnet                 17995  3 rndis_host,qmi_wwan,cdc_ether


Looks like this is known problem with Android 8.1 and Linux. Will update if there is a solution for this.

By default you will have Asus Zenfone Max M1 Pro drivers when you try to connect with PC? Didn't you get that?