Asus TUF Gaming AX6000 support

Wouldn't a really easy way to test be giving yourself a lower MTU value like say 1432 or something and see if that has the same problem? Give it so much overhead that it rules out MTU as the culprit.

I doubt it is MTU though. It would sort of make sense if you both had PPPoE and stuff like vlan tagging was messing up mtu but whitedd does not.

1 Like

I don't believe it's a problem with the ISP because the problem doesn't appear for me on the stock firmware. If the problem was with the ISP, then it would appear anyway.

I was not saying that it's an issue with the ISP, but an issue with OpenWrt on a specific ISP, in combination (due to the default config on OpenWrt and some specific settings on the ISP).

1 Like

Wrong MTU never leads to data corruption. The worst case would be stalled transfers.

Anyway - this issue is not debuggable without network dumps from both sides. If you need help, please reach out via private messages. I will send instructions on how to take these traffic dumps and how to preprocess them, and then I will look at them and post a summary here.

2 Likes

Just messaged you on pm.

I have not received network traffic dumps. However, there is a finding that narrows down the problem: it is apparently reproducible on LAN-to-LAN transfers, which indicates a defective, undervolted, or misconfigured switch.

1 Like

Hello,

I am keeping an eye on the device, since it would meet my need to upgrade to a 2.5Gb/s wired connection. Is the development at such a stage that there could be a stable release with the next OpenWRT release cycle?

Scroll back some 10-20 posts.

I tried reinstalling OpenWRT on my router today. first I installed openwrt-23_tuf-ax4200-initramfs.trx as always and after that the last SNAPSHOT (r24703-061a70d33c) . After all, my router is bricked. I can't access the GUI or via SSH. Power led blinking. Unfortunately, I don't have a serial console. I tried over 20 times to restore via Firmware Restoration, and every time it says4 that the restore was successful, but I still can't access either the GUI or SSH. Before I throw it in the trash and give up on everything, is there anything else I can do?

C:\Users\XXXX>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ethernet adapter Ethernet 2.5 GB:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::abca:6154:e3c1:3645%10
Autoconfiguration IPv4 Address. . : 169.254.115.114
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

serial using an USB TTL, it's a < $10 investment.

1 Like

where and what to buy?...advice?... link?... tnx

not the cheapest, not the most expensive.

https://www.amazon.com/dp/B0BTPFVYYK

1 Like

I've just noticed another disconnection of my ssh connections over wireless this afternoon, local and remote. Not sure if it's related to the glitches you're getting but extra interesting that it happens on the lan-lan connections too.

2 Likes

When I blow my setup, I force it into recovery. I hold the reset button 30s. Turn off power while holding reset. Turn on power while holding reset. Keep holding another 30s. Then I usually can access luci on 192.168.1.1 and flash a working firmware and reset settings.
Hope that helps

1 Like

It's strange because I don't have any problems. I tried to reproduce anything but router and connections are solid stable. Only NFS on the router sometimes have some problems. I can pass even 1TB without problem. Maybe it is related to uboot which come with stock software. I'm not sure. We can compare uboot versions.

My logs:

NOTICE:  BL2: v2.6(release):
NOTICE:  BL2: Built : 14:42:59, Jul 22 2022
NOTICE:  WDT: disabled
NOTICE:  CPU: MT7986 (2000MHz)
NOTICE:  EMI: Using DDR4 settings
NOTICE:  EMI: Detected DRAM size: 512MB
NOTICE:  EMI: complex R/W mem test passed
NOTICE:  SPI_NAND parses attributes from parameter page.
NOTICE:  SPI_NAND Detected ID 0xef
NOTICE:  Page size 2048, Block size 131072, size 268435456
NOTICE:  BL2: Booting BL31
NOTICE:  BL31: v2.6(release):
NOTICE:  BL31: Built : 14:43:05, Jul 22 2022



U-Boot 2022.04-rc1 (Nov 14 2022 - 14:58:21 +0800)
TUF-AX6000 bootloader version: 1.0.0.2

I am watching the development on this device and the Acer Predator W6. They are similar in specs, but the acer trades one 2.5gig port for wifi 6e and more flash/ram.
I’d prefer to upgrade to 6e, but a second 2.5 gig port would be nice too, especially since one is on the hardware’s lan side.

I do not have this device; I only offered help in troubleshooting, so please ask those whose router is affected by this packet corruption issue. Again, @deeddy claims (in a private message):

Same issue happens with Samba, locally, between my Win10 PC and TrueNAS Scale, as well.

Happens also, on scp/sftp/ssh, from Linux Mint to TrueNAS Scale.

In this case, if there are no misunderstandings, the data path does not touch the CPU at all, so the corruption must have happened at the switch level.

1 Like

Can you double-confirm (to avoid misunderstandings that I might have with @deeddy) that it is reproducible with only two devices on the wired LAN involved - i.e., no wireless and the same network segment (i.e., with both devices plugged directly into 1GbE LAN ports)?

No, I haven't confirmed that. Just adding that I'm seeing wireless connections reset.

Aside, I have sent 100s of GB across ssh to/from wan without seeing a reset on the AX4200.

Do you have enough hardware to perform the wired LAN-to-LAN test so that we have something more than a single possibly-misunderstood report?

I am asking because, if @deeddy's report is understood correctly, we can exclude a whooping lot of code from being under suspicion.