Asus TUF Gaming AX6000 support

SNAPSHOT (r24666-e2fa450560)

3 Likes

hi everybody

when activate veth

software offloading doesn't work en download , do you know why ?

thanks

Have you tested with software offloading (?) and could you test with WED ?
best regards,

Hi,

With SFO you need to select the main device, in this case eth1 if you are using ax6000 and wan if you are using any model with fully implemented dsa.

BR

simplest_tbf doesn't work with cake, only fq_codel

look my video...its working

software offloading is enabled... how to test WED?

please look at the wiki page of the tuf ax6000: https://openwrt.org/toh/asus/tuf-ax6000

It's not... look at your logs, you'll see

"user.notice SQM: WARNING: Cake is not supported with this script; falling back to FQ-CoDel"

The moment you select simplest_tbf, you're running fq_codel.

We have interesting commit to the main branch : https://github.com/openwrt/openwrt/commit/90fbec89be263a3838558c5b674f3c4072cc2f1d

Probably will be possible to fix last problem with LED for 2.5Gb LAN port.
UPDATE:

UPDATE2: tested PR:

1 Like

So you can't run cake on this?

No, you can't run Cake with simplest_tbf.

2 Likes

I don't really know what simplest_tbf means but I take it that's a bad thing. I'll hold off buying for now.

@gameinn There is a clear confusion here (since the conversation is split accross multiple posts). Let me put it more clearly for you.

  • SQM cake (piece_of_cake) is running perfectly fine on this router.
    I'm using it on a 1Gbps WAN connection without any problems. When the connection is saturated, on a speed test for example, CPU load is between 30% and 60% (across all 4 cores). I bet it can handle even higher WAN speeds (up to 2.5Gbps) with SQM cake, since there's a lot of unused CPU room left.

For explanation:

  • SQM cake is a Queueing discipline (qdisc), and QoS scripts layer_cake and piece_of_cake can only work on cake qdisc.
  • While simplest_tbf (that @whitedd selected) can only run with fq_codel. So it was a matter of wrong choice, that @diogosena and @p.p wanted to point out (cake is a wrong qdisc for simplest_tbf.qos script).

Have a look at the screenshot for better undestanding:

SQM cake is a more modern solution for QoS comparing to fq_codel. The only reason to use fq_codel over cake is that it's makes less load on a CPU. So with a older or less powerful routers (fyi: this router has one of the most powerful CPU for an ARM router!), sometimes your only option is to use fq_codel.

There's no single reason why not to buy this router for SQM cake. It DOES work with SQM cake perfectly fine.

1 Like

Thank you deeddy. It's hard for me to check stuff without actually having the software you know. One extra question about cake and openwrt: How do you change the wan packet overhead and mpu values for cake? On Asus merlin you could do it on the same page e.g.

wEtNk0N

I take it this takes place under the "Link Layer Adaptation" tab?

Thank you

I guess this replies your question. Glad to help. :slight_smile:

Speaking of the topic, does anybody know what values to put here for a fiber connection? There's a Huawei ONT and a direct connection (no PPPoE). I've been reading that there should be 42 or 44. I'm using 0 (overhead disabled) and I don't see any issues with the connection.

Any advise?

A really down and dirty way I think I found to get mpu is this specific ping with flags in Windows:

ping -f -l 1464 8.8.8.8

This is for a 1492 MTU so change the 1464 number accordingly to your own max MTU size. It will tell you what the mpu is from bytes=

rS7nZ7r

The 68 value seems to match with what I looked up for my scenario (which I sort of understood). I just saw is also on openwrt:

"For VDSL - Choose Ethernet , and set overhead 34 (or 26 if you're not using PPPoE) (mpu 68)."

In your case 44 for wan packet and 84 mpu since you then have to take into account l1 ethernet frame. It's always better to over estimate than underestimate.

1 Like

Another happy customer here. Got my TUF AX6000 up and running yesterday and flashed it with @remittor's trx. Then installed SNAPSHOT r24683-4cc6e7192f from Dec. 20th. Everything went very smooth.

It's running just fine. However, I see the same mishap that @Kuredant mentioned 9 days ago:

  • The eth1 WAN port is labelled as 1 GbE on LuCI instead of 2.5 GbE
  • The lan5 port is labelled as -1 MbE (H) instead of 2.5 GbE
    As I read the comments, this was already fixed. Is this a merge error, maybe?
1 Like

Hi, Please paste ethtool output for these interfaces. Below you can find commands from my router.
best regards, Patryk

root@router1:~# ethtool eth1
Settings for eth1:
	Supported ports: [ ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	                        2500baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	                        2500baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     2500baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 100Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 6
	Transceiver: external
	Auto-negotiation: on
	MDI-X: Unknown
	Current message level: 0x000000ff (255)
			       drv probe link timer ifdown ifup rx_err tx_err
	Link detected: yes
root@router1:~# ethtool lan5
Settings for lan5:
	Supported ports: [ ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	                        2500baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	                        2500baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     1000baseT/Full 
	                                     2500baseT/Full 
	Link partner advertised pause frame use: Symmetric Receive-only
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 2500Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 5
	Transceiver: external
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pg
	Wake-on: d
	Link detected: yes

Here you go

root@OpenWrt:~# ethtool eth1
Settings for eth1:
        Supported ports: [ ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
                                2500baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
                                2500baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
                                             1000baseT/Full 
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 6
        Transceiver: external
        Auto-negotiation: on
        MDI-X: Unknown
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

root@OpenWrt:~# ethtool lan5
Settings for lan5:
        Supported ports: [ ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
                                2500baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
                                2500baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: Unknown!
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 5
        Transceiver: external
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: pg
        Wake-on: d
        Link detected: no