Asus TUF AX4200 support

3 posts were split to a new topic: Broken my openwrt configuration - how to get to failsafe mode?

What method did you use, serial port or trx?

So is serial port still needed or can you now flash using UI?

No using ui :love_you_gesture:

The trx method was quite simple to flash and update with the initramfs. It took me longer to figure out how to get the stock firmware into a state that could flash something while offline.

Does anyone have 160mhz channels working on 5G? I've tried both release and snapshot branches but a new AP either appears disabled or never advertises or connects with 160mhz channel widths. The channel frequencies appear different in LUCI before and after selection.

I've been following the AX6000 thread as well since the hardware is quite similar.

Other reports:

  • SQM works well on the 4200
  • WED appears stable in the snapshot branch
  • no ssh large transfer interruption issues seen ssh target-host dd if=/dev/zero status=progress | dd of=/dev/null

Regarding the large file transfer issues - were you using software offloading with SQM? Also, what specific SQM do you use? We are trying to reproduce the issue, but seems as an isolated thing so far.

I can confirm that 160MHz channels do NOT work on AX6000, but not sure how similar wifi hardware is to AX4200. Both routers use the same SoC, so most of the hardware should be the same. The only other difference is the 2nd 2.5GbE port on TUF-AX6000.

specific SQM do you use? We are trying to reproduce the issue, but seems as an isolated thing so far.

Yeah it's a standard SQM configuration with software 90% of the bandwidth, piece of cake, and 44b packet overhead. A+ on the bufferbloat test, A without SQM.

I can confirm that 160MHz channels do NOT work on AX6000, but not sure how similar wifi hardware is to AX4200. Both routers use the same SoC, so most of the hardware should be the same. The only other difference is the 2nd 2.5GbE port on TUF-AX6000.
Thanks, it seems a lot of the 160MHz posts are tests from the vendor firmware. I had thought you might have gotten 160 to work by deleting the APs then creating with the 160MHz channel.

Do you see the same 6ghz frequencies for the channels in LuCI? It looks like it's confusing the 5GHz and 6GHz (ax only) channels and band names. 36, 100, 149 should be safe choices.

I'm having problem with 160MHz (wifi doesn't work), but I do see only 5GHz channels (AX).
For the reference: AX6000 here.

Hello, I had this issue, you have to set a country code to your adapter
Network --> Wireless --> Edit under MediaTek MT7986 next to the wifi station name --> Advanced Settings
I'll put mine under as an example for you:

My devices is a ax4200 but i had the same issue as you, also, you have to wait a bit until it works, maybe even restart it once

1 Like

I have the country code and it works okay for the 5g channels. 100 has some delay in connecting for the DFS as expected.

While testing this again, I noticed that when the interfaces aren't ready, they show the wrong frequency for the channel number. The pulldown menu while selecting them is okay. This persists for the 160MHz channels since they never initialize. iwinfo also shows some inconsistencies with my mesh and ap mode when trying 160MHz (neither work).

# ch149
MediaTek MT7986 802.11ac/ax/n
Channel: 149 (6.695 GHz) | Bitrate: ? Mbit/s

# ch100 working, 80Mhz after DFS startup delay
MediaTek MT7986 802.11ac/ax/n
Channel: 100 (5.500 GHz) | Bitrate: 960.7 Mbit/s

# ch100 display while DFS startup or any 160MHz attempt
MediaTek MT7986 802.11ac/ax/n
Channel: 100 (6.450 GHz) | Bitrate: ? Mbit/s
# iwinfo for the 2 5GHz connections, ap0 has the wrong freq and NOHT
phy1-ap0  ESSID:
          Mode: Master  Channel: 100 (6.450 GHz)  HT Mode: NOHT
          Center Channel 1: unknown 2: unknown
# the mesh has the wrong channel and is not connected either
phy1-mesh0 ESSID:
          Mode: Mesh Point  Channel: 149 (5.745 GHz)  HT Mode: VHT80
          Center Channel 1: 155 2: unknown

# ch36 at 160MHz
MediaTek MT7986 802.11ac/ax/n
Channel: 36 (6.130 GHz) | Bitrate: ? Mbit/s

# ch36 working at 80MHz
MediaTek MT7986 802.11ac/ax/n
Channel: 36 (5.180 GHz) | Bitrate: 216.1 Mbit/s

A little bit more on the 5ghz after reading iw reg get more closely. Only 5.500GHz(ch 100) in Europe is allowed for 160MHz in the same license. 2x80 is possible on the lower band (36) or a with a mix of DFS and the last channel 149 is one block shy of being allowed 160MHz. The 6E band in 6GHz is wide open for 160MHz but not in the support of this router.

Does anyone have an idea why the 6ghz frequencies show when the interfaces aren't working/allowed?

Is there any news when mediatek will get the 6.1 kernel in the snapshots?

emergency help!!!!!
I used your documentation to flash the ax4200 to openwrt, and then updated using the OpenWRT sysupgrade image, as you directed. After simply setting up the network, the router can access the Internet normally.
But within a few minutes I ran into a problem, I couldn't log in again with the changed password, which I was actually pretty sure I didn't enter wrong, well, I tried a lot of possible passwords anyway and still couldn't log in.
Then I can only use the official ASUS rescue tool to restore to the original ASUS firmware. I have successfully restored the firmware several times using the official tool before, so I was not worried.
But the real problem occurred: no matter how I tried, using the official firmware of ASUS or the openwrt firmware of ax4200, the router never changed and remained in the openwrt state. The network set up before was still working, and the login password was still the same, invalid!

I didn't know how to use the TFTP method suggested by openwrt before, so I used the file you provided.
What else can I do now? :sob: :sob: :sob:


Please don't start posts with emergency help, you don't even have a dead router so there is really no issue at all.
My guess would be that the image that uses the whole size of the system image re-partitions something , hence why it fails (Post)

Try a hard reset on your router , and afterwards use the incognito mode on your router, and also, do not enter any password.
You can also try to ssh into the router, same thing, without a password(link)

Don't panic , nothing is lost, you will learn stuff today, and you will have an awesome router in the end :slight_smile:

I followed the ASUS official guide link to hard reset the AX4200. I tried it several times, even binding the WPS button with tape for ten minutes, but the power light kept flashing quickly and did not turn off. The router is like a mountain, stubbornly without any change.

Forgive me for being a little anxious :sweat_smile: . If it were an old router, or if it bricked, I might be calmer, at least you know it's broken. But now it's like a monster out of control, and I have no way to deal with it.

This is a router I just bought a few days ago. I spent a lot of time choosing it just to flash OpenWrt. The AX4200 is a good balance of performance and price, but now....

Hello, no worries about the router, i also have searched for it for a long long time, for me it was the first router that i had to use a serial console to flash :)) , before the simple flashing method existed.

Reset the router using this method:
Afterwards insert a network cable in lan1 and the in your pc or laptop, and try again to connect to it using ssh (putty if you are on windows), as ip use, user:root , password: nothing, just press enter

Try this, and please let me know if it works for you

1 Like

Thank you very much for your guidance. Yes, I successfully restored openwrt to default through the reset key,but still failed to flash back to ASUS firmware.
What should I do now? Should I reinstall openwrt via Using the TFTP method

I have no clue about that method. I have Googled all day and even talked with Chatgpt Bing and Bard, but in the end I had no idea how and where to enter these commands. Bard told me to go through putty, I opened the COM1 port through putty and all I got was a complete blank.
Do you know how to enter these codes? I tried it on Windows before. Of course, if it must be Linux, I also have some basic Linux operating experience.

Download the OpenWrt initramfs image. Copy the image to a TFTP server reachable at Rename the image to tufax4200.bin.
Connect the TFTP server to the AX4200 (e.g. LAN Port 1). Connect to the serial console, interrupt the autoboot process by pressing '4' when prompted (your choice will be echoed)
Download & Boot the OpenWrt initramfs image:
MT7986> setenv ipaddr
MT7986> setenv serverip
MT7986> tftpboot 0x46000000 tufax4200.bin
MT7986> bootm 0x46000000

Have you tried this method?

1 Like

Saving the day as usual @remittor :+1: :+1: :+1:

I have a question, maybe off-topic: Would the ax4200 be able to have a secondary 2.5 port , like the ax6000 if one would solder another rj45 port and the missing utv24c01(i think) chip ?


It seems to me that the success rate is 90%
But in the end you will not get AX6000, but only AX4200Q