Asus RT-N66U problems

I just got a used Asus RT-N66U (rev B1) for $10 Canadian. Although it is stable, I found some big problems thus far.

  1. The wireless works for like 2.4G with the b43 module, but there is something weird going on with the signal strength, and is thus pretty much useless. Other nearby openwrt routers report strengths around -80db. I tried dd wrt on the same rt-n66u and it worked perfectly. I was thinking maybe there is some hardware thing you have to do like enable a gate on the board using pci writes or something maybe the driver is not doing. BTW I tried brcm-wl and it complains about an unknown bus type and does not load.

  2. I get the same issue using android rndis over usb. Don't know the exact problem, but you get these massive network drop outs like it just won't do anything for 4 minutes. This may be a problem with the usb. I am using a Samsung Tab A. I saw this same problem on a SmartRG400ac which also uses a similar broadcom chipset.

As listed in the warning box right on top of the device page of your rt-n66u, the wireless is a lost a cause:

Do yourself a favour and look for some fully supported device instead, maybe you can recover your losses by selling the rt-n66u again.

It's ok in my setup there are 2 routers. One connects 2 cellular devices on different plans to my network. The other one proxy forwards to a different gateway, and downloads using youtube-dl and wget over night onto a usb stick. My main computer downloads slowly from one plan after the data limit with a --proxy in the command. This fits the 2nd one so I have a backup 1st one now. It was a bit disappointing how messed it was though.

I was experimenting with dd-wrt and for what I need it for it is just about possible to use it for the RT-N66U. I used entware and bound to usb stick to add applications to the larger firmware file. The bigger firmware only installed from the smaller dd-wrt firmware. Really the openwrt version needs a lot of improvement.

oh, where ?

It was doing weird things running processes where it would totally hang the filesystem doing python3 yt-dlp. Also the wireless was non-functional. There are good openwrt routers. I would definitely not recommend this one for openwrt. Maybe you can read this don't know:
dd-wrt experience

The 1st answer you received, from @slh, was basically a "don't do it", and you still believe the issue's with openwrt ?

Check if Merlin supports the N66U.