Asus RT-N56U "Image metadata not present" on upgrade

I have a Asus RT-N56U A1 where I recently installed openwrt 22.03.3.
Here is what the Webinterface tells me:

I wanted to upgrade to 22.03.4 using attended sysupgrade, but this failed.
So I manually generated a image at with the packages

auc base-files busybox ca-bundle cgi-io curl ddns-scripts dnsmasq drill dropbear firewall4 fstools fwtool getrandom hostapd-common iw iwinfo jansson jshn jsonfilter kmod-cfg80211 kmod-crypto-aead kmod-crypto-ccm kmod-crypto-cmac kmod-crypto-crc32c kmod-crypto-ctr kmod-crypto-gcm kmod-crypto-gf128 kmod-crypto-ghash kmod-crypto-hash kmod-crypto-hmac kmod-crypto-manager kmod-crypto-null kmod-crypto-rng kmod-crypto-seqiv kmod-crypto-sha256 kmod-eeprom-93cx6 kmod-gpio-button-hotplug kmod-leds-gpio kmod-lib-crc-ccitt kmod-lib-crc32c kmod-mac80211 kmod-nf-conntrack kmod-nf-conntrack6 kmod-nf-flow kmod-nf-log kmod-nf-log6 kmod-nf-nat kmod-nf-reject kmod-nf-reject6 kmod-nfnetlink kmod-nft-core kmod-nft-fib kmod-nft-nat kmod-nft-offload kmod-ppp kmod-pppoe kmod-pppox kmod-rt2800-lib kmod-rt2800-mmio kmod-rt2800-pci kmod-rt2800-soc kmod-rt2x00-lib kmod-rt2x00-mmio kmod-rt2x00-pci kmod-slhc kmod-usb-ohci kmod-usb2 libblobmsg-json libiwinfo libiwinfo-data libiwinfo-lua libjson-c libjson-script liblua liblucihttp liblucihttp-lua libmnl libnftnl libnl-tiny libubox libubus libubus-lua libuci libuclient libucode libustream-wolfssl libwolfssl logd lua luci luci-app-attendedsysupgrade luci-app-ddns luci-app-firewall luci-app-opkg luci-base luci-lib-base luci-lib-ip luci-lib-jsonc luci-lib-nixio luci-mod-admin-full luci-mod-network luci-mod-status luci-mod-system luci-proto-ipv6 luci-proto-ppp luci-ssl luci-theme-bootstrap mtd nano netifd nftables-json odhcp6c odhcpd-ipv6only openwrt-keyring opkg ppp ppp-mod-pppoe procd procd-seccomp px5g-wolfssl rpcd rpcd-mod-file rpcd-mod-iwinfo rpcd-mod-luci rpcd-mod-rrdns rt2800-pci-firmware swconfig ubox ubus ubusd uci uclient-fetch ucode ucode-mod-fs ucode-mod-ubus ucode-mod-uci uhttpd uhttpd-mod-ubus urandom-seed urngd usign wireless-regdb wpad-basic-wolfssl base-files busybox ca-bundle dnsmasq dropbear firewall4 fstools kernel kmod-gpio-button-hotplug kmod-leds-gpio kmod-nft-offload kmod-rt2800-pci kmod-rt2800-soc kmod-usb-ohci kmod-usb2 libustream-wolfssl logd mtd netifd odhcp6c odhcpd-ipv6only opkg ppp ppp-mod-pppoe procd procd-seccomp swconfig uci uclient-fetch urandom-seed urngd wpad-basic-wolfssl

Build worked, Image was available for download

I uploaded the image to the router and get this error:
sha256sum matches the download.

Since this failed, I decided to just use the base image and downloaded it

Same error:

What am I doing wrong here?

I have the same issue. There is the option to force the upgrade, but is there a chance to brick my device?

--force disables all sanity checks, so yes - make double-, triple sure to flash the correct image.

What is causing this error to appear? Is there something wrong with our current installations, the upgrade images or something else?

1 Like

If I understood correctly from the documentation, the metadata is embedded information that is used to make sure compatibility between OpenWrt versions. Why is this rather important information missing?

I tried a forced upgrade and this works. But doing another upgrade results in the same error.
I assume this is a bug in OpenWRT

1 Like

I've had the same issue for the last few releases. I haven't had any issues after forcing each upgrade, :crossed_fingers: