Asus RT N12 missing wan and wireless

Bit the bullet and installed OpenWRT on my main router. Unfortunately things didn't go so well and I'm currently stuck.

Wan doesn't seem to be configured and I had to add it myself. Unfortunately I'm still unable to get the configuration sorted. I've added wan to /etc/config/network with dhcp to eth0.1 but it seems it still missing something. Anyone know the steps to get this configured?

I am starting to configure my wireless via Asus Initial Wireless Configuration and hoping this is a simple fix.

On phone searching for answers suck.

What version of the RT-N12 firmware did you install?

Several versions do not support 2.4 Ghz wireless...

https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=rt-n12

https://downloads.lede-project.org/releases/17.01.4/targets/brcm47xx/mips74k/lede-17.01.4-brcm47xx-mips74k-asus-rt-n12-d1-squashfs.trx

Had to revert to my tomato FW due to the angry mob getting ready to hang me.

On the plus side I can dig into the problem on my computer instead of my phone.

Wireless issue still an issue... https://dev.openwrt.org/ticket/14236 (4 years now). :frowning:

Keep your posts on this topic in one thread.

Thanks.

Not likely to ever be supported.

See the warning on the Techdata page...

Devices with Broadcom WiFi chipsets have limited LEDE supportability (due to limited FLOSS driver availability for Broadcom chips).

Adding a reference link for a currently open issue that is relevant in both threads I would argue is beneficial.

The Techdata page says "limited" it should say unsupported in this case for the device.

I also double checked my WRT160N installation and the WAN is also not setup, (I didn't bother with any WAN settings since it's more a bridge and AP than anything else). Are OpenWRT installations have the WAN port unconfigured out of the box? Not having much luck with setting up the WAN interface, (I found some instructions with connecting to various ISPs via SSH but nothing straight forward with LuCi).

As mentioned in the ticket, it's a "won't fix", so I don't see how cross-posting it benefits the other thread..

You also cross-posted the same questions, which wastes peoples' time and causes confusion because responders in one location don't know there are responders to the same thing in another location.

The Table of Hardware does say it is unsupported. You may have missed that...

https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=rt-n12&dataflt[Versions*~]=d1

WAN is never fully configured out of the box.

You might take a look at the LEDE User Guide...

https://openwrt.org/docs/user-guide/start

Again... I disagree... my question was if the original poster was able to resolve the issue. The ticket posted was the official issue for the project. 100% relevant for the original thread. Fair that my WAN comment was extra but the rest was relevant.

I had to read the table four times to notice that it was the column that indicated the "unsupported" status. The column would be better listed as "Issues" and the cell should show the actual issue, (ie "WiFi unsupported" or "WiFi 5GHz unsupported"). People naturally read listed items as supported.

This seems to be an understatement. So far in both routers I've installed WAN configuration seems non-existent. The existing information I've found on the wiki isn't easy to follow and not complete in any one place. The first and only step I've ran into from reading your posted link is a ping command, (which fails with "ping: bad address 'lede-project.org'"). Looking in LuCi and the file system in /etc/config/network and there isn't a wan device configured and I'm not having much luck in getting all the steps in getting it set up without trying to get through all the docs. Still working out issues and posting the problems I'm encountering as I go.

As I mentioned in my previous post, if I am encountering these issues, many more are and not saying anything and just moving on to other projects.

Relevance has nothing to do with it...it's considered common courtesy in forums to not post the same issues in two different threads. Some support sites will ban users who cross-post.

That's what the docs are for...the more you read, the better prepared you are for configuring and using the firmware.

Unsupported means exactly that...items listed in the column are not supported for the device in OpenWrt/LEDE.

Based on your complaints, OpenWrt/LEDE may not be for you.

You mght wish to try another open source firmware that is more plug-and-play.

1 Like

similar problem. although d1 in the table shown was supported. that is, this version of expect Wi-Fi is not worth it? strange but in ddwrt everything works

@jwoods I hope that wasn't a threat of banning for asking for an update in an old inactive thread and updating it with the actual bug reference and starting a thread for specific device issues.

Also a "RTFM or go elsewhere" response I hope isn't what the community expects of it's users. Poor documentation is a large part of it and unexpected and non-intuitive UX is the other half. As I mentioned I am willing to fix what I can as I encounter it.

@moobi: If you are looking at the table https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=rt-n12&dataflt[Versions*~]=d1 as @jwoods supplied, it's the column header that lists the feature in the cells as unspported. Again... took me four reads to see that. I would also add the Techdata should say the WLAN specific device is not supported also, (not a generic banner that people should cross check). I've also updated the https://openwrt.org/inbox/unsupported_features page to include the board.

As mentioned, some support sites do for cross-posting.

You posted more than just the bug report.

As mentioned, the LEDE User Guide is available, and probably addresses most of the issues people encounter...(certainly helped me get started with LEDE), regardless of whether you personaly like how it is written.

OpenWrt/LEDE requires configuration, more so than stock firmware...it is not plug-and-play.

It is not for everyone.

Removing the [Solved] tag as this issue is definitely not solved for the following points:

  • Wireless is still an issue ("will not fix" is the situation but several wiki pages should be updated which I have not gotten to nor has anyone else updated them).
  • WAN is still not working, (there is a huge gap from running ping to setting up WAN ISP configuration that needs clarification). I don't agree that pointing to a link with 7 dozen other pages is really solution but rather sweeping the issue under the rug.

Your keyboard warrior approach doesn't change the facts that wireless is not supported (and probably never will be) and setting up the WAN should be simple.

If you would have noted your prior WAN settings before upgrading, it would have been much easier.

In LuCI -

Network > Interfaces > WAN > Edit button

  1. General Setup tab - select the connection protocol (DHCP, PPPoE, etc.)

  2. Advanced Settings tab - Use default gateway (checked), Use DNS severs advertised by peer (check if you want to use ISP's...otherwise uncheck), or enter your DNS servers in Use custom servers.

  3. Physical Interface tab - Interface (ethernet for WAN).

  4. Firewall Settings tab - WAN

Done.

Any other settings can be found in the LEDE User Guide.

Please review my previous comment. My stated issue that was outstanding is with the wiki and NOT with the fact that wireless is not supported.

Wireless issue wiki update:

  • https://openwrt.org/inbox/unsupported_features updated with device list link
  • https://openwrt.org/toh/views/toh_fwdownload devices and coresponding Techdata pages updated with a more descriptive and less ambiguous information.
  • Unsupported WLAN from unsupported features page updated to Techdata pages.
  • Pending Techdata design updates to incorporate device support state into Techdata pages directly with the hardware.
  • As close to resolved as we can get for wireless.

WAN confirmation still pending:

  • Thanks @jwoods I will verify the steps provided as soon as I can.
  • Just as note, in my searches for WAN configuration I only found Command line configuration, that only has bits and pieces of the configuration, I would like to know which page you obtained the above steps so that this can be made easier to find for the next person.
  • Not resolved yet.

Removing [Solved] tag again as confirmation of remaining WAN issue is still needed before I would consider this resolved.

Wiki issues should be reported here...

https://forum.openwrt.org/c/documentation

There is no "configure using LuCI quick start" tutorial page.

I have configured routers using GUI's in DD-WRT, Gargoyle, OpenWRT, LEDE, and stock. All have common areas of configuration.

It's a matter of transferring that to whatever GUI you are using, and reading the User Guide for whatever firmware you are using.

If the wiki is wrong, misleading or lacking, I will update the wiki as needed rather than requesting and waiting for someone else to do it. If someone is more qualified I would welcome for the improvements to come from them. I have also configured other firmware (Tomato, DD-WRT, stock), but I have not had to configure WAN from ground up on any other firmware.

WAN instructions provided above did not gain network access. (Currently working on my WRT160Nv3 on figuring out the issue).

WAN comes out-of-the-box missing any sort of configuration, (as mentioned before also looked and edited in /etc/config/network). I've attempting to add wan with the provided *s== and eth0 options. eth0 is configured to local network, (where router is serves DHCP addresses to local network successfully). I've tried configuring with *s== and attempted eth0.1 and eth0.2 without success, (as per instructed on other WAN configuration pages).

SSH from the device did not have internet access, (checked via ping). ISP provides a DHCP address normally and is failing to do so with OpenWRT.

I am still looking for a resolution for this issue, (but have been tied up with cleaning up wiki info so others are stumped with the same hang ups I ran into). I will continue digging in the wiki and provide a solution if I find it.

I would suspect there is something you have already configured in UCI that is causing the issue with WAN.

Those steps work fine for my connection.

Hopefully someone more qualified will be reviewing whatever you write for accuracy.