Hello! I installed OpenWRT 23.05.4 on Asus rt-ax59u and configured it as a WDS wireless bridge/repeater based on instructions from https://openwrt.org/docs/guide-user/network/wifi/wifiextenders/wds. It connects to my main router (Xiaomi AX9000, it also runs OpenWRT 23.05.4), to 2 separate LANs (with normal gateway and one via wireguard interface). Everything works fine, except that for some odd reason, every interface on the 5GHz radio (it's also used for WDS bridging) starting from the 4th one reports "Wireless is not associated" on LuCI. Here's my /etc/config/wireless
:
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/18000000.wifi'
option channel '6'
option band '2g'
option htmode 'HT20'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan_vpn'
option mode 'ap'
option ssid 'alllexx_cab'
option encryption 'sae-mixed'
option key '*'
option ieee80211r '1'
option ft_over_ds '0'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/18000000.wifi+1'
option channel '44'
option band '5g'
option htmode 'HE160'
option cell_density '0'
config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'sta'
option network 'lan_vpn'
option ssid 'bridge1'
option encryption 'sae'
option key '*'
option wds '1'
config wifi-iface 'wifinet3'
option device 'radio1'
option mode 'sta'
option network 'lan'
option ssid 'bridge2'
option encryption 'sae'
option key '*'
option wds '1'
config wifi-iface 'wifinet4'
option device 'radio0'
option mode 'ap'
option ssid 'alllexx'
option encryption 'sae-mixed'
option key '*'
option ieee80211r '1'
option ft_over_ds '0'
option network 'lan_vpn'
config wifi-iface 'wifinet5'
option device 'radio1'
option mode 'ap'
option ssid 'alllexx'
option encryption 'sae-mixed'
option key '*'
option ieee80211r '1'
option ft_over_ds '0'
option network 'lan_vpn'
config wifi-iface 'wifinet6'
option device 'radio0'
option mode 'ap'
option ssid 'dfEfdsfHHf'
option encryption 'sae-mixed'
option key '*'
option ieee80211r '1'
option ft_over_ds '0'
option network 'lan'
config wifi-iface 'wifinet7'
option device 'radio1'
option mode 'ap'
option ssid 'dfEfdsfHHf'
option encryption 'sae-mixed'
option key '*'
option ieee80211r '1'
option ft_over_ds '0'
option network 'lan'
wifinet7
, added the last, is the one that reports "Wireless is not associated". If I disable wifinet5
, the 3rd interface on 5GHz radio1
, wifinet7
can be enabled. Also adding 5th, 6th, and so on AP interfaces on radio1
also gives "Wireless is not associated" interfaces. On the 2.4GHz radio0
I can have as many AP interfaces working as needed (tried up to 7).
This is what is written to the system log when I try to enable the problematic interface:
Mon Sep 9 15:37:07 2024 daemon.notice netifd: radio1 (11280): sh: out of range
Mon Sep 9 15:37:07 2024 daemon.notice netifd: radio1 (11280): sh: out of range
Mon Sep 9 15:37:07 2024 daemon.notice wpa_supplicant[1505]: Set new config for phy phy1
Mon Sep 9 15:37:07 2024 daemon.notice hostapd: Set new config for phy phy1: /var/run/hostapd-phy1.conf
Mon Sep 9 15:37:07 2024 daemon.notice hostapd: Add bss phy1-ap1 on phy phy1
Mon Sep 9 15:37:07 2024 daemon.notice hostapd: Reloaded settings for phy phy1
Mon Sep 9 15:37:07 2024 daemon.notice wpa_supplicant[1505]: Set new config for phy phy1
Mon Sep 9 15:37:07 2024 daemon.notice netifd: Wireless device 'radio1' is now up
Mon Sep 9 15:37:09 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Mon Sep 9 15:37:09 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 names
Probably the issue is netifd: radio1 (11280): sh: out of range
, but I don't really understand what's causing it, or what it means.
Any ideas? Thank you!