Asus rt-ax53u - router boots up but is unreachable

Hi everyone.

I just got my asus rt-ax53u and flashed openwrt on it. However I ran into a quite curious scenario.

I think that the router manages to boot correctly because I am able to enter failsafe mode and perform factory resets using the physical button. However the router is unreachable.

I am connected to it via an ethernet cable (to the LAN port 1) and the router seems to just be completely silent. I tried to check the traffic via wireshark and if I try to access 192.168.1.1 my laptop sends the ARP request, but the router does not reply.

It is important to note that this scenario happened when I first installed 23.05.2. Then after several hw reboots, power cycles, etc I finally managed to access the luci interface (no idea why that worked at some point). Anyways that reinforces my hypothesis that there were no flashing issues.

Now I wanted to downgrade to 22.03.6 so I flashed it through the luci web interface. I am now in the same original situation (router correctly boots up but is unreachable). I tried again to factory reset and reboot it several times to see if it would magically fix things but this time it seems that I am not lucky :smiley:

Any idea on what could be causing this? I guess the only way to debug this is to connect via serial?

Disconnect everything except for power and one ethernet connection between your router's lan port and your computer's ethernet port. Make sure your computer has only a single active network connection (i.e. turn off wifi, unplug any other ethernet connections).

Reboot the router, and set your computer to get an IP address via DHCP.

Does the computer get an IP? If so, what is it?

It doesn't get an IP.

The first time when I actually managed to connect after multiple attempts, I had set a static ip to my laptop interface. However not even that works now. Seems like the openwrt code is stuck somewhere?

Set your computer to 192.168.1.10 (subnet mask 255.255.255.0).
Start a persistent ping to 192.168.1.1 and reboot the router (disconnect and reconnect power). Over the period of ~1-2 minutes from the time that you apply power, what happens in terms of any successful ping responses. Pay particular attention to the TTL values that come back.

This is the output:

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.10 icmp_seq=1 Destination Host Unreachable
From 192.168.1.10 icmp_seq=2 Destination Host Unreachable
From 192.168.1.10 icmp_seq=3 Destination Host Unreachable
From 192.168.1.10 icmp_seq=5 Destination Host Unreachable
From 192.168.1.10 icmp_seq=6 Destination Host Unreachable
From 192.168.1.10 icmp_seq=7 Destination Host Unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
From 192.168.1.10 icmp_seq=15 Destination Host Unreachable
From 192.168.1.10 icmp_seq=16 Destination Host Unreachable
From 192.168.1.10 icmp_seq=17 Destination Host Unreachable
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
...
ping: sendmsg: Network is unreachable
ping: sendmsg: Network is unreachable
From 192.168.1.10 icmp_seq=40 Destination Host Unreachable
From 192.168.1.10 icmp_seq=41 Destination Host Unreachable
From 192.168.1.10 icmp_seq=42 Destination Host Unreachable
From 192.168.1.10 icmp_seq=43 Destination Host Unreachable
From 192.168.1.10 icmp_seq=44 Destination Host Unreachable
From 192.168.1.10 icmp_seq=45 Destination Host Unreachable
From 192.168.1.10 icmp_seq=46 Destination Host Unreachable
...
From 192.168.1.10 icmp_seq=142 Destination Host Unreachable
From 192.168.1.10 icmp_seq=143 Destination Host Unreachable
From 192.168.1.10 icmp_seq=144 Destination Host Unreachable

Seems like the router never replies

Ok... see if you can engage failsafe mode... if the pings come back successfully, login via ssh and grab this information:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I managed to enter failsafe mode (by pressing wps button when the power led blinks). After the power leds keeps blinking instead of remaining ON, so I think I am successfully in failsafe mode.

However the result of the pings is the same as before.

Also just fyi when downgrading from 23.05.2 to 22.03.6 I unchecked the box which allows to keep configuration. So everything should be clean.

Something is not right here... if failsafe is engaged and your computer is configured properly, you should get a ping return.

What double check your computer's physical connection to the router as well as the network configuration (feel free to share a screenshot here). The computer should have a direct connection to the router's lan port and no other connections whatsoever. The IP address should be on the 192.168.1.0/24 network -- any value from .2 - .254, with a subnet mask of 255.255.255.0).

Also, you may want to try another cable and/or inspect the ethernet ports to ensure that there are no bent pins or debris in there. This will help rule out a physical connection issue.

I tried with another laptop. Accessing luci worked at first attempt...

I guess the problem is with my laptop. I am still puzzled because after the first flashing I was able to successfully access luci from my "faulty" laptop...

Anyways, solved. Sorry for wasting your time.

Glad it is working now!

Sometimes, in Windows, when you set a static IP under iPv4/TCP properties and/or other settings, it will leave trash in advanced settings or alternate settings.

Might be a good idea to check those.

I was using ubuntu on one laptop (the one which does not work) and fedora on the other one. With Fedora everything worked fine. Not sure it is related to distro behaviour though.

I will post here if I manage to discover the root cause of why it is not working on one of the laptop. I am afraid it might just be faulty eth port

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.