Asus RT-AX1800S instability

Hi, I need help to diagnose what is wrong with Openwrt on Asus RT-AX1800S that it stops transmitting a wifi signal and needs power off and on to recover. Here is the transcript of ssh information request:

BusyBox v1.36.1 (2024-09-23 12:34:46 UTC) built-in shell (ash)


| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || | |_____|| |||||___||| |____| || W I R E L E S S F R E E D O M

OpenWrt 23.05.5, r24106-10cc5fcd00

root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.167",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:4",
"model": "ASUS RT-AX54",
"board_name": "asus,rt-ax54",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.5",
"revision": "r24106-10cc5fcd00",
"target": "ramips/mt7621",
"description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
}
}
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
option channel 'auto'
option band '2g'
option htmode 'HE20'
option txpower '10'
option cell_density '0'
option beacon_int '1000'
option country 'CA'
option disabled '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2'
option dtim_period '3'
option key 'clear'
option ocv '0'
option disabled '1'

config wifi-device 'radio1'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
option channel 'auto'
option band '5g'
option htmode 'HE40'
option cell_density '0'
option beacon_int '1000'
option country 'CA'
option txpower '10'
option disabled '1'

config wifi-iface 'wifinet1'
option device 'radio1'
option mode 'ap'
option ssid 'OpenWrt 5g'
option encryption 'psk2'
option key 'clear'
option network 'lan'
option dtim_period '3'
option wpa_group_rekey '86400'
option disabled '1'

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fda2:226f:7ed3::/48'
option packet_steering '1'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
list dns '8.8.8.8'
list dns '8.8.4.4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

Please restore default txpower, vht80 auto channel and use cell density parameter IF you need to reduce range.
Also make identical AP-s in both bands.

1 Like

Try to re-format your post

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

whatever

This was problematic: VHT80 caused signal to be turned off. Reverting to VHT40 restored it.

If you know so well why you ask here at all?
Make as default setup as possible and collect log around "switching off"
Your current setup is so messed up that I would suggest to reset the device and re-do it from zero:

  • connect br-lan to main nettwork
  • set up eifi ap setting only country code,, network lan auto channel and security refraining from clicking other buttons.

Try HE80. This device is an AX radio.

Also, anything else you tried that doesn't work (so we don't suggest them)?

Beacon int 1000 will be barely connectable to start with.

Ok, well I dont really know what vht80 or he80 are. I am using LUCI. All i am seeing is operaring frequency mode = AX, channel = auto, width = 80. The only thing known to not work is width 80. Other unknowns are causing problems randomly with width set to 40.

Undo the other dozen parameters added.
Also helps to ducking enable wifi. Frankly it looks like AI hallucination

1 Like

Ok, its best i start from zero as suggested. By the way, for whatever reason i am trying to limit RF signal output, hence the low transmit power and dtim = 1000. That was my reason for trying openwrt.

Dont you see the link between weak signal and poor connection?

1 Like

It is more challenging for a weak RT-ax1800s processor and limited RAM. Perhaps i shoild get a higher quality router if i am trying to do things like that.

Thats totally not related to your current self-inflicted damage.

2 Likes

Not sure if i will be able to achieve my objectives, but it makes sense to try again fresh. But at minimum i will have to lower the tx power (for whatever reason).

You are on your own . It causes connection drop.

1 Like

To be clear, you do understand that your settings can cause the stability issues you're experiencing, correct?

What's the reason?

Yes i totally understand and it was not clear until you guys informed me. Anyways to be fair to you with the effort you put into this to set me on the right path, my whatever reason is controversial and has strong opinions either way, concerning health impact of focused RF frequencies of wifi strength.

1 Like

I understand some people experience what's called "wireless sensitivity."

Gotcha.

You can optimise your Tx power if you can find a way to get at the signal level - a WiFi analyser on a mobile phone, or even some info from a laptop with a WiFi interface.

As long as the signal level is at least -67dBm (*) where you want to use WiFi devices you should have satisfactory performance, so adjust the router Tx power so that your test device is consistently reporting at least that signal level in your target locations. You may find long term that slight tweaking of the Tx power is required to achieve best results but this strategy should give you a baseline. Some devices might also perform better, or worse, than these generalisations too.

(*): source - SIGNIFICANCE OF TRANSMIT POWER LEVELS section

Well, higher wifi speeds use less airtime to transmit same data at same power. By design you have to stay 20cm from wifi antenna - i.e you can put it in your bed but dont hug it ( tell that to my moms radiomanic cat who sleeps on warm access point)

1 Like