ASUS RT-AC58U crashes under heavy load/ after a while

Can someone clarify if the notice in the wiki There have been multiple reports of instability of this device under load. is still relevant with openwrt 19.07.x?

I have been using code 19.07.1 for more than a month, with ISP speed of 150-up/ 50-down.

We have 10 wireless devices at home simultaneously accessing wifi on 2.4 and 5ghz. The router has been very stable for me.

openwrt-19.07 is using kmod-ath10k-ct-smallbuffers, which reduces the memory pressure a bit (however, the same patches to reduce ath10k's buffer sizes was already present in openwrt-18.06). Despite these mitigation patches to reduce the memory pressure, 128 MB RAM is very limiting for devices with two ath10k based wireless cards and can be considered insufficient. If you're looking to buy a rt-ac58u, don't (look for devices with 256 MB RAM or more instead) - if you already own one, give it a try, but be prepared for OOM conditions and crashes.

fwiw, do you use IPv6?

There is a known issue where ethernet controller stops working in other devices using IPQ401x, such as: EA6350, EA8300, Fritzbox when IPv6 is enabled.
https://bugs.openwrt.org/index.php?do=details&task_id=2741

Yes, I have disable IPv6 DHCP6 as I donot need it in my home network. Though link-local address FE80::/10 are assigned automatically.

Maybe you have this problem OpenWRT 18.06.5-18.06.7 and IPv6 , if yes , you need double autorize with 5 seconds delay. If so , please say here and in my theme.

My ISP is not ipv6 so i can't confirm this, may be @bill888 can confirm.

do you have any transmission/p2p experiences? or constant http downloads or steam/origin/epic? cause mine died with recent releases when i did "heavy" downloads.

What's your ISP speed and how many concurrent live sessions do you have on your network ?
P-2-P does not crash my router, however its possible I am running P2P on single client there is no impact.
I have ran 4-5 live HD streaming sessions on Youtube, and Netflix and they dont seem to affect my network.

as i said i have problem with recent releases. i still not updated but i would like to know what users experiencing with the new one with this solution.

I know this is a dead thread, but I went out and bough 2 ACRH-13s, equivalent to the RT-AC58U, before I realized they only had 128MB of RAM. I went out and flashed one anyway to decide if I should return it. I've run a lot of testing and so far I have not seen free memory go down below 50% (or available below 30%) with multiple 2.4, 5GHz, and ethernet clients. No crashes either. I'm on the 19.07.2 official build.

1 Like

ezviz w3 and same too , works good and fast enough , installed irqbalance and anabled it , see below

I still have stability problems with wifi. 70% time crash 5ghz, 30% time crash both.
Free memory 20-30% and I did swap to external HDD, but no succes.

From addons I have samba, transmissions UPnP and wifi schedule (tu turn off wifi at night).

Hello. I'm going to buy this router, are there any problems with using OpenWrt on it?

I have a hAP ac2 (IPQ4018 + 16MB ROM + 128MB RAM) and works good with ath10k-ct-smallbuffers although I'd look for a 128+MB RAM device for future proofing.

1 Like

Hello

I'm not using OpenWRT yet; though planning to use it with my AC-58U Router. If memory is a problem; I was wondering if plugging in a USB3.0 Stick with SWAP partition to the device could help with it. It wouldn't make it go away; but at least make it stable?

Linux kernel really sucks when it comes to low memory and swap situations - so I don't think the problem is actually OpenWRT; rather than the kernel itself.

Did anyone try this?

There were multiple reports of instability under load, likely due to 128 MB RAM being insufficient for two “ath10k” radios.

Prior to 19.07, using the non-“ct” ath10k drivers and firmware could improve stability (default was kmod-ath10k-ct).

19.07 is now using kmod-ath10k-ct-smallbuffers by default, with many reporting no issues for this device.

There are issues configuring vlans from LuCI for ipq40xx boards, please edit /etc/config/network directly.

1 Like

Don't do it, if you throw a swap partition at it, it will start using it even though you don't need it. if you start getting oom killer going on, only then you start thinking about that again. forget about it for the time being, considering that the current OpenWrt version for that device uses a different driver.

1 Like

Hmm makes sense..

As I said; I don't really like Linux's memory management strategies :smiley:

There seems to be less people reporting this issue anyway; so perhaps it's of thing of past now. My concern right now; even without 'fancy' modules; my 'stock' firmware is on about 70% RAM... I guess I won't find out how it will fare until I do it :slight_smile:

1 Like

Bad idea. In case of memory pressure you will tire stick and also you'd have horrible performance of everything