Asus RT-AC56U installation fails

Hi OpenWrt-folks,
I recently bought a used Asus RT-AC56U router. I made a reset and logged into the default router UI. I configured the router and it worked fine.

I noticed that a new firmware version was available. I chose to let the router UI take care of the upgrade. The upgrade failed. The router became unresponsive - no access to UI, no internet. Dang.

I followed the restoration guide

The router seems to go into recovery mode as it should with the power LED flashing slowly.

But the the transfer of the new firmware failed somewhere around 70% into the process.

I tried this several times.

All right - OpenWrt to the rescue?

I followed the guide here

I was using the tftp method. But the transfer does not succeed "Transfer timed out".

I tried to set my IP to and Subnet - no joy.

I tried renaming the openwrt-15.05-bcm53xx-asus-rt-ac56u-squashfs.trx file to something shorter. Still the same.

I read somewhere, that a "Transfer timed out" message probably means I never even connect properly to the router.

I had only LAN cable in the router while doing this.

Any ideas very welcome - before the gadget goes to the scrap yard.

With the router in recovery mode, first do a basic connectivity test with ping
If you get no reply, check if your ARP table now has an entry for If there is none, the router is
unreachable over the network and flashing attempts will also fail.
If connectivity is established, watch the tftp transfer with the tftp client's verbose mode or tcpdump/wireshark.
Try a different network cable, network interface, PC, tftp client software or operating system and repeat the previous tests.
Maybe a serial console would show what is happening on the target.
Disclaimer: I don't have this device.

The old wiki is unmaintained. Please use the current RT-AC56U device page and TFTP guide.

Openwrt 15.05 is unmaintained. The current stable release for the RT-AC56U is 18.06.1.
Either one should be OK for unbricking, though.

A hardware defect would certainly be a good reason to dump the device.
Firmware problems should be fixable depending on your available time, since the bootloader seems to be intact.

Thanks for your reply mpa, really appreciate your help.

I tried another cable today but I still don't seem to have much luck reaching the router.

PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable

arp says

$ arp
Address                  HWtype  HWaddress           Flags Mask            Iface                      (incomplete)                              enp6s0

Best regards,