Asus rt-ac5300

Hi guys' I need some help, I have read through the quick guide and several other ways to try and resolve my issue.

Having installed openwrt-22.03.4-bcm4908-generic-asus_gt-ac5300-squashfs.bin, I am unable to access the internet.

here are my config files:
/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/xx'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan5'
	list ports 'lan6'
	list ports 'sw'
	option sendredirects '0'
	option multicast '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option delegate '0'

config device
	option name 'eth0'
	option promisc '1'
	option ipv6 '0'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth0'
	option delegate '0'

/etc/config/firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

any help would be greatly appriciated :slight_smile:

many thanks inadvance

nooby

Did you alter this from the default configs in any way?

1 Like

hi there thank you for your kind reply..

the top one is default.. however i had to create the eth0 as it was not configured. The OpenWrt instalation only added 1 bridged port with no other adapters or interfaces

thank you again for you reply

nooby

Hi there,

So having no joy with setting up openwrt on the asus gt-ac5300, I decided to download the asus firmware FW_GT_AC5300_300438648377. to replace the openwrt-22.03.4-bcm4908-generic-asus_gt-ac5300-squashfs.bin. All works so I decided to re flash it again with openwrt-22.03.4-bcm4908-generic-asus_gt-ac5300-squashfs.bin, hoping the setting would be retained but unfortunately I am presented with the same one item which is the the bridged device br-lan with nothing else picked up. I am not at this moment concerned with wireless I would just like to get the router going and getting access to the internet. It would appear all other devices will have to be manually added and configured :-(.

Back to more reading wish me luck lol.

Did you find any solutions?

Duplicate post:

I follow 'nooby' suggestion and flash the 22.03.4 firmware to my RT-AC5300 using the Asus firmware restoration utility but my RT-AC5300 never reboot and the power led just continue to blink ! Does the GT-AC5300 firmware can really be flashed on RT-AC5300 ?