Asus RT-AC3100 Bricked?

Hi, I hope any amazing person here can help me with my Asus RT-AC3100 just brought today. I tried to upload the openwrt trx file to install openwrt to my router, but it said Asus does not allow non genuine firmware to be installed. So I found this on openwrt page (not my model but I figured I would try anyway)

" ASUS Firmware Restoration Tool

Easiest solution for Windows users, confirmed working as of June 2019.

  1. Download the ASUS Firmware Restoration Tool but don't open it yet (Recommended version)

  2. Unplug your computer from the router

  3. Put the router into Rescue Mode by: turning the power off, using a pin to press and hold the reset button, then turning the router back on while keeping the reset button pressed for ~5 secs until the power LED starts flashing slowly (which indicates the router has entered Rescue Mode)

  4. Important (if you don't do this next step the Asus Firmware Restoration Tool will wrongly assume that the router is not in Rescue Mode and will refuse to flash it): go to the Windows Control Panel and temporarily disable ALL other network adapters except the one you will use to connect your computer to the router

  5. For the single adapter you left enabled, temporarily give it the static IP 192.168.1.10 and the subnet mask 255.255.255.0

  6. Connect a LAN cable between your computer (make sure to use the Ethernet port of the adapter you've just set up) and port 1 of the router (not the router's WAN port)

  7. Rename openwrt-XX.XX.X-ramips-mt7620-rt-ac51u-squashfs-sysupgrade.bin to factory.trx

  8. Open the Asus Firmware Restoration Tool, locate factory.trx and click upload (if Windows shows a compatibility prompt, confirm that the tool worked fine)

  9. Flashing and reboot is finished when the power LED stops blinking and stays on

  10. That's it! (Don't forget to re-enable any network adapters you disabled earlier)"

and then now only the power light is on for my router. The TRX file I downloaded was the one for my router. Any help from all you beautiful soul would be much much appreciated.

Did you try following the instructions for your device?
https://openwrt.org/toh/asus/rt-ac88u?s[]=asus&s[]=rt&s[]=ac3100

1 Like

No, I haven't. Thank you for your help, let me try it now, hopefully it save my router from being a brick. I will update here in 15 to 30 minutes. Thanks so much!

Hi, I tried to followed the page instruction, and 3 times the network is reset and the router is still on recovery mode. I am sorry but this is very complicated for me. If any beautiful soul out there can help (maybe connect on phone?) I will pay tips. Thank you, in the meantime, I will keep trying to figure out with my not too functional brain. :sweat_smile: