ASUS RT-AC2400 | PPPoE doesn't work on OpenWrt

I installed Open WRT as soon as got router from the box (through Windows TFTP with octet mode), it booted up good, but PPPoE wouldn't work. I connected it to my old router via LAN and it worked through DHCP. Making wireless networks worked as well. In OpenWRT error is displayed as "Unknown error: USER REQUEST".

I connected to internet via old router from this one, installed tcpdump from Software tab and captured some output with it:

It seems that PADI request is sent out, but no response.

After it i flashed back to old firmware and it was working. Then i flashed back to OpenWRT and it doesn't work again. May it happen because of wrong installation, or is it an OpenWRT bug?

? I did not find that router under Table of Hardware (OpenWrt supported) list.


Perhaps the following two other topics dealing with same error assists,
PPPoE “unknown error (USER_REQUEST)”
PPPoE Connection “Unknown error: User Request” // Deutsche Telekom VDSL

What version of OpenWrt is installed?

Have you tried 22.03.0-rc5 ?

Use LuCI to upgrade

Release candidate 6 is available for download for routers with MT7621 SoC.

Thanks, i figured as much that the problem is with auto resolving provider configuration. Going to try RC now.

I installed 22.03.0-rc6, it worked. Amazing :slight_smile:

Glad it worked out for you.
Please mark this topic as resolved for others searching/referencing similar problem. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.