Asus rt-ac1200 v2

Hello.
I bought the rt-ac1200 v2, i wanted to flash openwrt on it. The flash method is straight forward, issue am having is when i turn off the router, press reset button, turn on the router while still pressing reset, the power led start blinking fast while it is stated that it shoukd blink slow? For rescue mode, even keeping reset button for a long time the power led blink never change to a slower rate, try to upload the firmware fail saying router is not in rescue mode.
1-what am i doing wrong?
2-is there a huge difference using openwrt vs factory firmware, when the factory firmware seem to have the things i need for now.
Thank you for your feedback.

have you seen https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=a4bf562aa71ad1e3dcffa392b79110d803a93f11 ?

I will surely have a look once am free at home, thank you.

@frollic
I tried the same method b4 but i thought i will give it an another try just in case.
i prepared everything on the laptop side, power off the router, press the reset button, leds flash and then power led start blinking but not slow, so i kept pressing the reset hopping to get a slower blink but this never happened, so either way i stopped pressing the reset button plugged the network cable and tried to upload the factory flash file, after 31 seconds the firmware restoration stated that the router is not in rescue mode, tried to upload that flash fike multiple times all same result, then retried the whole process, the router seems not wanting to go rescue mode?

Tried the 2nd approach, using the TFTP client?

No because am thinking that the router is not actually in rescue mode, yet, maybe.
kinda confuses me that each search i made are clearly mentioning the slow blinking, even couple of youtube videos show how it is slowly blinking something like, beep ..............beep, the blinking am getting beep . beep . beep, so am not sure even if the router is on rescue mode, hence why i did not venture to TFTP yet, in a hope that someone might have had the same issue and my guessing if the router is not actually in rescue mode TFTP also wont work, but i will be ready to give it a go when i have more time.
Hence my 2nd question in the main post if it is worth it to install openwrt if the factory firmware so far actually have what i need.
In other words what are the benefit of openwrt on this router over asus firmware.
Thank you for your follow up, appreciate it.