ASUS OnHub SRT-AC1900 ... Vlans?

Hi there,
I'm trying to configure vlans on my two ASUS OnHub SRT-AC1900, without sucess.

I'm using OpenWrt 23.05.2 r23630-842932a63d / LuCI openwrt-23.05 branch git-23.306.39416-c86c256 , before that I used snapshot, rc1, rc2...

In this router there is the old vlans way (Network -> Switch...) and the new one (DSA? it's in network -> intefaces -> devices), which is a little confusing.

I've tried adding the vlan through the "old way", and the vlan does not work. I've tried turning off vlans through this way, and enabling in the "new way" (dsa) and... got locked out, had to reflash.

Can anyone help me?

did you apply the same vlan on the client(s) connecting ?

Yep. They are connected in a USW-Pro-24-PoE, and I have other two routers (from linksys, with openwrt) on the same network, but connected to a USW-Pro-24 and ... working.

I've tried using vlan 1 untagged and vlan 40 tagged... no sucess. Tried both tagged and almost got locked out (had to use the other port)

"br-lan" on this router is a bridge between eth1 and eth1.1 ... for me, this is cofusing.

Trying again, now. I created vlan 40 on Network -> Switch -> Add Vlan

Now on Network -> Interfaces -> Add new interface. Gave it a name (040_iot), static address, device eth1.40, an Ip address, netmask, firewall zone, save, save & apply

And... it's working. :unamused: