Asus onhub ethernet port can't communicate with bridge since 24.10 and move to DSA

I have an ASUS Onhub and I use it as a dumb AP. It has 2 Ethernet ports, one is labeled as lan(eth1) and the other as wan(eth0) by openwrt by default.
The wan(eth0) is configured statically 192.168.0.251 and is connected to the main router which does DHCP
The lan(eth1) has a computer connected, the computer gets its IP via DHCP
Both ports are bridged br-lan. No VLAN is explicitly configured. The computer can talk to other devices and same for the Onhub but they can't talk to each other, PING and TCP do not work between these devices. The firewall is off (service firewall stop).

I tried adding a vlan but that did not help, I lose all connectivity to the both devices from a separate device (192.168.0.123).

This used to work with swconfig.

$ ubus call system board 
{
	"kernel": "6.6.73",
	"hostname": "onhub",
	"system": "ARMv7 Processor rev 0 (v7l)",
	"model": "ASUS OnHub",
	"board_name": "asus,onhub",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "24.10.0",
		"revision": "r28427-6df0e3d02a",
		"target": "ipq806x/chromium",
		"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
		"builddate": "1738624177"
	}
}
$  cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfa:xxxx:xxxx::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
        list ports 'wan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.0.251'
	option netmask '255.255.255.0'
	option gateway '192.168.0.254'
	option dns '192.168.0.254'
$ ip address show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1502 qdisc mq state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:b4 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::xxxx:xxxx:xxxx:xxb4/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1502 qdisc mq state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:b5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::xxxx:xxxx:xxxx:xxb5/64 scope link 
       valid_lft forever preferred_lft forever
4: lan1@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:b5 brd ff:ff:ff:ff:ff:ff
5: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:b4 brd ff:ff:ff:ff:ff:ff
12: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:b5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.251/24 brd 192.168.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fe80::xxxx:xxxx:xxxx:xxb5/64 scope link 
       valid_lft forever preferred_lft forever
13: phy0-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:bc brd ff:ff:ff:ff:ff:ff

swconfig for /etc/config/network prior to upgrading

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth0.2'
        list ports 'eth1'
        list ports 'eth1.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.0.251'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.0.254'
        list dns '192.168.0.254'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '2 0t'

I also tried explicitly adding a vlan config but I lose connectivity to the onhub but can still reach the computer connected to it. This is the config I tried:

config device
	option name 'br-lan'
	option macaddr '2c:56:dc:de:16:b4'
	option type 'bridge'
	list ports 'lan1'
        list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.0.251'
	option netmask '255.255.255.0'
	option gateway '192.168.0.254'
	option dns '192.168.0.254'

Any ideas ?

This was wrong....

The below looks mostly fine...

it should explicitly be configured as untagged, if that is the desired state (add :u* to each of the ports.

Then, for the below, you need to change the device to br-lan.1

Do you have other VLANs that you'll be adding? If not, there's no need to do this in the first place.

It was the only way I could get it to work with swconfig in the previous version.

Yes I would think so too but it this state the device and the computer cannot talk. to each other and that is what I am trying to fix.

I do not need VLANs at all, I am only trying to get things to work and that is why I tried them.

I tried changing to (I used 5 instead in case 1 was the problem I realised that this was unnecessary as /proc/net/vlan/config shows no VLANs configured)

config device
        option name 'br-lan.5'
        option macaddr 'xx:xx:xx:xx:xx:b4'
        option type 'bridge'
        list ports 'lan1'
        list ports 'wan'

config bridge-vlan
        option device 'br-lan'
        option vlan '5'
        list ports 'lan1:u*'
        list ports 'wan:u*'

but after this I can access neither the device nor the computer.

How can I debug this further?

config device
        option name 'br-lan'
        option macaddr 'xx:xx:xx:xx:xx:b4'
        option type 'bridge'
        list ports 'lan1'
        list ports 'wan'

config bridge-vlan
        option device 'br-lan'
        option vlan '5'
        list ports 'lan1:u*'
        list ports 'wan:u*'

and

config interface 'lan'
	option device 'br-lan.5'
	option proto 'static'
	option ipaddr '192.168.0.251'
	option netmask '255.255.255.0'
	option gateway '192.168.0.254'
	option dns '192.168.0.254'

If you don't need VLANs, let's just go back to the basics.

What is the specific goal here? I'm guessing you want the lan and wan ports to both be part of the bridge such that the wan port is 'just another' lan port? If so, please confirm. If not, please explain.

Meanwhile, I'd recommend that you reset to defaults and we'll start from a nearly default condition. Go ahead and make the necessary changes to the lan interface (i.e. the address), disable the DHCP server, and enable wifi. Then post your complete config here for review and the recommended methods to achieve your specific goal(s):

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Yes correct

I reset to default but thought I'd try @mattimat's idea and that just worked.
Thanks both of you for your time and patience. I'd been banging my head for hours on this.
Any idea why it doesn't work without VLANS? Like just with the config below? Just PEBKAC?

Should work also without vlans just fine.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.