Associated Wifi at 0% level

I do not achieved to radiate anything with my wifi. In the web interface the wifi it is shown as 'on' but, the signal is 0%...

These are the interfaces. radio0wm is which are attached to the wifi-iface and it is bridged to the eth. But, the problem seems to be in the wireless device.

This which I have in the /etc/config/wireless and /etc/config/network files:

config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr	'00:25:CA:3C:1F:97'
	option channel '11'
	option phy 'phy0'
	option hwmode	'11g'
	option path	'soc0/soc/2100000.aips-bus/2190000.usdhc/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode	'HT20'
	option country	'DE'
	option txpower	'18'

config wifi-iface 'wmesh'
	option device 'radio0'
	option network 'radio0wm'
	option encryption 'psk2+ccmp'
	option mode 'adhoc'
	option ssid 'ingerev'
	option 'mcast_rate' '18000'
	option bssid '02:CA:FE:CA:CA:40'
config interface 'radio0wm'
	option type 'bridge'
	option stp '1'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ipv6 '1'

config interface 'lan'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ipv6 '1'

I think I saw that when there were no clients connected. Does it change when you connect some clients?

1 Like

It looks like you're trying to set up a mesh. For a regular access point you use mode AP.

In meshes, adhoc mode is seldom used any more, 802.11s (mesh) mode should be used instead whenever possible. I don't think encryption is possible on adhoc mode. Adhoc requires a backing mesh route control layer such as BATMAN. 802.11s has an optional built in mesh routing.


In my opinion, this is not the reason. Firstly, because here is not clients concept because, it is a mesh. Secondly, because if I scan I do not find the wifi signal.

Yeah. I am trying it.

If I set option encryption 'none' wireless changes to disabled or not associated state.

Yes, this is the final goal but, previously I want to test direct connection with another device using only in the both of the nodes adhoc mode.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.