Assign public IPv6 address on guest network with Linksys EA6350v3

Hi all, I'm trying to get IPv6 network working on my guest network. However public prefix won't assign on the interface.
Digging through some posts and relevant articles on OpenWrt wiki, the problem seems belonging to the ISP, that it is not possible to assign public prefix on two different interfaces with this IPv6-
PD address.


Network configuration files

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd80:f187:c471::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.23.1'

config device 'lan_dev'
        option name 'eth0'
        option macaddr '60:38:e0:7a:1e:5a'

config interface 'wan'
        option ifname 'eth1'
        option proto 'pppoe'
        option username '****'
        option password '****'
        option ipv6 'auto'
        option keepalive '0'

config device 'wan_dev'
        option name 'eth1'
        option macaddr '60:38:e0:7a:1e:59'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 5'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 1t 2t 3t 4t'

config interface 'lan3'
        option proto 'static'
        option ifname 'eth0.3'
        option ipaddr '192.168.8.1'
        option type 'bridge'
        option netmask '255.255.255.0'
        option ip6assign '64'
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'lan3'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'lan3'

Any ideas? Thanks in advance.

My educated guess would be that if you assign the whole /60 prefix to an interface, there is simply nothing left to be assigned to another one.

1 Like

But the PD address assigned by ISP also comes with /60 prefix. So change the prefix on lan may help?

Ha I just changed them both to /64, it's working fine now.

If your IP assigns you a /60, then you have 4 bytes to assign different prefixes to each of your networks, each one with a /64 and a different prefix.

2 Likes


For anyone configured guest network with the guide on OpenWrt wiki: Don't forget to allow ICMPv6 in Firewall!

  # === Optional for IPv6 add ===
  
  # Allow ICMP input for guest zone,
  # for DHCPv6 in the guest network
  config rule
    option name 'Allow guest ICMP input'
    option src 'guest'
    option proto 'icmp'
    option target 'ACCEPT'
    option family 'ipv6'  
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.