AsRock G10 OpenWrt problems

Great. Some light reading:

For most developers, it makes sense to stat with the build system. You can set it up with the information provided here:

This is a great retirement project. You can start learning about all the millions of lines of source code that have been written by volunteer developers. And if it takes you several years to understand how this all works, somewhere along the journey you might realize just how much work has gone into this project.

You don't need to contact anyone. But there is an openwrt developers mailing list (just google that), and of course the "for developers" section of the forum.

If you've worked with digital logic, hardware/firmware/software can sometimes be considered interchangeable in that it boils down to logical operators. I mean, hardware and software are very different animals, but if you're versed in digital logic electronics (especially at the bare metal level), you can learn to code.

1 Like

The solution is at the end, again a big thank you to our friend lleachii

Let us know when you've got a PR that will fix the problems you've been complaining about. :slight_smile:

1 Like

What you would be looking at (if you were you be serious about it), tends to be (a lot) easier done on x86_64, just add a ath5k/ ath9k/ ath10k/ mt76 WLAN card[0], a mainstream general purpose linux distribution, hostapd/ wpa_supplicant and get cracking on mac80211/ hostapd. Get OpenWrt and its way of managing patches, wrapped in patches, wrapped into a quilt series - with tons of target specific- and generic patches out of the picture, just work on the code that (would) need[s] changing (mac80211/ drivers/ hostapd).

This is also an easy explanation why 'OpenWrt' would be the wrong tree to bark at for this functionality, you're looking at mainline linux and hostapd instead (still not going to happen easily[1]).

[0] whatever is easily available, cheap and comes closest to your desired target.
[1] but you'll see the details, once you get intimate with the 802.11 specifications (IEEE RFCs) and the code implementing them

1 Like


It was very difficult to read this thread since the OP vandalized it by editing every post and adding irrelevant text. As a reminder, that doesn't help others interested in reading to solve their problem.

The solution is at the end, again a big thank you to our friend lleachii

You seem to want:

This is called "WiFi bridge" in some marketing terms. Others noted that is not possible.

Is there a reason you're insisting that it is (please do not refrence the proprietary ISP firmware when responding)?

You also put:

config wifi-iface 'wifinet0'
     option device 'radio1'
     option mode 'sta`
     option network 'lan'

STA is an invalid config.

:spiral_notepad: BTW, please stop making mutiple posts for the same issue. I just realized when searching for a reference thread - that you've asked this same question before. Multi posts take away time from others who need help with thier issues too - to be resolved by the community members.

The solution is at the end, again a big thank you to our friend lleachii


I'm not sure what this means. What are you asking for?

Are you saying that you don't want people to respond?


(Hope that's not a "novel".)


Livebox 6 < -WIFI 5GHz - > OpenWrt Relayd < - Lan - > Orange TV

With relayd all is ok except the TV

The solution is at the end, again a big thank you to our friend lleachii

I'm not sure why you posted that.

If you don't wish to provide configs (maybe that's what "novel" means?), it'll be almost impossible to assist.

Do you know how to copy/paste the network and wifi configs of the OpenWrt?

Describe, please (hard to guess).

  • Do you get IP?
  • Does it freeze, what?

Also do you know if you IPTV is IPv4 or IPv6 based?

Also, post DHCP configs (configs are important and it's possible you configured a network conflict, etc.).

Config is exactly this exactly except that the AP master is currently a LiveBox 6:
I also tried with an SFR box

The TV box does indeed obtain an ip address from the Livebox 6 but the multicast TV stream does not pass
The DHCP on the OpenWrt is obviously disabled

I see no config on your link. So I surmise you do not know how to post them.

Please provide your settings. Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp

:spiral_notepad: Web GUI screenshots of the config are less preferred. E.g. pics of LAN, WWAN and relay, wireless, etc.

Whoa, multicast?!

(It's hard to tell since you edited your posts if you ever mentioned that.)

:warning: Did you ever try igmpproxy before a relayd setup???

You should be able to install/configure igmpproxy in your current setup. In fact, I beleive you'll need it for multicast (:spiral_notepad: I can't explain why without "writing a novel"). You defnatly need it for WWAN or any standard downstream setup.

Ok well since I'd have to ask a series of questions about your upstream and dowstream IP, dhcp config, what is the upstream range, etc...that are simply in the configs and pics...

I won't be able to assist without writing questions in "novel" format.

Sorry I couldn't guess.


Ummmmmm, no. Seems like you didn't properly configure the device (igmpproxy was never mentioned) and you won't show configs.

But feel free to hold your opinion. Have a good day and the best on your device setup.

If you wanna show configs, feel free to update.

(IPTV box works here with relayd on Atheros WiFi chip. Multicast streams on wired/wifi downstream works here with proper igmpproxy setup on OpenWrt device).

:spiral_notepad: i.e. you never setup multicast and never mentioned it to the community until the last few posts - so I won't be able to help adding/changing configs before I see the current ones, no matter how much one claims they match pics or steps - perhaps someone else could guess, you could also try installing and configuring igmpproxy

1 Like

These diagrams are unhelpful without configs, regrets I can't assist. I also am unsure if you mean multicast or unicast on-demand.

Bridging STA interfaces is not a possibility provided by the IEEE 802.11 standards, as it would require sqeezing a fourth MAC address somehow into an IEEE 802.11 packet header which only specifies space for three MAC addresses, there can be no standards compliant way to accomplish this - only proprietary ones

From what I know the number of MAC addresses in a 802.11 frame is decided by the To DS and From DS bits found in the Frame Control field. If both of them are set to 1, then the 4th MAC address is required. And with 4 addresses available, it is possible to connect 2 Ethernet networks via Wi-Fi.

I also hear that the actual implementations using that 4th address differs from vendor to vendor, making them incompatible. I haven't get into detail of any implementation, so I cannot say for sure why it is so hard to do. At first glance, using 4 addresses looks like routing to me (2 IP addresses + 2 MAC addresses).

Ileachi , many thanks , you put me on the right track because now it works

I put this in igmpproxy

config igmpproxy
        option quickleave 1

config phyint
        option network wwan
        option direction upstream
        list altnet 
        list altnet
        list altnet
        list altnet

config phyint
        option network lan
        option direction downstream
        list altnet ---- IP box

I have found:infos with tracert dns orange dns orange but not at this time ip first link
192.0..0.0/8 ip by my Libebox 6

On the other hand i do not understand why with 2 * OpenWrt boxes there is nothing to do

It's great because i will now be able to operate my box's in WIFI AX

1 Like

I found the previous request which described the TV problem well

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.