ASRock G10 AC2600 experience

I'm looking to build a mesh network with VLAN support, so I can have one main WiFi network and one for my IoT devices. It sounds like OpenWRT could do this. I found a good deal on the ASRock G10 AC2600, so I'm considering buying this router. However, the OpenWRT support is listed as experimental. Does anyone happen to have this router? I'm wondering how experimental "experimental" is exactly. I will be main driving it. If it just means I can't use the IR port, then whatever, I've never used a router with IR anyway. If it's super unstable, that's a no, I will be main driving this router. Both would make it experimental, but one is something I don't care about and the other is a vital aspect. In fact, I plan to have multiple of the same device in my network.

Not experimental at all, supported by 22.03.

Dunno what main driving it means...

I meant as in main driver/daily driver. Relying on it full-time.

But I guess I misread about the support then. If it's fully supported, I am buying this.

There is only one thing to consider, the g10 doesn't have any convenient means of recovery in case of a (soft-)brick, no push-button tftp recovery available, if it bricks, you need serial console access.

I wouldn't buy top dollar for it, but otherwise it's a solid device and in working/ used condition worth taking up a bargain (no quite up the level of r7800 or nbg6817, but similar to c2600 and tew-827dru v1), but still have a look at Black Friday deals of more contemporary devices (e.g. the rt3200 for ~45 EUR a few days back would have been hard to beat).

I just ordered 4 (including 1 for a friend) for 157 euros including shipping. Sounds like a decent bargain to me.

I wouldn't call that a bargain, even less for buying four of them in one order…

It's still a decent device (as long as you are well aware of its non-existent recovery options).

The RT3200s at 45€, make the G10s look expensive.

1 Like

I'm afraid I can't find the other routers you guys are mentioning. They're completely unavailable here. I already had to order these from Germany, which is one country over for me. Last known price for some of the ones you guys recommended according to is in the hundreds of even in the 200s. BTW, when I say 157, that's for 4 of them in total. They were 33 euros each, excluding shipping. I might be able to sell my shitty Fritzbox set for the same money I just spent.

Well, look at it from the other side.

  • 2015 vintage hardware
  • it has always been an unpopular device
  • the last OEM firmware is from 2017 and buggy (security and otherwise)
  • ASRock has pulled their streamboost servers (providing game profiles for game acceleration) in 2018
  • no user-friendly recovery, at all
  • this really is selling off remaining old stock, scrapped together from dusty shelves

With OpenWrt you can do a lot with them, but stock, as you get them delivered (what you're paying them for), they're well past their shelf life - and there are better, contemporary, devices available for only slightly more money. I hope you got them at least in new/ factory-sealed condition for that price.

Again, I don't want to diminish the hardware, it's solid and working nicely with OpenWrt - actually I bought one myself last year, it's fine.

Yeah, they were new. It does sound bad if we're talking factory firmware then, but in practice the only relevant bit to me would be the recovery part, since I was never planning to use stock firmware anyway unless it somehow beat Ubiquiti or some brand like that. Which I definitely wasn't expecting it to. If it's half-decent for its price when running openwrt, that's good enough for me. And well, I haven't been able to find a better deal so far. Mostly routers that cost more and are (at least on paper) way slower. I was almost ready to buy prosumer grade stuff until I thought of using OpenWRT and then found this thing.

In regards to serial console recovery, I think I briefly came across something involving serial converters? RX, TX, DTR, CTS, UART, that sort of stuff? Because I have a million different microcontrollers and those sorts of converters are basically everywhere in my house. I lost most of them and I still have plenty anyway. Some people have cockroaches. I have serial converters.

On the good side, you can flash OpenWrt from the OEM firmware as-is, no fuss involved.

The serial console is 3.3V based, so a standard 3.3V USB2serial adapter will do. See J6 (small unpopulated 4-pin header at the middle/bottom of the PCB; the header is solder-filled though).

That should be easy enough. I read something about using ssh after attaching the serial converter and running a script located on the router. That honestly doesn't sound too bad at all. I've rooted a Toon thermostat before, now those are a pain in the ass. You need a Raspberry Pi and a million jumper wires, and if you do one wrong it won't work. Serial stuff and a bit of solder are a breeze compared to that. I've seen way worse.

Because of the difficulties to date with boxes equipped with mt76xx i ordered an AsRock G10 box at 70 euros

I received it today and tried very quickly
With stock firmware all my problems are solved: Repeater + Orange TV + DLNA + printer server all is good
A little difficult to configure because it is only possible in router mode
For WIFI speed it is very good
In addition, the box is supplied with an EzCast HDMI TV key, too bad it is 2.4 Ghz

I am surprised that in the forum it is spoken of as a good product.

I will receive a second one that I will try with OpenWrt

I got my ASRocks now. They seem at least decent. My network did slow down once I tried to do Batman Advanced, so I'll construct a more static network instead. LAN to WAN is capped around 450 Mbit though, because you really want a MT7621 for that. But you've already mentioned that chip. I got a secondhand Xiaomi Redmi AC2100 for 10 euros including shipping for that (got very lucky too find a seller that is interested in my project). Even then, you want OpenWRT Snapshot because of some fixes with hardware NAT that won't get backported to current stable. The ASRock routers are solid enough network nodes though. Don't know that I'd have paid 70 bucks for them. At that point, I'd have considered secondhand Ubiquiti UniFi access points.

Noone in this thread had anything negative to say about them...?
Except perhaps the recovery being difficult.

Just found one on amazon-de for 44,44 Euro.
As I couldn't find the RT3200 for that price, I just ordered one.

When i get the second i will install openwrt

I hope it will do well
LiveBox 6 < -- > Repeater + Orange TV + DLNA + Samba + USB Printer all in Wifi 5 Ghz

-> Which has never worked with my many mt76 boxes except old PandoraBox

I got mine a couple of days ago, flashing openwrt from the oem ui was easy.
Just tried the recovery process, serial console is working.
I interrupted the boot process and from the u-boot prompt did:

(IPQ) # setenv ipaddr
(IPQ) # setenv serverip
(IPQ) # tftpboot <filename>

followed by a "bootm" command.
<filename> was one of:

  • openwrt-22.03.2-ipq806x-generic-asrock_g10-squashfs-nand-factory.bin
  • openwrt-22.03.2-ipq806x-generic-asrock_g10-squashfs-nand-sysupgrade.bin
  • openwrt-22.03.2-ipq806x-generic-asrock_g10-initramfs-fit-uImage.itb

Each time if failed to boot and complained about

## Booting kernel from FIT Image at 44000000 ...
ERROR: can't get kernel image!

Any advice ?


Did you try:

setenv ipaddr
setenv serverip
tftpboot 44000000 openwrt-22.03.2-ipq806x-generic-asrock_g10-initramfs-fit-uImage.itb

(for practical intents and purposes, rename the initramfs image to something shorter)

0x44000000 is the default address, so no need to supply this parameter (am I right ?)
I already renamed the file "openwrt-22.03.2-ipq806x-generic-asrock_g10-initramfs-fit-uImage.itb"
to "g10.itb" before trying the tftp recovery.

Other ideas ?