Aruba AP-105 Negotiation timeout Unkown speed read!

Hello to everyone.

I took it out with my solder and reprogrammed the MX25L12845EMI-10G IC using the Programmer and soldered it again.

I connect the ethernet cable directly to the computer ip addresses and everything is correct. Ap-105 does not detect the cable, so tftp does not work.

console output

AP-10x (ar7100) U-boot 0.0.1
DRAM: 128 MB
Flash: 16 MB
In: serial
Out: serial
Err: serial
Net: ag7100_enet_initialize...
ATHRF1E: Port 0, Negotiation timeout
ATHRF1E: unit 0 phy addr 0 ATHRF1E: reg0 ffff
eth0: d8:c7:c8:ca:9c:ce
eth0 up
RESET is un-pushed
Hit any key to stop autoboot: 0
##Booting image at bf040000 ...
Bad Magic Number
ATHRF1E: Unkown speed read!
Using eth0 device
TFTP from server; our IP address is
Filename 'firmware.bin'.
Load address: 0x80010000
Loading: *

this is printenv result

ar7100> printenv
bootargs=console=ttyS0,9600 mtdparts=ar7100-nor0:256k(uboot),16000k(firmware),64k(hwinfo),64k(u-boot-env)
bootcmd=run bootap
loadUboot=tftpboot 0x80010000 u-boot.bin && erase 0xbf000000 +0x40000 && cp.b 0x80010000 0xbf000000 0x40000
loadLinux=tftpboot 0x80010000 firmware.bin && erase 0xbf040000 +0xfa0000 && cp.b 0x80010000 0xbf040000 $filesize
loadStock=tftpboot 0x80010000 ap-105-stock.bin && erase 0xbf000000 +0x1000000 && cp.b 0x80010000 0xbf000000 $filesize
loadAll=run loadUboot;run loadLinux;
resetcmd=run loadLinux;
bootLinux=bootm 0xbf040000;
bootap=run bootLinux; run loadLinux bootLinux; run bootap;
Environment size: 744/65532 bytes

Does it help to force duplex speed on the pc? Or try other cable

1 Like

Thank you for your advice.
I tried what you said.
I tried 100mbps full duplex and 1gbps full duplex.
And finally I tried it with 8 wire connected ethernet cable. (I tested the cable is working.) But the problem continues.

Ok, I had it only happen once I use a Gigabit USB Ethernet Adapter
I set full duplex 1000 Mbps and it sent file correctly

I tftp flashed 15 of these devices, I used the Raspberry Pi and a Pomona Clip to flash them

1 Like

by the way I force full duplex from the device manager.

I have tried the ethernet port of the motherboard and use windows.
Do you think I should buy USB Ethernet?

I used a spi programmer, but an electronics engineer friend helped me. He mastered these the process.

Not sure if it going to fix your situation

Can you connect via hub or switch ?

How about reducing the speed duplex ?

I just find it easier to tftp from another network interface so I dont affect my other running stuff.

1 Like

Double check your tftp server

Look at this guide for the TFT server part for windows, I dont use windows

I use a switch, but the result is the same.
and now I tried 10 mbps full duplex is not working.

Ok, it could be issue with the actual port on the Aruba AP-105 ?

Does it respond to ping when it get its ip address ?

Are you sure the hardware is OK? Does it make an Ethernet link with stock bootloader / firmware?

Does the Ethernet link light on the PC or switch come on?

Writing directly to flash, you could put OpenWrt into the kernel partition (starting after the bootloader) and it should boot straightaway.

1 Like

I have a rj45 tester. I tested it and it lights up at 8 lights from the enet port.

And poe works from that port.

no but I have a rj45 tester. I tested it and it lights up at 8 lights from the enet port.

as @mk24 suggested you could see if you can insert the OpenWRT 19.07.3 sysupgrade file into your flash dump and write it again

Here are suggested steps

  1. Read your flash and save as dump.rom

Here is a binwalk of the stock firmware after the new -boot inserted

user@t30:~/AP-105_flashed/AP-105/BE0049050_00:0b:86:cf:7f:99$ binwalk new.rom >output.txt
user@t30:~/AP-105_flashed/AP-105/BE0049050_00:0b:86:cf:7f:99$ cat output.txt 

140752        0x225D0         U-Boot version string, "U-Boot 1.1.4-g62c452c1 (May 11 2019 - 21:29:36)"
141008        0x226D0         CRC32 polynomial table, big endian
1049088       0x100200        ELF, 32-bit MSB MIPS64 executable, MIPS, version 1 (SYSV)
1119856       0x111670        LZMA compressed data, properties: 0x5D, dictionary size: 8388608 bytes, uncompressed size: 6731856 bytes
6014792       0x5BC748        Certificate in DER format (x509 v3), header length: 4, sequence length: 1165
16384560      0xFA0230        gzip compressed data, maximum compression, from Unix, last modified: 2011-06-24 06:58:14
  1. Get the 19.07.3 sysupgrade file
wget -c
  1. insert it into your full dump rom (dump.rom)
    The seek value is taken from the binwalk output above
dd if="openwrt-19.07.3-ath79-generic-aruba_ap-105-squashfs-sysupgrade.bin" of=dump.rom conv=notrunc bs=1 seek=1119856 status=progress
  1. Write it back to flash

With serial console you can enable wireless and then test Ethernet from the device

1 Like

I disturb you. thank you very much i will try and write the result.

1 Like

markbirss sir I bought raspberry pi 4 and clips. Can you send your dump.rom?

My device is faulty. I flashed the file that markbirss sent with rasperryi pi and clips. The result is the same thank you very much for everything.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.