ART partition for Netgear WNR2000v1

I wouldn't agree with this statement, in particular because there's a difference between sufficient, but low-end devices and those (like this one) which are below the bar. With 4/32 devices you don't really get into the learning phase, as you're hitting the wall (unfixable flash/ RAM limits) way too early (adblock, not enough RAM, VPN, neither enough flash, nor RAM, ...).

1 Like

Hi slh,

For me it was a good chance to learn about bootloader, about router's partitions and serial console pins assignment and many other things specific to routers. As a result I managed to install latest version of openwrt on this 4/32 router, installed adblock and everything works fine. Right now I use an Tplink 1900 router that now I get the courage to update it's firmware to openwrt or ddwrt, exactly because I already exercised on this "bellow the bar" device.

On the other hand, do you have a flash dump for this router?


Hi danut,

I bumped in the same problem, the prices for a second hand one is almost the price of a new one....

In amsterdam i found one
total cost will be about 17€ to get it home.

One day I will find one in a bin somewhere. Of course this time I'll take a backup from the U boot.


1 Like

The links missing in my previous post, wlEmoticon-smile[1].png

Hi smart,

I already downloaded them from the first links. These two are the same. Let's let the time to say the word. Maybe someone will come up with these original partitions.


Hi Danut,

found another u-boot bin with different CRC32, the file is smaller too.

but both files have the same version (Jan 13 2011 - 13:00:15).

I believe they are same the difference is due to trailing FF’s.

you never know you find a difference, I didn’t so far

latest upload:

Name: u-boot.bin

Size: 210100 bytes (205 KiB)


(Name: u-boot.orig.bin

Size: 262144 bytes (256 KiB)

CRC32: D387E475)


Hi smart,

Yes indeed, you are right their content is the same for bought and the difference is due to the trailing FF's. And these two are the same with fuhry u-boot version. We should try to find the original version of u-boot from 14 May 2008 according to the putty log file from the original u-boot on my router.

Hi Danut,

  1. The file

Hi found this router on second hand marked (see picture)

I understood he is prepared to sell for 10€, I understood.

It looks exactly the same as my WNR2000V1, Please confirm it is the same as yours,

then I will buy and you will get finally the the original u-boot back

Unfortunately that person is abroad and he can’t return at home due to Corona Crisis

I have to wait, but I keep you informed, it could take some month’s I’m afraid.

  1. Art partition

I tried your original art partition with success! many thanks for sharing your mac!

  1. I “played” a bit more with the WNR2000V1 and the tiny releases you documented about (I avoid the word “learning”, since that seems to offend people, wlEmoticon-smile[1].png).

Are you sure these are working: I have no space left to save my configuration...(known 4/32 issue...)

I want just use this router only to connect to an hotspot (needs wpad instead of wpad-mini) and due lack of space I can’t achieve saving the config...

Fuhry build such a version long ago but dnsmasq fails in that very old version (backfire).


Hi smart,

In the first hand I cheeked right now and only the Backfire and LEDEv16 keep the user settings, the other versions I have to check them later, but I think the problem is as you said, lack of space for user settings.

In the second hand I managed to put back the original NETGEAR firmware using fuhry u-boot and a tftp connection. I followed these steps:
1 - I downloaded the latest firmware file ( from here
2 - I placed it in the folder Test for Tftpd64 and opened a serial connection
4 - I erased everything from 0x040000 to 0x3f0000
--- erase 0xbf040000 +0x3b0000
6 - I followed the

The router will reboot and will start normally. The login page is on with admin/password as default login credentials.


In your case, you'll have to change the MAC for both WAN and LAN interfaces which is specified on the router case (for WAN the MAC is with one unit bigger 34 for LAN and 35 for WAN in my router's case), and to do that you have to edit the files ART.bin in a hexeditor and make changes to the following offsets:

  • 0x1000 xx:xx:xx:xx:xx for LAN
  • 0x1006 xx:xx:xx:xx:xx for WAN
  • 0x120c xx:xx:xx:xx:xx for LAN

You'll have to rewrite the ART partition with the next stpes:

  • tftpboot 0x81000000 name-of-modified-art-partition.bin
  • cp.b 0x81000000 0xbf3f0000

Btw, taking into account that I have a functional router with the latest original Netgear firmware installed, I don't think I need to buy another router. In my opinion the problem is fixed.


Hi danut,

Seems we have lot’s of fun with this old router, wlEmoticon-smile[1].png

  1. I already loaded stockfirmware from netgear, some days ago, just to check if the old u-boot is popping up again (wishfull thinking of course). So there is no need for the older U-boot, ok.

  2. FYI

Only Lede 16 had room enough on your list, but it had other issues (tab sofware was missing in luci and no downloads found on the site).

I have however also BB, CC, and yes DD booting up and saving the config. But they all have issues somewhere and in common that there is no room to replace Wpad-min by his big brother.

  1. I changed mac in the /etc/config/wireless but the radio was not happy about that. so thanks for the info about where to change the mac in the art partition but I’m quite sure that checksums need to be altered too ( see radenger’s posts). As long as I don’t know where these are located in the file I can’t complete Radengers instructions to get it working too.


Hi smart,

I managed to change the MAC on all three interfaces, lan, wan and wireless. I changed the last two bytes to "77 77".

For lan and wan the change is simple because there is no crc checksum. The offsets are 0x1004 and 0x1005 (0x3F1004 and 0x3F1005). The wan MAC will automacially cange to a new value whit a unit bigger than what you entered for lan, "77 78" in my case.

For wireless there is a crc checksum and you will have to follow a few more steps as are described here: -

With this explanations I think you can have the router live again.


Hi Danut,

I now changed over to my mac’s
LAN 00 22 3f 91 1d dd (offset in “Art.bin” 0X1000), and indeed there was no checksum.
WAN 00 22 3f 91 1d de (offset in “Art.bin” 0X1006), and indeed there was no checksum.
WLAN 00 22 3f 91 1d dd offset in “Art.bin” 0X120C), and
I got the checksum according
The checksum was located (also) at the offset 0x1202 in “Art.bin”.



so I’m not abusing your mac anymore, wlEmoticon-smile[1].png

thanks for sharing!

1 Like

Hi smart,

That's great! As I said I use this router only for educational purposes, to learn about hardware and software used in routes. It was not my original intention, but now it has become. Now, the latest challenge for me is to compile my own version of u-boot. It is very difficult but even more exciting. I hope to succeed.


Hi Sadang / all,

I'm still playing with this old router, during my attemps to install OpenWrt 19.07.6 I think I've messed up my ART partition because, when I reverted back to version 19.07.2, i cannot longer see wireless interface. Can any of you kindly update the links where I can find an ART partition (or share a new one) to customize with my MAC addresses?

Thanks in advance,

1 Like

Hi andrea,

I managed to solve an identical issue, a while ago.
(danut sent me his art partition and I managed to patch it with my mac)

These are some links regarding the art partition.


1 Like

Hi Andrea,

I updated the download link for that archive which contain all six versions of openwrt. The post name is " [Netgear WNR2000v1 flash full dump]" and it was suggested to you by smart. Hope this will solve your problem.


What else, other than MAC/checksum, is different in ART?

Hi, I need art.backup wnr2000v1 , my art is broken.

Does this link helps?

I tried different versions of OpenWrt, but vlan0 does not work.