ARP requests ignored on Client WiFi connection

An odd and very specific problem on a GL-iNET SFT1200 router running OpenWrt 18.06.

On the router's 2.4 GHz interface (wlan1), I am trying to connect to a WiFi camera adapter, which acts as a WiFi AP with SSID "WIFIAV-HD." Most of my devices connect to this adapter with no issues. Its IP address is fixed as 192.168.99.1. I have no way to change any WiFi parameters on this adapter.

The GL-iNET router is able to connect as a Client to "WIFIAV-HD" and receive an IP address over DHCP. But for some reason, I can't ping the adapter from the router. It appears that the router's ARP requests are going unanswered. The requests are being sent over the right interface (confirmed with tcpdump), but no response.

root@GL-SFT1200:~# arp
IP address       HW type     Flags       HW address            Mask     Device
192.168.8.126    0x1         0x0         00:00:00:00:00:00     *        br-lan
192.168.8.5      0x1         0x2         00:68:eb:8e:d2:53     *        br-lan
192.168.99.1     0x1         0x0         00:00:00:00:00:00     *        wlan1
root@GL-SFT1200:~# tcpdump --interface=wlan1 -n
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wlan1, link-type EN10MB (Ethernet), capture size 262144 bytes
05:11:35.547208 ARP, Request who-has 192.168.99.1 tell 192.168.99.2, length 28
05:11:36.579806 ARP, Request who-has 192.168.99.1 tell 192.168.99.2, length 28
05:11:37.620281 ARP, Request who-has 192.168.99.1 tell 192.168.99.2, length 28
...

I've reset the router to a "clean" configuration, but this didn't help. The router has no trouble acting as a client on other 2.4 GHz networks. And every other device I have has no issues connecting to the camera adapter and pinging it afterwards. Here's my Windows box, pinging away:

C:\WINDOWS\system32>ping 192.168.99.1

Pinging 192.168.99.1 with 32 bytes of data:
Reply from 192.168.99.1: bytes=32 time=1ms TTL=255
Reply from 192.168.99.1: bytes=32 time=1ms TTL=255
Reply from 192.168.99.1: bytes=32 time=1ms TTL=255

Config files below.

/etc/config/wireless:


root@GL-SFT1200:/etc/config# cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option txpower '25'
        option txpower_max '25'
        option channel 'auto'
        option band '5G'
        option hwmode '11a'
        option noscan '0'
        option netisolate '0'
        option max_all_num_sta '64'
        option path 'platform/17800000.wifi-hb'
        option htmode 'VHT80'
        option disabled '0'
        option country 'US'
        option acs_noradar '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option hidden '0'
        option ifname 'wlan0'
        option wpa_group_rekey '36000'
        option isolate '0'
        option group '1'
        option disable_input '0'
        option wps_pushbutton '1'
        option wps_label '0'
        option ssid 'GL-SFT1200-51f-5G'
        option encryption 'psk2'
        option key 'goodlife'
        option disassoc_low_ack '0'
        option wds '1'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option txpower '20'
        option txpower_max '20'
        option band '2.4G'
        option hwmode '11g'
        option netisolate '0'
        option max_all_num_sta '64'
        option path 'platform/11000000.wifi-lb'
        option htmode 'HT40'
        option country 'US'
        option channel '1'
        option legacy_rates '1'
        option __toggle 'Enable'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option hidden '0'
        option ifname 'wlan1'
        option wpa_group_rekey '36000'
        option isolate '0'
        option group '1'
        option disable_input '0'
        option wps_pushbutton '1'
        option wps_label '0'
        option ssid 'GL-SFT1200-51f'
        option encryption 'psk2'
        option key 'goodlife'
        option wds '1'
        option disassoc_low_ack '0'
        option disabled '1'

config wifi-iface 'guest5g'
        option device 'radio0'
        option network 'guest'
        option mode 'ap'
        option wds '1'
        option ssid 'GL-SFT1200-51f-Guest-5G'
        option encryption 'psk2'
        option key 'goodlife'
        option ifname 'wlan2'
        option disabled '1'
        option guest '1'
        option disassoc_low_ack '0'

config wifi-iface 'guest2g'
        option device 'radio1'
        option network 'guest'
        option mode 'ap'
        option wds '1'
        option ssid 'GL-SFT1200-51f-Guest'
        option encryption 'psk2'
        option key 'goodlife'
        option ifname 'wlan3'
        option disabled '1'
        option guest '1'
        option disassoc_low_ack '0'

config wifi-iface
        option network 'wlan1'
        option ssid 'WIFIAV-HD'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'sta'
        option bssid 'A0:9F:10:E1:16:17'
        option key '12345678'
        option ifname 'wlan1'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:9a50:a6ca::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option hostname 'GL-SFT1200-51f'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '94:83:c4:23:35:20'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option hostname 'GL-SFT1200-51f'
        option ipv6 '0'
        option metric '10'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '94:83:c4:23:35:1f'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option disabled '1'

config interface 'guest'
        option ifname 'guest'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option group '0'
        option forcelink '1'
        option ipaddr '192.168.9.1'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'

config switch_port
        option device 'switch0'
        option port '5'
        option pvid '2'

config interface 'wlan1'
        option proto 'dhcp'

what is the output of ubus call system board?

root@GL-SFT1200:~# ubus call system board
{
        "kernel": "4.14.90",
        "hostname": "GL-SFT1200",
        "system": "MIPS sf19a28",
        "model": "GL-SFT1200",
        "board_name": "glinet,gl-sft1200",
        "release": {
                "distribution": "OpenWrt",
                "version": "LEDE",
                "revision": "r0-d5ed025",
                "codename": "",
                "target": "siflower\/sf19a28-fullmask",
                "description": "OpenWrt  18.06"
        }
}

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

Fair enough, psherman, thank you! I thought maybe I was just doing something dumb in my configuration. :upside_down_face:

Probably not you and your config, but it can be hard to know for sure because GL-inet's custom forks behave differently than official OpenWrt.

2 Likes