ARP is "stuck" with no response from OpenWRT

Network diagram

Running OpenWrt v23.05.3 on APU2 (x86-64), client PC connected to the router via ethernet.

OpenWRT has its default DHCP server enabled and it is the only DHCP server on this subnet.

At random, workstation client stops receiving packets with the following ARP requests being the only visible packets:

The same situation is observed on the OpenWRT side:

$ tcpdump -i eth1
tcpdump: verbose output suppressed, use -v[v]... for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), snapshot length 262144 bytes
00:00:32.000217 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28
00:00:33.040211 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28
00:00:35.734043 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28
00:00:36.800214 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28
00:00:37.840218 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28
00:00:40.556024 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28
00:00:41.600211 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28
00:00:42.640220 ARP, Request who-has PC.home.arpa tell OpenWRT.home.arpa, length 28

OpenWRT router has the correct ARP record:

IP address       HW type     Flags       HW address            Mask     Device
192.168.2.183    0x1         0x0         MY:MA:CA:DD:RE:SS     *        br-lan

...and the routing table:

default via 192.168.1.1 dev eth0  src 192.168.1.253 
192.168.1.0/24 dev eth0 scope link  src 192.168.1.253 
192.168.2.0/24 dev br-lan scope link  src 192.168.2.1

...and DHCP lease for the workstation client:

However, there is an odd record in the "IPv4 neighbours" section:

The issue looks similar to this topic which doesn't have a solution.

Any ideas?

Hi, Still no fix, having the same issue since moving to 23.X.Y. Tried multiple thing, moving wifi mutlicast to unicast, had a script to modify the forwarding table, etc. none of them worked. One thing I did not try yet is what if I remove the bridge devices and set VLANs on the individual lan ports. I saw someone mentioning it and claimed it worked. There is a long github issue on this: https://github.com/openwrt/openwrt/issues/11650

1 Like

In my case the client is connected via Ethernet, so this is not specific to wireless interfaces.

Sounds like amputating itching finger. Might resolve the problem, but negative implications outweigh the benefits.

Does openwrt receive any packets? Does it resolve by pinging client from openwrt?

Oh ok, then it might be a different problem. For me it only impacts device that I move in my house and it gets connected to different devices... I am not sure about your bridge to individual lan port comment. In my case all ports on the router set as trunk ports, have two VLANs on each so I don't see much impact. Can you please elaborate, i might be missing something in which case i may not even start.

@brada4, I have edited the original post adding all the relevant details. Pinging client from the router is impossible in this state, the packets do not return anything.

This seems like bridge arp proxy gets record stuck for this MAC being in that network port.