Armor Z2 Luci Hangs on Overview and Wireless Screens

I have been compiling my own version of the latest snapshot for the Armor Z2 since just before Christmas and initially it worked just fine, but recently I have found that when I compile it I am unable to see the Overview screen because it just times out and complains about an XHR error and forces me to login.

I have eventually discovered that if the WiFi is disabled it works just fine, but as soon as the WiFi is enabled I get this problem again.

I have done a complete reset of the configuration and gone back to the default and found that I get exactly the same problem, so it isn't any sort of specific configuration.

Reset to default configuration and I can login and see Luci, enable the WiFi and it immediately stops working and timing out on the overview screen and the wireless screen, albeit that some other pages do still work.

I don't have this problem with snapshot firmware for other devices, so it appears to be specific to the Armor Z2.

Powered by LuCI Master (git-20.033.77428-3d63732) / OpenWrt SNAPSHOT r12170-3b99d67639

Retry with a new build after the following commands:

make package/rpcd/clean
make package/libubox/clean
make package/iwinfo/clean
make package/rpcd-mod-luci/clean
make world
1 Like

I would like to thank you for the suggestion which worked a treat, weeks of tearing my hair out trying to work out why it wouldn't work have now ended!

If you want to say thank you -> click the "Thumbs up" button below jows posting :slight_smile:

And if his posting solved your problem, you can mark it as solution -> See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.