Arm64 (or armvirt) with UEFI boot?


Im trying to boot openwrt on an arm64 UEFI environment (proxmox on rPi4) so I went through the thread below but I think Im missing something as the built image wont boot.

I pushed to target/linux/armvirt/config-5.4


and even this (that is suggested at some point):


But the resulted rootfs img converted to qcow2 wont boot.

@statto99 provided a VM HD for EXSI but its not proxmox compatible.

Any ideas?? I might be missing something obvious..

You may be interested in this PR.


Time for another make world :slight_smile:

the PR worked great on Proxmox-arm64 (Pi 4).
Boots like a charm with console on serial.


@daemonix, If feasible can you share the complied image? I have similar case of yours.

sure I can!
Im not openwrt veteran but I think you might be better with compiling your own as Im in the process of adding more packages.
For example my image is for atheros wifi cards only. (Ill try to build all packages as modules today... if it works...)

Test it and let me know. I can help you compile you own if you have a bit of knowledge.

1 Like

For proxmox:

qemu-img convert -f raw -O qcow2 XXXXXX

qm importdisk vm_id vmdisk_name storage

I built all packages:

1 Like

@daemonix Thank you very much.

openwrt-arm64-efi-generic-ext4-combined.img.gz works like a charm on my PiMox :slight_smile: Seems like you have complied with all the packages (more than I need) and all my scenarios are covered.

But irrespectively, would be great if you can guide me how to compile myself. And did you figure out the qemu agent stuff, shutdown/restart is not working on the image, and it takes long to reboot proxmox.

I haven’t even tried qemu agent. Did you check my full list of built packages?

Whats your main OS? For building your own I mean.
Im more of a macos/linux guy but I build mine on a win11 with WSL2 because it is a cpu beast :slight_smile:

Yes, checked the full package list. But I am good with what it is already in your image.

I have all type of environments available (WSL, Mac, Linux). Just need help to Kickstart how to compile openwrt.

I pushed the code I used and the config file on:

on a vanilla debian VM:

sudo apt update
sudo apt install build-essential ccache ecj fastjar file g++ gawk \
gettext git java-propose-classpath libelf-dev libncurses5-dev \
libncursesw5-dev libssl-dev python python2.7-dev python3 unzip wget \
python3-distutils python3-setuptools python3-dev rsync subversion \
swig time xsltproc zlib1g-dev 

then clone my repo and:

move/copy my config to ".config"

./scripts/feeds update -a
./scripts/feeds install -a

make defconfig
make download
make -j8 world

let me know.

edit: -j8 is the number of threads your CPU has. sometimes we add some on top. Like on the 5950x 32 thread I do -j34 just to saturate it a bit more during workload switching.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.