Aria2 - impossible to run it

Hello,

I'm new on openwrt. I install Aria2 and Aria2-luci via Luci.
I modify the path to have a correct download path but i don't manage to run aria2. I get this on the log:

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: GENERAL_NAMES_free: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: SSL_get_peer_certificate: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: ASN1_STRING_data: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: BN_CTX_new: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: RAND_bytes: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: ERR_error_string: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: ASN1_STRING_to_UTF8: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: sk_value: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: BN_CTX_free: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: SSL_get_error: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: SSL_CTX_use_PrivateKey: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: EVP_DigestInit_ex: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: EC_KEY_free: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: X509_NAME_get_index_by_NID: symbol not found

Tue Jul 2 09:57:59 2024 daemon.err aria2c[23077]: Error relocating /usr/bin/aria2c: SSL_CTX_free: symbol not found

Can you please help me?
Thank you in advance

start by posting the output of

ubus call system board

Here you go:
root@GL-MT300N-V2:~# ubus call system board
{
"kernel": "4.14.63",
"hostname": "GL-MT300N-V2",
"system": "MediaTek MT7628AN ver:1 eco:2",
"model": "GL-MT300N-V2",
"board_name": "gl-mt300n-v2",
"release": {
"distribution": "OpenWrt",
"version": "18.06.1",
"revision": "r7258-5eb055306f",
"target": "ramips/mt76x8",
"description": "OpenWrt 18.06.1 r7258-5eb055306f"
}

you should really upgrade, that release is 6 years old.

https://firmware-selector.openwrt.org/?version=23.05.3&target=ramips%2Fmt76x8&id=glinet_gl-mt300n-v2

2 Likes